summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-26 15:23:43 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-26 15:23:43 +0000
commitaca5b63d91a56fe6e37bce4d76f91f30f30f4046 (patch)
tree02d8815bccdbd0ad4eebfffd289745cbd6d6e891 /sci-libs/itpp
parentsci-libs/ogdi: Drop unnessecary die (diff)
downloadhistorical-aca5b63d91a56fe6e37bce4d76f91f30f30f4046.tar.gz
historical-aca5b63d91a56fe6e37bce4d76f91f30f30f4046.tar.bz2
historical-aca5b63d91a56fe6e37bce4d76f91f30f30f4046.zip
sci-libs/itpp: Drop unnessecary die, add LICENSE
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog5
-rw-r--r--sci-libs/itpp/itpp-4.0.6.ebuild30
-rw-r--r--sci-libs/itpp/metadata.xml4
3 files changed, 22 insertions, 17 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index f17e22a67cdf..23706f4dbff3 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.109 2012/03/08 23:09:54 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.110 2012/04/26 15:23:43 jlec Exp $
+
+ 26 Apr 2012; Justin Lecher <jlec@gentoo.org> itpp-4.0.6.ebuild, metadata.xml:
+ Drop unnessecary die, add LICENSE
08 Mar 2012; Brent Baude <ranger@gentoo.org> itpp-4.2-r1.ebuild:
Marking itpp-4.2-r1 ppc64 for bug 394037
diff --git a/sci-libs/itpp/itpp-4.0.6.ebuild b/sci-libs/itpp/itpp-4.0.6.ebuild
index b358b63bcaa1..ee0ba1b01598 100644
--- a/sci-libs/itpp/itpp-4.0.6.ebuild
+++ b/sci-libs/itpp/itpp-4.0.6.ebuild
@@ -1,28 +1,31 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.9 2012/02/05 17:40:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.10 2012/04/26 15:23:43 jlec Exp $
inherit flag-o-matic
-# we need this to prevent itpp's specialized debug lib
-# (built with USE="debug" set) from being stripped
-RESTRICT="strip"
-
-DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
-LICENSE="GPL-2"
+DESCRIPTION="C++ library of mathematical, signal processing and communication"
HOMEPAGE="http://itpp.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
SLOT="0"
+LICENSE="GPL-3"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE="blas debug doc fftw lapack minimal"
-RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
- blas? ( virtual/blas
- lapack? ( virtual/lapack ) )"
+RDEPEND="
+ !minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
+ blas? (
+ virtual/blas
+ lapack? ( virtual/lapack ) )"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen
- virtual/latex-base )"
+ doc? (
+ app-doc/doxygen
+ virtual/latex-base )"
+
+# we need this to prevent itpp's specialized debug lib
+# (built with USE="debug" set) from being stripped
+RESTRICT="strip"
pkg_setup() {
# lapack can only be used in conjunction with blas
@@ -73,8 +76,7 @@ src_compile() {
"${blas_conf}" \
"${lapack_conf}" \
"${fftw_conf}" \
- ${myconf} \
- || die "econf failed"
+ ${myconf}
emake || die "emake failed"
}
diff --git a/sci-libs/itpp/metadata.xml b/sci-libs/itpp/metadata.xml
index d75e91bb2432..44d71c60f368 100644
--- a/sci-libs/itpp/metadata.xml
+++ b/sci-libs/itpp/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang='en'>
+ <herd>sci</herd>
+ <longdescription lang="en">
IT++ is a C++ library of mathematical, signal processing and
communication classes and functions. Its main use is in simulation
of communication systems and for performing research in the area of