summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-30 16:44:17 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-30 16:44:17 +0000
commitbc8ae86b4c31748e2ae1c85bbfd8f935bdea666a (patch)
tree1b02a72728ab6b857f0567ad91dbb0a3352dd38f /sci-libs/hdf5/files
parentAdd new snapshot wrt bug #417747. (diff)
downloadhistorical-bc8ae86b4c31748e2ae1c85bbfd8f935bdea666a.tar.gz
historical-bc8ae86b4c31748e2ae1c85bbfd8f935bdea666a.tar.bz2
historical-bc8ae86b4c31748e2ae1c85bbfd8f935bdea666a.zip
Version bump
Package-Manager: portage-2.2.0_alpha108/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/hdf5/files')
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.9-implicits.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/hdf5/files/hdf5-1.8.9-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.9-implicits.patch
new file mode 100644
index 000000000000..43e4f0774a29
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.9-implicits.patch
@@ -0,0 +1,55 @@
+--- b/configure.in
++++ a/configure.in
+@@ -1499,6 +1499,9 @@
+ dnl though we do not do this as it breaks the big test on older versions
+ dnl of linux (CentOS 4.6) using newer versions of gcc (4.6.2).
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ dnl _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
+--- a/test/cache_common.h
++++ b/test/cache_common.h
+@@ -702,5 +702,9 @@
+ hbool_t compare_init,
+ int test_num);
+
++hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
++ const H5C_auto_size_ctl_t *b,
++ hbool_t compare_init);
++
+ #endif /* _CACHE_COMMON_H */
+
+--- a/tools/misc/talign.c
++++ b/tools/misc/talign.c
+@@ -23,6 +23,7 @@
+
+ #include "hdf5.h"
+ #include "H5private.h"
++#include "h5tools.h"
+
+ const char *fname = "talign.h5";
+ const char *setname = "align";
+--- a/tools/h5repack/testh5repack_detect_szip.c
++++ b/tools/h5repack/testh5repack_detect_szip.c
+@@ -17,6 +17,7 @@
+ #include "h5repack.h"
+ #include "h5tools.h"
+ #include "h5test.h"
++#include "h5tools_utils.h"
+
+
+ /* Name of tool */
+--- a/hl/src/H5LTanalyze.c
++++ b/hl/src/H5LTanalyze.c
+@@ -49,7 +49,8 @@
+ #define YY_FLEX_MINOR_VERSION 5
+
+ #include <stdio.h>
++#include "H5pubconf.h"
+ #ifdef H5_HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+