summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-09 22:08:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-09 22:08:56 +0000
commitca4ef82bdfaaae065bfac6f2f990c9af8c4bde91 (patch)
tree91db49aa34971c98ca23dd30b3ec75fb7cd49787 /sci-libs/blas-goto
parentstable on x86 for bug 195257 (diff)
downloadhistorical-ca4ef82bdfaaae065bfac6f2f990c9af8c4bde91.tar.gz
historical-ca4ef82bdfaaae065bfac6f2f990c9af8c4bde91.tar.bz2
historical-ca4ef82bdfaaae065bfac6f2f990c9af8c4bde91.zip
Removed older versions, get ready for new style virtuals, workaround for
eselect bug #189942. Package-Manager: portage-2.1.3.12
Diffstat (limited to 'sci-libs/blas-goto')
-rw-r--r--sci-libs/blas-goto/ChangeLog7
-rw-r--r--sci-libs/blas-goto/blas-goto-1.14.ebuild144
-rw-r--r--sci-libs/blas-goto/blas-goto-1.16.ebuild144
-rw-r--r--sci-libs/blas-goto/blas-goto-1.19.ebuild24
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.143
-rw-r--r--sci-libs/blas-goto/files/digest-blas-goto-1.163
-rw-r--r--sci-libs/blas-goto/files/eselect-goto3
7 files changed, 22 insertions, 306 deletions
diff --git a/sci-libs/blas-goto/ChangeLog b/sci-libs/blas-goto/ChangeLog
index 08932a0765ca..ec9be534ca50 100644
--- a/sci-libs/blas-goto/ChangeLog
+++ b/sci-libs/blas-goto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/blas-goto
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.11 2007/09/21 06:39:37 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/ChangeLog,v 1.12 2007/10/09 22:08:56 bicatali Exp $
+
+ 09 Oct 2007; SĂ©bastien Fabbro <bicatali@gentoo.org> -files/eselect-goto,
+ -blas-goto-1.14.ebuild, -blas-goto-1.16.ebuild, blas-goto-1.19.ebuild:
+ Removed older versions, get ready for new style virtuals, workaround for
+ eselect bug #189942.
21 Sep 2007; Donnie Berkholz <dberkholz@gentoo.org>;
blas-goto-1.19.ebuild:
diff --git a/sci-libs/blas-goto/blas-goto-1.14.ebuild b/sci-libs/blas-goto/blas-goto-1.14.ebuild
deleted file mode 100644
index 8a0078ce451d..000000000000
--- a/sci-libs/blas-goto/blas-goto-1.14.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.14.ebuild,v 1.3 2007/08/19 00:30:51 markusle Exp $
-
-inherit eutils fortran flag-o-matic toolchain-funcs
-
-MY_PN="GotoBLAS"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
-HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
-SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
-LICENSE="tacc"
-SLOT="0"
-# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
-# for supported architectures
-KEYWORDS="~x86 ~amd64"
-IUSE="threads"
-RESTRICT="mirror"
-RDEPEND="app-admin/eselect-blas"
-
-DEPEND="${RDEPEND}
- >=sys-devel/binutils-2.17"
-
-S="${WORKDIR}/${MY_PN}"
-FORTRAN="g77 gfortran" # ifc g95 pgf77 pathf90 f90 f77
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Set up C compiler
- if [[ $(tc-getCC) = *gcc ]]; then
- C_COMPILER="GNU"
- elif [[ $(tc-getCC) = icc ]]; then
- C_COMPILER="INTEL"
- else
- die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
- fi
-
- # Set up Fortran compiler
- if [[ ${FORTRANC} = g77 ]]; then
- F_COMPILER="G77"
- elif [[ ${FORTRANC} = gfortran ]]; then
- F_COMPILER="GFORTRAN"
- # Otherwise, we get undefined reference to _gfortran_runtime_error
- FORTRAN_LIB="-lgfortran"
-# elif [[ ${FORTRANC} = ifc ]]; then
-# F_COMPILER="INTEL"
-# elif [[ ${FORTRANC} = g95 ]]; then
-# F_COMPILER="G95"
-# elif [[ ${FORTRANC} = pgf77 ]]; then
-# F_COMPILER="PGI"
-# elif [[ ${FORTRANC} = pathf90 ]]; then
-# F_COMPILER="PATHSCALE"
-# elif [[ ${FORTRANC} = f90 ]] || [[ ${FORTRANC} = f77 ]]; then
-# F_COMPILER="SUN"
-# elif [[ ${FORTRANC} = xlf ]]; then
-# F_COMPILER="IBM"
- else
- die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
- fi
-
- # Fix shared lib build
- sed -i \
- -e "s:\(&& echo OK\):${FORTRAN_LIB} \1:g" \
- "${S}"/exports/Makefile
-
- # Set up compilers
- sed -i \
- -e "s:^\(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
- -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
- -e "s:^# \(SMP = 1\):\1:g" \
- -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
- -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
- -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
- -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
- "${S}"/Makefile.rule
-
- # Threaded?
- if use threads; then
- sed -i \
- -e "s:^# \(SMP = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # If you need a 64-bit binary
- # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
- if use amd64; then
- sed -i \
- -e "s:^# \(BINARY64 = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # Respect CFLAGS/FFLAGS
- sed -i \
- -e "/^COMMON_OPT += -O2$/d" \
- "${S}"/Makefile.rule
- sed -i \
- -e "s:^\(CCOMMON_OPT += -D_GNU_SOURCE\)$:\1 ${CFLAGS}:g" \
- -e "s:^\(FCOMMON_OPT +=\)$:\1 ${FFLAGS:- -O2}:g" \
- "${S}"/Makefile.rule
-}
-
-src_compile() {
-
- # Make static library
- emake || die "emake failed"
-
- # Make shared library
- cd exports
- emake so -j1 || die "emake failed"
-}
-
-src_test() {
- cd test
- emake || die "emake test failed"
-}
-
-src_install() {
- local MAIN_DIR="/usr/$(get_libdir)/blas"
- local DIR="${MAIN_DIR}/goto"
-
- # dolib.so doesn't support our alternate locations
- exeinto ${DIR}
- doexe libgoto_*.so
- dosym libgoto_*.so ${DIR}/libgoto.so
- dosym libgoto_*.so ${DIR}/libgoto.so.0
- dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
-
- # dolib.a doesn't support our alternate locations
- insinto ${DIR}
- doins libgoto_*.a
- dosym libgoto_*.a ${DIR}/libgoto.a
-
- dodoc 01Readme.txt 03History.txt 04FAQ.txt
-
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect-goto goto
-}
-
-pkg_postinst() {
- if [[ -z $(eselect blas show) ]]; then
- eselect blas set goto
- fi
-}
diff --git a/sci-libs/blas-goto/blas-goto-1.16.ebuild b/sci-libs/blas-goto/blas-goto-1.16.ebuild
deleted file mode 100644
index 6ef45faa93dd..000000000000
--- a/sci-libs/blas-goto/blas-goto-1.16.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.16.ebuild,v 1.1 2007/08/20 13:42:22 markusle Exp $
-
-inherit eutils fortran flag-o-matic toolchain-funcs
-
-MY_PN="GotoBLAS"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="The fastest implementations of the Basic Linear Algebra Subroutines"
-HOMEPAGE="http://www.tacc.utexas.edu/resources/software/software.php"
-SRC_URI="http://www.tacc.utexas.edu/resources/software/login/gotoblas/${MY_P}.tar.gz"
-LICENSE="tacc"
-SLOT="0"
-# See http://www.tacc.utexas.edu/resources/software/gotoblasfaq.php
-# for supported architectures
-KEYWORDS="~x86 ~amd64"
-IUSE="threads"
-RESTRICT="mirror"
-RDEPEND="app-admin/eselect-blas"
-
-DEPEND="${RDEPEND}
- >=sys-devel/binutils-2.17"
-
-S="${WORKDIR}/${MY_PN}"
-FORTRAN="g77 gfortran" # ifc g95 pgf77 pathf90 f90 f77
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Set up C compiler
- if [[ $(tc-getCC) = *gcc ]]; then
- C_COMPILER="GNU"
- elif [[ $(tc-getCC) = icc ]]; then
- C_COMPILER="INTEL"
- else
- die "tc-getCC() returned an invalid C compiler; valid are gcc or icc."
- fi
-
- # Set up Fortran compiler
- if [[ ${FORTRANC} = g77 ]]; then
- F_COMPILER="G77"
- elif [[ ${FORTRANC} = gfortran ]]; then
- F_COMPILER="GFORTRAN"
- # Otherwise, we get undefined reference to _gfortran_runtime_error
- FORTRAN_LIB="-lgfortran"
-# elif [[ ${FORTRANC} = ifc ]]; then
-# F_COMPILER="INTEL"
-# elif [[ ${FORTRANC} = g95 ]]; then
-# F_COMPILER="G95"
-# elif [[ ${FORTRANC} = pgf77 ]]; then
-# F_COMPILER="PGI"
-# elif [[ ${FORTRANC} = pathf90 ]]; then
-# F_COMPILER="PATHSCALE"
-# elif [[ ${FORTRANC} = f90 ]] || [[ ${FORTRANC} = f77 ]]; then
-# F_COMPILER="SUN"
-# elif [[ ${FORTRANC} = xlf ]]; then
-# F_COMPILER="IBM"
- else
- die "fortran.eclass returned an invalid Fortran compiler \'${FORTRANC}\'; valid are ${FORTRAN}."
- fi
-
- # Fix shared lib build
- sed -i \
- -e "s:\(&& echo OK\):${FORTRAN_LIB} \1:g" \
- "${S}"/exports/Makefile
-
- # Set up compilers
- sed -i \
- -e "s:^\(C_COMPILER =\) GNU:\1 ${C_COMPILER}:g" \
- -e "s:^# \(F_COMPILER =\) G77:\1 ${F_COMPILER}:g" \
- -e "s:^# \(SMP = 1\):\1:g" \
- -e "s:\$(COMPILER_PREFIX)ar:$(tc-getAR):" \
- -e "s:\$(COMPILER_PREFIX)as:$(tc-getAS):" \
- -e "s:\$(COMPILER_PREFIX)ld:$(tc-getLD):" \
- -e "s:\$(COMPILER_PREFIX)ranlib:$(tc-getRANLIB):" \
- "${S}"/Makefile.rule
-
- # Threaded?
- if use threads; then
- sed -i \
- -e "s:^# \(SMP = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # If you need a 64-bit binary
- # If you need a 64-bit integer interface, also do this for "INTERFACE64 = 1"
- if use amd64; then
- sed -i \
- -e "s:^# \(BINARY64 = 1\):\1:g" \
- "${S}"/Makefile.rule
- fi
-
- # Respect CFLAGS/FFLAGS
- sed -i \
- -e "/^COMMON_OPT += -O2$/d" \
- "${S}"/Makefile.rule
- sed -i \
- -e "s:^\(CCOMMON_OPT += -D_GNU_SOURCE\)$:\1 ${CFLAGS}:g" \
- -e "s:^\(FCOMMON_OPT +=\)$:\1 ${FFLAGS:- -O2}:g" \
- "${S}"/Makefile.rule
-}
-
-src_compile() {
-
- # Make static library
- emake || die "emake failed"
-
- # Make shared library
- cd exports
- emake so -j1 || die "emake failed"
-}
-
-src_test() {
- cd test
- emake || die "emake test failed"
-}
-
-src_install() {
- local MAIN_DIR="/usr/$(get_libdir)/blas"
- local DIR="${MAIN_DIR}/goto"
-
- # dolib.so doesn't support our alternate locations
- exeinto ${DIR}
- doexe libgoto_*.so
- dosym libgoto_*.so ${DIR}/libgoto.so
- dosym libgoto_*.so ${DIR}/libgoto.so.0
- dosym libgoto_*.so ${DIR}/libgoto.so.0.0.0
-
- # dolib.a doesn't support our alternate locations
- insinto ${DIR}
- doins libgoto_*.a
- dosym libgoto_*.a ${DIR}/libgoto.a
-
- dodoc 01Readme.txt 03History.txt 04FAQ.txt
-
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect-goto goto
-}
-
-pkg_postinst() {
- if [[ -z $(eselect blas show) ]]; then
- eselect blas set goto
- fi
-}
diff --git a/sci-libs/blas-goto/blas-goto-1.19.ebuild b/sci-libs/blas-goto/blas-goto-1.19.ebuild
index 97266ea67973..90f1e29bf215 100644
--- a/sci-libs/blas-goto/blas-goto-1.19.ebuild
+++ b/sci-libs/blas-goto/blas-goto-1.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.19.ebuild,v 1.2 2007/09/21 06:39:37 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-goto/blas-goto-1.19.ebuild,v 1.3 2007/10/09 22:08:56 bicatali Exp $
inherit eutils fortran flag-o-matic toolchain-funcs
@@ -26,9 +26,6 @@ DEPEND="app-admin/eselect-blas
S="${WORKDIR}/${MY_PN}"
FORTRAN="g77 gfortran ifc"
-# remove when we have new virtuals in main tree.
-PROVIDE="virtual/blas"
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -150,11 +147,22 @@ src_install() {
blas.pc || die "sed blas.pc failed"
insinto /usr/$(get_libdir)/blas/goto
doins blas.pc
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.goto goto
+ ESELECT_PROF=goto
+ eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.goto ${ESELECT_PROF}
}
pkg_postinst() {
- [[ -z "$(eselect blas show)" ]] && eselect blas set goto
- elog "To use BLAS GOTO implementation, you have to issue (as root):"
- elog "\teselect blas set goto\n"
+ local p=blas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${ROOT}"/etc/env.d/${p}/lib/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
}
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.14 b/sci-libs/blas-goto/files/digest-blas-goto-1.14
deleted file mode 100644
index e4e74bf09c78..000000000000
--- a/sci-libs/blas-goto/files/digest-blas-goto-1.14
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4e0bf45fa52178268f7723292c254556 GotoBLAS-1.14.tar.gz 1732821
-RMD160 e3c5def6b23d7cd0f02fb8b9feeae012d90a6b86 GotoBLAS-1.14.tar.gz 1732821
-SHA256 a57b93c554910c0a43dccbc2663611ba15af9c4b539fc73d59aae148dc356eed GotoBLAS-1.14.tar.gz 1732821
diff --git a/sci-libs/blas-goto/files/digest-blas-goto-1.16 b/sci-libs/blas-goto/files/digest-blas-goto-1.16
deleted file mode 100644
index 4bcd0425d105..000000000000
--- a/sci-libs/blas-goto/files/digest-blas-goto-1.16
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fe1489037a3c2d69e7d5b9a05f14bfa9 GotoBLAS-1.16.tar.gz 1783818
-RMD160 416f905cb07a3eaf03c85f4660865393403fe398 GotoBLAS-1.16.tar.gz 1783818
-SHA256 4a490f86648aa26fa1e5bfe4569224c8146d0086db90280eeff279f92cb8cbe5 GotoBLAS-1.16.tar.gz 1783818
diff --git a/sci-libs/blas-goto/files/eselect-goto b/sci-libs/blas-goto/files/eselect-goto
deleted file mode 100644
index ad8fde5a7eca..000000000000
--- a/sci-libs/blas-goto/files/eselect-goto
+++ /dev/null
@@ -1,3 +0,0 @@
-blas/goto/libgoto.so /usr/@LIBDIR@/libblas.so
-blas/goto/libgoto.so.0 /usr/@LIBDIR@/libblas.so.0
-blas/goto/libgoto.a /usr/@LIBDIR@/libblas.a