summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2008-12-24 12:54:17 +0000
committerHanno Boeck <hanno@gentoo.org>2008-12-24 12:54:17 +0000
commita126e584555b109218aaa0e73775067fb0b55c73 (patch)
tree7d86ff85196fb6f3a664472fb22193d6f7dc44cd /sci-geosciences/qlandkarte/qlandkarte-0.7.4.ebuild
parentslotmove x11-themes/metacity-themes-1.1 to slot 0, bug #236226. (diff)
downloadhistorical-a126e584555b109218aaa0e73775067fb0b55c73.tar.gz
historical-a126e584555b109218aaa0e73775067fb0b55c73.tar.bz2
historical-a126e584555b109218aaa0e73775067fb0b55c73.zip
qlandkarte bump
Package-Manager: portage-2.2_rc18/cvs/Linux 2.6.28-rc9 x86_64
Diffstat (limited to 'sci-geosciences/qlandkarte/qlandkarte-0.7.4.ebuild')
-rw-r--r--sci-geosciences/qlandkarte/qlandkarte-0.7.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-geosciences/qlandkarte/qlandkarte-0.7.4.ebuild b/sci-geosciences/qlandkarte/qlandkarte-0.7.4.ebuild
new file mode 100644
index 000000000000..6733f63b204d
--- /dev/null
+++ b/sci-geosciences/qlandkarte/qlandkarte-0.7.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qlandkarte/qlandkarte-0.7.4.ebuild,v 1.1 2008/12/24 12:54:17 hanno Exp $
+
+inherit autotools eutils qt4
+
+EAPI="1"
+
+DESCRIPTION="View and upload map files, track and waypoint data to your Garmin GPS."
+HOMEPAGE="http://qlandkarte.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/QLandkarte_final.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="|| ( ( x11-libs/qt-core:4 x11-libs/qt-gui:4 ) =x11-libs/qt-4.3* )
+ sci-libs/proj
+ dev-libs/libusb"
+
+S="${WORKDIR}/QLandkarte_final"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+ econf || die "econf failed"
+ eqmake4 QLandkarte.pro || die "eqmake4 failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "install failed"
+}