summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-05-26 20:57:56 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-05-26 20:57:56 +0000
commit478d46cfa74d8b50e5e36adce3812e78703a2ce6 (patch)
treed4bda5e546433f1a97e4ad5e5d085dd60e49ec0e /sci-electronics/ng-spice-rework/ng-spice-rework-17-r2.ebuild
parentFixing the grsecurity patch, had one '};' too much. (diff)
downloadhistorical-478d46cfa74d8b50e5e36adce3812e78703a2ce6.tar.gz
historical-478d46cfa74d8b50e5e36adce3812e78703a2ce6.tar.bz2
historical-478d46cfa74d8b50e5e36adce3812e78703a2ce6.zip
Enabled xspice and intnoise after testing them, which closes bug #140402. Added optional ngspice and xspice documentation. Fixed X dependencies and made them optional. Fixed collision with external xgraph. Fixed debug messing with compilation optimizations. Made debug even more chatty.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'sci-electronics/ng-spice-rework/ng-spice-rework-17-r2.ebuild')
-rw-r--r--sci-electronics/ng-spice-rework/ng-spice-rework-17-r2.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/sci-electronics/ng-spice-rework/ng-spice-rework-17-r2.ebuild b/sci-electronics/ng-spice-rework/ng-spice-rework-17-r2.ebuild
new file mode 100644
index 000000000000..bdfa926adc41
--- /dev/null
+++ b/sci-electronics/ng-spice-rework/ng-spice-rework-17-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ng-spice-rework-17-r2.ebuild,v 1.1 2007/05/26 20:57:56 calchan Exp $
+
+inherit eutils
+
+DESCRIPTION="The Next Generation Spice (Electronic Circuit Simulator)."
+SRC_URI="mirror://sourceforge/ngspice/${P}.tar.gz
+ doc? ( http://users.ece.gatech.edu/~mrichard/Xspice/Xspice_Users_Manual.pdf \
+ http://users.ece.gatech.edu/~mrichard/Xspice/XSpice_SoftwareDesignDoc_Sep92.pdf \
+ http://users.ece.gatech.edu/~mrichard/Xspice/XSpice_InterfaceDesignDoc_Sep92.pdf \
+ http://users.ece.gatech.edu/~mrichard/Xspice/XSpice_CodeModelSubsysSoftwareDesign.pdf \
+ http://users.ece.gatech.edu/~mrichard/Xspice/XSpice_CodeModelSubsysInterfaceDesign.pdf )"
+HOMEPAGE="http://ngspice.sourceforge.net"
+LICENSE="BSD GPL-2"
+
+SLOT="0"
+IUSE="X debug doc readline"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="readline? ( >=sys-libs/readline-5.0 )
+ X? ( x11-libs/libXaw
+ x11-libs/libXt
+ x11-libs/libX11
+ sci-visualization/xgraph )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-com_let.patch
+ epatch ${FILESDIR}/${PN}-numparam.patch
+ epatch ${FILESDIR}/${PN}-pipemode.patch
+ epatch ${FILESDIR}/${PN}-postscript.patch
+ sed -i -e 's/CFLAGS=" "/CFLAGS="\${CFLAGS}"/' configure
+ if use doc ; then
+ cp ${DISTDIR}/Xspice_Users_Manual.pdf ${S}
+ cp ${DISTDIR}/XSpice_SoftwareDesignDoc_Sep92.pdf ${S}
+ cp ${DISTDIR}/XSpice_InterfaceDesignDoc_Sep92.pdf ${S}
+ cp ${DISTDIR}/XSpice_CodeModelSubsysSoftwareDesign.pdf ${S}
+ cp ${DISTDIR}/XSpice_CodeModelSubsysInterfaceDesign.pdf ${S}
+ fi
+}
+
+src_compile() {
+ local MYCONF
+ if use debug ; then
+ MYCONF="--enable-debug \
+ --enable-ftedebug \
+ --enable-cpdebug \
+ --enable-asdebug \
+ --enable-stepdebug \
+ --enable-pzdebug"
+ else
+ MYCONF="--disable-debug \
+ --disable-ftedebug \
+ --disable-cpdebug \
+ --disable-asdebug \
+ --disable-stepdebug \
+ --disable-pzdebug"
+ fi
+ # Those don't compile
+ MYCONF="${MYCONF} \
+ --disable-sensdebug \
+ --disable-blktmsdebug \
+ --disable-smltmsdebug"
+
+ econf ${MYCONF} \
+ --enable-intnoise \
+ --enable-xspice \
+ --enable-numparam \
+ --enable-dot-global \
+ --disable-xgraph \
+ --disable-dependency-tracking \
+ $(use_with X x) \
+ $(use_with readline) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ local infoFile
+ for infoFile in doc/ngspice.info*; do
+ echo 'INFO-DIR-SECTION EDA' >> ${infoFile}
+ echo 'START-INFO-DIR-ENTRY' >> ${infoFile}
+ echo '* NGSPICE: (ngspice). Electronic Circuit Simulator.' >> ${infoFile}
+ echo 'END-INFO-DIR-ENTRY' >> ${infoFile}
+ done
+
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ANALYSES AUTHORS BUGS ChangeLog DEVICES NEWS \
+ README Stuarts_Poly_Notes || die "failed to install documentation"
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins doc/ngspice.pdf
+ doins *.pdf
+ fi
+
+ # We don't need makeidx to be installed
+ rm ${D}/usr/bin/makeidx
+}
+
+src_test () {
+ # Bug 108405
+ true
+}