summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:41:27 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:41:27 +0000
commit71299d22e19acb1d802f0e5784f6f36bb02689e9 (patch)
treee057bb39e241d76417d822b344bf8fdbcebfeb0c /sci-chemistry
parentAdded fortran-2.eclass support (diff)
downloadhistorical-71299d22e19acb1d802f0e5784f6f36bb02689e9.tar.gz
historical-71299d22e19acb1d802f0e5784f6f36bb02689e9.tar.bz2
historical-71299d22e19acb1d802f0e5784f6f36bb02689e9.zip
Added fortran-2.eclass support
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild7
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r1.ebuild5
-rw-r--r--sci-chemistry/apbs/apbs-1.3.ebuild5
-rw-r--r--sci-chemistry/ccp4-apps/ChangeLog6
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild7
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild5
-rw-r--r--sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild5
8 files changed, 30 insertions, 16 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index c46749d87ef7..d4a72b5752bd 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.46 2011/04/16 07:54:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.47 2011/06/21 08:41:13 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
+ apbs-1.3.ebuild, apbs-1.3-r1.ebuild:
+ Added fortran-2.eclass support
16 Apr 2011; Justin Lecher <jlec@gentoo.org> apbs-1.3.ebuild,
apbs-1.3-r1.ebuild:
diff --git a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
index 1e8a5af64d69..52723ffd9f78 100644
--- a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
+++ b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.9 2010/12/16 08:55:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.10 2011/06/21 08:41:13 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
+ fortran-2_pkg_setup
use python && python_set_active_version 2
}
diff --git a/sci-chemistry/apbs/apbs-1.3-r1.ebuild b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
index 0bb9066cd862..a18c4459275e 100644
--- a/sci-chemistry/apbs/apbs-1.3-r1.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.3 2011/04/16 07:54:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.4 2011/06/21 08:41:13 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -36,6 +36,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
+ fortran-2_pkg_setup
use python && python_set_active_version 2
if use mpi && use python; then
einfo "mpi and python support are incompatible"
diff --git a/sci-chemistry/apbs/apbs-1.3.ebuild b/sci-chemistry/apbs/apbs-1.3.ebuild
index 97ac9f5fdf3f..cb0f92b7bee9 100644
--- a/sci-chemistry/apbs/apbs-1.3.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.5 2011/04/16 07:54:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.6 2011/06/21 08:41:13 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -36,6 +36,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
+ fortran-2_pkg_setup
use python && python_set_active_version 2
if use mpi && use python; then
einfo "mpi and python support are incompatible"
diff --git a/sci-chemistry/ccp4-apps/ChangeLog b/sci-chemistry/ccp4-apps/ChangeLog
index 837199428582..1f1f88c2804f 100644
--- a/sci-chemistry/ccp4-apps/ChangeLog
+++ b/sci-chemistry/ccp4-apps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/ccp4-apps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.25 2011/03/14 17:06:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ChangeLog,v 1.26 2011/06/21 08:41:27 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> ccp4-apps-6.1.3-r7.ebuild,
+ ccp4-apps-6.1.3-r8.ebuild, ccp4-apps-6.1.3-r9.ebuild:
+ Added fortran-2.eclass support
14 Mar 2011; Justin Lecher <jlec@gentoo.org> +files/6.1.3-lapack.patch,
ccp4-apps-6.1.3-r9.ebuild:
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild
index 579bdc4b4401..ed78231d8d65 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild,v 1.2 2011/03/02 17:53:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r7.ebuild,v 1.3 2011/06/21 08:41:27 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit autotools eutils flag-o-matic gnuconfig python toolchain-funcs
+inherit autotools eutils fortran-2 flag-o-matic gnuconfig python toolchain-funcs
MY_P="${PN/-apps}-${PV}"
@@ -103,6 +103,7 @@ PDEPEND="${SCIAPPS}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
+ fortran-2_pkg_setup
python_set_active_version 2
}
@@ -133,7 +134,7 @@ src_prepare() {
# libraries come from sci-libs/ccp4-libs
ccp_patch "${FILESDIR}"/${PV}-dont-build-libs.patch
- # coreutils installs a binary called truncate
+ # coreutils fortran-2 installs a binary called truncate
# ccp_patch "${FILESDIR}"/${PV}-rename-truncate.patch
# mv ./doc/truncate.doc ./doc/ftruncate.doc || die
# mv ./html/truncate.html ./html/ftruncate.html || die
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild
index 0bef8dc77473..26a2ff648235 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild,v 1.4 2011/03/04 17:02:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r8.ebuild,v 1.5 2011/06/21 08:41:27 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit autotools eutils flag-o-matic gnuconfig python toolchain-funcs
+inherit autotools eutils fortran-2 flag-o-matic gnuconfig python toolchain-funcs
MY_P="${PN/-apps}-${PV}"
@@ -103,6 +103,7 @@ PDEPEND="${SCIAPPS}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
+ fortran-2_pkg_setup
python_set_active_version 2
}
diff --git a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild
index 520ad814532e..be70068c6fae 100644
--- a/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild
+++ b/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild,v 1.2 2011/03/14 17:06:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccp4-apps/ccp4-apps-6.1.3-r9.ebuild,v 1.3 2011/06/21 08:41:27 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit autotools eutils flag-o-matic gnuconfig python toolchain-funcs
+inherit autotools eutils fortran-2 flag-o-matic gnuconfig python toolchain-funcs
MY_P="${PN/-apps}-${PV}"
@@ -103,6 +103,7 @@ PDEPEND="${SCIAPPS}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
+ fortran-2_pkg_setup
python_set_active_version 2
}