summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-02-06 15:14:10 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-02-06 15:14:10 +0000
commitaaaf288a8c8f4df8112013127a70027055f68b76 (patch)
tree7336e46d88ec33064da0719799688470a8fdf348 /sci-chemistry/pdb2pqr/pdb2pqr-1.3.0.ebuild
parentuntested bump to 0.9.23, bug 209070 (diff)
downloadhistorical-aaaf288a8c8f4df8112013127a70027055f68b76.tar.gz
historical-aaaf288a8c8f4df8112013127a70027055f68b76.tar.bz2
historical-aaaf288a8c8f4df8112013127a70027055f68b76.zip
Version bump (see bug #209007).
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'sci-chemistry/pdb2pqr/pdb2pqr-1.3.0.ebuild')
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.3.0.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.3.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.3.0.ebuild
new file mode 100644
index 000000000000..acc332c03593
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.3.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.3.0.ebuild,v 1.1 2008/02/06 15:14:10 markusle Exp $
+
+inherit eutils fortran multilib flag-o-matic distutils
+
+DESCRIPTION="pdb2pqr is an automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
+LICENSE="BSD"
+HOMEPAGE="http://pdb2pqr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-lang/python"
+
+FORTRAN="g77 gfortran"
+
+src_compile() {
+ # we need to compile the *.so as pic
+ append-flags -fPIC
+ FFLAGS="${FFLAGS} -fPIC"
+ F77="${FORTRANC}" econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ python_version
+ INPATH="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
+
+ insinto "${INPATH}"
+ doins __init__.py || \
+ die "Setting up the pdb2pqr site-package failed."
+
+ exeinto "${INPATH}"
+ doexe ${PN}.py || die "Installing pdb2pqr failed."
+
+ exeinto "${INPATH}"/propka
+ doexe propka/_propkalib.so || \
+ die "Failed to install propka."
+
+ exeinto "${INPATH}"/extensions
+ doexe extensions/* || \
+ die "Failed to install extensions."
+
+ insinto "${INPATH}"/propka
+ doins propka/propkalib.py propka/__init__.py || \
+ die "Failed to install propka."
+
+ insinto "${INPATH}"/src
+ doins src/* || die "Installing of python scripts failed."
+
+ insinto "${INPATH}"/dat
+ doins dat/* || die "Installing data failed."
+
+ # generate pdb2pqr wrapper
+ cat >> "${T}"/${PN} <<-EOF
+ #!/bin/sh
+ ${python} ${INPATH}/${PN}.py \$*
+ EOF
+
+ exeinto /usr/bin
+ doexe "${T}"/${PN} || die "Failed to install pdb2pqr wrapper."
+
+ dodoc ChangeLog NEWS README AUTHORS || \
+ die "Failed to install docs"
+ dohtml -r doc/* || die "Failed to install html docs."
+}