summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 13:59:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 13:59:36 +0000
commitf8c12a27827912f8316c9685d0c27cf8e5558f6a (patch)
tree005c7c40405f618cf75ec517dacb6f5568378426 /sci-chemistry/pdb-tools
parentAdded missing toolchain-funcs.eclass (diff)
downloadhistorical-f8c12a27827912f8316c9685d0c27cf8e5558f6a.tar.gz
historical-f8c12a27827912f8316c9685d0c27cf8e5558f6a.tar.bz2
historical-f8c12a27827912f8316c9685d0c27cf8e5558f6a.zip
Removal of fortran.eclass, #348851
Package-Manager: portage-2.2.0_alpha8/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/pdb-tools')
-rw-r--r--sci-chemistry/pdb-tools/ChangeLog5
-rw-r--r--sci-chemistry/pdb-tools/pdb-tools-0.1.4-r2.ebuild12
2 files changed, 9 insertions, 8 deletions
diff --git a/sci-chemistry/pdb-tools/ChangeLog b/sci-chemistry/pdb-tools/ChangeLog
index 455851ac3ab9..755ecf21bc65 100644
--- a/sci-chemistry/pdb-tools/ChangeLog
+++ b/sci-chemistry/pdb-tools/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/pdb-tools
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/ChangeLog,v 1.3 2010/10/28 20:01:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/ChangeLog,v 1.4 2010/12/16 13:41:37 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> pdb-tools-0.1.4-r2.ebuild:
+ Removal of fortran.eclass, #348851
*pdb-tools-0.1.4-r2 (28 Oct 2010)
diff --git a/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r2.ebuild b/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r2.ebuild
index 40de5820edb0..7e8fc6040a5b 100644
--- a/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r2.ebuild
+++ b/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r2.ebuild,v 1.1 2010/10/28 20:01:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb-tools/pdb-tools-0.1.4-r2.ebuild,v 1.2 2010/12/16 13:41:37 jlec Exp $
EAPI="3"
@@ -8,7 +8,7 @@ PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-inherit python fortran
+inherit python toolchain-funcs
DESCRIPTION="A set of tools for manipulating and doing calculations on wwPDB macromolecule structure files"
HOMEPAGE="http://code.google.com/p/pdb-tools"
@@ -22,8 +22,6 @@ IUSE=""
RDEPEND="sci-chemistry/dssp"
DEPEND=""
-FORTRANC="ifc gfortran"
-
S="${WORKDIR}"/${PN}_${PV}
src_prepare() {
@@ -35,9 +33,9 @@ src_compile() {
mkdir bin
cd satk
for i in *.f; do
- einfo "${FORTRANC} ${FFLAGS} ${LDFLAGS} ${i} -o ${i/.f}"
- ${FORTRANC} ${FFLAGS} -c ${i} -o ${i/.f/.o} || die
- ${FORTRANC} ${LDFLAGS} -o ../bin/${i/.f} ${i/.f/.o} || die
+ einfo "$(tc-getFC) ${FFLAGS} ${LDFLAGS} ${i} -o ${i/.f}"
+ $(tc-getFC) ${FFLAGS} -c ${i} -o ${i/.f/.o} || die
+ $(tc-getFC) ${LDFLAGS} -o ../bin/${i/.f} ${i/.f/.o} || die
sed "s:${i/.f}.out:${i/.f}:g" -i ../pdb_satk.py || die
done
}