summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-13 16:33:38 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-13 16:33:38 +0000
commitf17b4d2ac465e85bb25f5bb2b2ae212de28159a8 (patch)
tree9c1c9f06e1ae2901e2106d25727dc249e368f94b /sci-biology/tophat/tophat-2.0.8.ebuild
parentAdd build dep on kernel headers (bug #461614). (diff)
downloadhistorical-f17b4d2ac465e85bb25f5bb2b2ae212de28159a8.tar.gz
historical-f17b4d2ac465e85bb25f5bb2b2ae212de28159a8.tar.bz2
historical-f17b4d2ac465e85bb25f5bb2b2ae212de28159a8.zip
sci-biology/tophat: Version Bump; unbundle sci-biology/seqan
Package-Manager: portage-2.2.0_alpha166/cvs/Linux x86_64 Manifest-Sign-Key: 0x70EB7916
Diffstat (limited to 'sci-biology/tophat/tophat-2.0.8.ebuild')
-rw-r--r--sci-biology/tophat/tophat-2.0.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-biology/tophat/tophat-2.0.8.ebuild b/sci-biology/tophat/tophat-2.0.8.ebuild
new file mode 100644
index 000000000000..d811ebe05cf8
--- /dev/null
+++ b/sci-biology/tophat/tophat-2.0.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-2.0.8.ebuild,v 1.1 2013/03/13 16:33:37 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/boost
+ sci-biology/samtools
+ sci-biology/seqan"
+RDEPEND="${DEPEND}
+ sci-biology/bowtie"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+src_prepare() {
+ rm -rf src/SeqAn* || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optim
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}