summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:09:28 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:09:28 +0000
commita6583f4e1b82285886b46c78348615248f552cb6 (patch)
tree8189bdf3bbe9e894e1f4368173ecdea43a4775eb /sci-biology/prints
parentInstall static library again. Add /etc/dmtab and new rc-scripts addon for (diff)
downloadhistorical-a6583f4e1b82285886b46c78348615248f552cb6.tar.gz
historical-a6583f4e1b82285886b46c78348615248f552cb6.tar.bz2
historical-a6583f4e1b82285886b46c78348615248f552cb6.zip
Added support for the "emboss" and "minimal" "USE" flags.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'sci-biology/prints')
-rw-r--r--sci-biology/prints/ChangeLog5
-rw-r--r--sci-biology/prints/prints-37.0.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/sci-biology/prints/ChangeLog b/sci-biology/prints/ChangeLog
index 71bebc381a09..fbca962b1211 100644
--- a/sci-biology/prints/ChangeLog
+++ b/sci-biology/prints/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/prints
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/ChangeLog,v 1.4 2005/02/02 21:32:12 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/ChangeLog,v 1.5 2005/02/23 04:06:27 ribosome Exp $
+
+ 22 Feb 2005; Olivier Fisette <ribosome@gentoo.org> prints-37.0.ebuild:
+ Added support for the "emboss" and "minimal" "USE" flags.
02 Feb 2005; Lina Pezzella <j4rg0n@gentoo.org> prints-37.0.ebuild:
Stable ppc-macos
diff --git a/sci-biology/prints/prints-37.0.ebuild b/sci-biology/prints/prints-37.0.ebuild
index 2fc7fa47d1c0..4a658fdbae14 100644
--- a/sci-biology/prints/prints-37.0.ebuild
+++ b/sci-biology/prints/prints-37.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/prints-37.0.ebuild,v 1.3 2005/02/02 21:32:12 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prints/prints-37.0.ebuild,v 1.4 2005/02/23 04:06:27 ribosome Exp $
DESCRIPTION="A protein motif fingerprint database"
HOMEPAGE="http://www.bioinf.man.ac.uk/dbbrowser/PRINTS/"
@@ -13,27 +13,29 @@ SRC_URI="ftp://ftp.ebi.ac.uk/pub/databases/${PN}/newpr.lis.gz
LICENSE="public-domain"
SLOT="0"
KEYWORDS="x86 ~ppc ppc-macos"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
S=${WORKDIR}
src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/printsextract ] && ! use no-emboss; then
+ if use emboss; then
mkdir PRINTS
+ echo
einfo "Indexing PRINTS for usage with EMBOSS."
EMBOSS_DATA=. printsextract -auto -infile prints37_0.dat || die \
"Indexing PRINTS failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins ${PN}37_0.{all.fasta,dat,lis,nam,vsn} newpr.lis
fi
- if [ -e /usr/bin/printsextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/PRINTS
doins PRINTS/*
fi