summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2008-12-31 00:28:51 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2008-12-31 00:28:51 +0000
commitcf54590270a0bf1270feb9a90f00ba0f99a30c81 (patch)
tree1ae03e33872da030160d0fef2de415d5550cbe67 /sci-biology/phrap/phrap-1.080812.ebuild
parentStable on sparc, bug #252656 (diff)
downloadhistorical-cf54590270a0bf1270feb9a90f00ba0f99a30c81.tar.gz
historical-cf54590270a0bf1270feb9a90f00ba0f99a30c81.tar.bz2
historical-cf54590270a0bf1270feb9a90f00ba0f99a30c81.zip
Import from Science overlay, bug 114094
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-tuxonice i686
Diffstat (limited to 'sci-biology/phrap/phrap-1.080812.ebuild')
-rw-r--r--sci-biology/phrap/phrap-1.080812.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-biology/phrap/phrap-1.080812.ebuild b/sci-biology/phrap/phrap-1.080812.ebuild
new file mode 100644
index 000000000000..8b1d86ffc2e2
--- /dev/null
+++ b/sci-biology/phrap/phrap-1.080812.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phrap/phrap-1.080812.ebuild,v 1.1 2008/12/31 00:28:51 weaver Exp $
+
+DESCRIPTION="Phrap, swat, cross_match: Shotgun assembly and alignment utilities"
+HOMEPAGE="http://www.phrap.org/"
+SRC_URI="phrap-${PV}-distrib.tar.gz"
+
+LICENSE="phrap"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Please visit http://www.phrap.org/phredphrapconsed.html and obtain the file"
+ einfo "\"distrib.tar.gz\", then rename it to \"phrap-${PV}-distrib.tar.gz\""
+ einfo "and put it in ${DISTDIR}"
+}
+
+src_compile() {
+ sed -i 's/CFLAGS=/#CFLAGS=/' makefile
+ sed -i 's|#!/usr/local/bin/perl|#!/usr/bin/env perl|' phrapview
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin cluster cross_match loco phrap phrapview swat
+ for i in {general,phrap,swat}.doc ; do
+ newdoc ${i} ${i}.txt
+ done
+}
+
+pkg_postinst() {
+ elog If you are operating a non-commercial \(academic or government\)
+ elog computer facility which provides access to several independent
+ elog investigators, you are required by the licensing agreement to set the
+ elog permissions on the executables and source code to allow execute but
+ elog not read access, so that the programs may not be copied.
+ elog
+ elog Phrap documentation is installed in ${ROOT}/usr/share/doc/${P}.
+}