summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-02-20 01:16:50 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-02-20 01:16:50 +0000
commit5ff36968700ce2bfe86c32d44900b0f4cde039f0 (patch)
tree14c67be7dbf746333e9182317bb9c568772c940d /sci-biology/biopython/biopython-1.40b.ebuild
parentDon't put CTARGET_ALIASES stuff in the env. (diff)
downloadhistorical-5ff36968700ce2bfe86c32d44900b0f4cde039f0.tar.gz
historical-5ff36968700ce2bfe86c32d44900b0f4cde039f0.tar.bz2
historical-5ff36968700ce2bfe86c32d44900b0f4cde039f0.zip
New version. Fixed bug #82498.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'sci-biology/biopython/biopython-1.40b.ebuild')
-rw-r--r--sci-biology/biopython/biopython-1.40b.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/biopython/biopython-1.40b.ebuild b/sci-biology/biopython/biopython-1.40b.ebuild
new file mode 100644
index 000000000000..cb2b77f8b70c
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.40b.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.40b.ebuild,v 1.1 2005/02/20 01:16:50 ribosome Exp $
+
+inherit distutils
+
+IUSE=""
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+SRC_URI="http://www.biopython.org/files/${P}.tar.gz"
+HOMEPAGE="http://www.biopython.org"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-python/numeric-19.0
+ >=dev-python/reportlab-1.11"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="Doc/* Doc/install/*.txt"
+ distutils_src_install
+
+ dohtml Doc/install/*.html
+ cp -r Doc/examples/ ${D}/usr/share/doc/${PF}/
+}