summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-06-30 16:41:51 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-06-30 16:41:51 +0000
commit0dde672d768d01d335e6b9b09774453012e22976 (patch)
treee35766c67d085cf6ea64905313013d18e70dfbe7 /perl-core/DB_File
parent. (diff)
downloadhistorical-0dde672d768d01d335e6b9b09774453012e22976.tar.gz
historical-0dde672d768d01d335e6b9b09774453012e22976.tar.bz2
historical-0dde672d768d01d335e6b9b09774453012e22976.zip
Bumped for patch. The default Makefile.PL was overriding any calls for INSTALLDIRS and placing the module in the core perl dirs instead of vendor. The patch changes perl to vendor in the Makefile.PL (another kludge) to correct this. Will eventually fix bugs 97476, 97497
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'perl-core/DB_File')
-rw-r--r--perl-core/DB_File/ChangeLog12
-rw-r--r--perl-core/DB_File/DB_File-1.811-r1.ebuild30
-rw-r--r--perl-core/DB_File/DB_File-1.811.ebuild6
-rw-r--r--perl-core/DB_File/Manifest15
-rw-r--r--perl-core/DB_File/files/DB_File-MakeMaker.patch11
-rw-r--r--perl-core/DB_File/files/digest-DB_File-1.811-r11
6 files changed, 66 insertions, 9 deletions
diff --git a/perl-core/DB_File/ChangeLog b/perl-core/DB_File/ChangeLog
index eb76ba55e703..b6cac5a7160b 100644
--- a/perl-core/DB_File/ChangeLog
+++ b/perl-core/DB_File/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for perl-core/DB_File
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/ChangeLog,v 1.3 2005/05/26 20:09:29 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/ChangeLog,v 1.4 2005/06/30 16:41:51 mcummings Exp $
+
+*DB_File-1.811-r1 (30 Jun 2005)
+
+ 30 Jun 2005; Michael Cummings <mcummings@gentoo.org>
+ +files/DB_File-MakeMaker.patch, +DB_File-1.811-r1.ebuild,
+ DB_File-1.811.ebuild:
+ Bumped for patch. The default Makefile.PL was overriding any calls for
+ INSTALLDIRS and placing the module in the core perl dirs instead of vendor.
+ The patch changes perl to vendor in the Makefile.PL (another kludge) to
+ correct this. Will eventually fix bugs 97476, 97497
26 May 2005; Herbie Hopkins <herbs@gentoo.org> DB_File-1.811.ebuild:
Multilib fix.
diff --git a/perl-core/DB_File/DB_File-1.811-r1.ebuild b/perl-core/DB_File/DB_File-1.811-r1.ebuild
new file mode 100644
index 000000000000..cf9a38a0c528
--- /dev/null
+++ b/perl-core/DB_File/DB_File-1.811-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/DB_File-1.811-r1.ebuild,v 1.1 2005/06/30 16:41:51 mcummings Exp $
+
+inherit perl-module multilib eutils
+
+DESCRIPTION="A Berkeley DB Support Perl Module"
+HOMEPAGE="http://www.cpan.org/modules/by-module/DB_File/${P}.readme"
+SRC_URI="mirror://cpan/authors/id/P/PM/PMQS/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+DEPEND="sys-libs/db"
+
+SRC_TEST="do"
+
+mydoc="Changes"
+
+src_unpack() {
+ unpack ${A}
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e "s:^LIB.*:LIB = /usr/$(get_libdir):" \
+ ${S}/config.in || die
+ fi
+ cd ${S}
+ epatch ${FILESDIR}/DB_File-MakeMaker.patch
+}
diff --git a/perl-core/DB_File/DB_File-1.811.ebuild b/perl-core/DB_File/DB_File-1.811.ebuild
index 41dcef04e164..6655fc097e7e 100644
--- a/perl-core/DB_File/DB_File-1.811.ebuild
+++ b/perl-core/DB_File/DB_File-1.811.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/DB_File-1.811.ebuild,v 1.2 2005/05/26 12:15:27 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/DB_File-1.811.ebuild,v 1.3 2005/06/30 16:41:51 mcummings Exp $
-inherit perl-module multilib
+inherit perl-module multilib eutils
DESCRIPTION="A Berkeley DB Support Perl Module"
HOMEPAGE="http://www.cpan.org/modules/by-module/DB_File/${P}.readme"
@@ -25,4 +25,6 @@ src_unpack() {
sed -i -e "s:^LIB.*:LIB = /usr/$(get_libdir):" \
${S}/config.in || die
fi
+ cd ${S}
+ epatch ${FILESDIR}/DB_File-MakeMaker.patch
}
diff --git a/perl-core/DB_File/Manifest b/perl-core/DB_File/Manifest
index 46158deeabe6..adefa87d3b80 100644
--- a/perl-core/DB_File/Manifest
+++ b/perl-core/DB_File/Manifest
@@ -1,15 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 36fe144b7d9caf8cf46c2e1e4df6bfc0 DB_File-1.811.ebuild 751
-MD5 d5a3db8098899bccd78ce59eea85ce77 ChangeLog 4557
+MD5 88a526b893bbb4ef3e607b56b0dd9838 ChangeLog 5010
+MD5 29ec4bf3df6cd0b8c361ec5f07d2a56e DB_File-1.811.ebuild 815
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 fd70565e0d9cc8afeb68fd536f908510 DB_File-1.811-r1.ebuild 818
MD5 2259e73a14e4f2c7bd63215dba073b10 files/config.in 3121
MD5 1900638402c237ae141b03ef26fe6933 files/digest-DB_File-1.811 64
+MD5 a8508928a7565d049db19d4045693201 files/DB_File-MakeMaker.patch 569
+MD5 1900638402c237ae141b03ef26fe6933 files/digest-DB_File-1.811-r1 64
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
+Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCli0VI1lqEGTUzyQRAgG4AJ4gZ7YXG1TmQPxgytNlKKsEL08PKQCgpm7B
-8EwwfXXUQuKpuhvbN9L6o1E=
-=bWg7
+iD8DBQFCxCDptG5z4I8BtQoRAh9UAKCEACd7TCkquIXgdQXYUGo/HCyq6gCfY9Fe
+GurkQf8yN7LvhAqDajnRMpc=
+=+RUY
-----END PGP SIGNATURE-----
diff --git a/perl-core/DB_File/files/DB_File-MakeMaker.patch b/perl-core/DB_File/files/DB_File-MakeMaker.patch
new file mode 100644
index 000000000000..0640feeba640
--- /dev/null
+++ b/perl-core/DB_File/files/DB_File-MakeMaker.patch
@@ -0,0 +1,11 @@
+--- Makefile.PL.old 2005-06-30 12:31:52.000000000 -0400
++++ Makefile.PL 2005-06-30 12:35:11.000000000 -0400
+@@ -54,7 +54,7 @@ WriteMakefile(
+ 'depend' => { 'Makefile' => 'config.in',
+ 'version$(OBJ_EXT)' => 'version.c'},
+ 'clean' => { FILES => 'constants.h constants.xs' },
+- 'macro' => { INSTALLDIRS => 'perl', my_files => "@files" },
++ 'macro' => { INSTALLDIRS => 'vendor', my_files => "@files" },
+ 'dist' => { COMPRESS => 'gzip', SUFFIX => 'gz',
+ DIST_DEFAULT => 'MyDoubleCheck tardist'},
+ );
diff --git a/perl-core/DB_File/files/digest-DB_File-1.811-r1 b/perl-core/DB_File/files/digest-DB_File-1.811-r1
new file mode 100644
index 000000000000..b1156336765c
--- /dev/null
+++ b/perl-core/DB_File/files/digest-DB_File-1.811-r1
@@ -0,0 +1 @@
+MD5 b5fe98c944ead904ebf2afb3eff95b9f DB_File-1.811.tar.gz 86858