summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-07-22 18:08:48 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-07-22 18:08:48 +0000
commit99373ea170e6f781bcfd6212cf3b10bdf5f5da7f (patch)
treecbdadbc08e864f5c14044e77ad3c59018e0c8788 /net-www
parentVersion bump to 1.11a27 (diff)
downloadhistorical-99373ea170e6f781bcfd6212cf3b10bdf5f5da7f.tar.gz
historical-99373ea170e6f781bcfd6212cf3b10bdf5f5da7f.tar.bz2
historical-99373ea170e6f781bcfd6212cf3b10bdf5f5da7f.zip
Fixed gpm problems in the 0.96 version of links
Diffstat (limited to 'net-www')
-rw-r--r--net-www/links/ChangeLog8
-rw-r--r--net-www/links/files/digest-links-0.96-r21
-rw-r--r--net-www/links/files/links-0.96-r2-gentoo.patch55
-rw-r--r--net-www/links/links-0.96-r2.ebuild50
4 files changed, 113 insertions, 1 deletions
diff --git a/net-www/links/ChangeLog b/net-www/links/ChangeLog
index 9d6f48bb68cd..5b9390957014 100644
--- a/net-www/links/ChangeLog
+++ b/net-www/links/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-www/links
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.11 2002/07/21 15:54:04 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.12 2002/07/22 18:08:48 naz Exp $
+ 22 Jul 2002; Michael Nazaroff <naz@gentoo.org> links-0.96-r2.ebuild :
+
+ Added a patch to fix links 0.96 compiling against gpm, since the previous
+ version still did even with -gpm set in USE. Thanx to Christopher Horler for
+ the excellent patch and ebuild. This fix's bug 5351.
+
21 Jul 2002; Seemant Kulleen <seemant@gentoo.org> links-2.1_pre2-r1.ebuild
changed --disable-graphics to --without-graphics. Fix submitted by:
diff --git a/net-www/links/files/digest-links-0.96-r2 b/net-www/links/files/digest-links-0.96-r2
new file mode 100644
index 000000000000..ca0426901384
--- /dev/null
+++ b/net-www/links/files/digest-links-0.96-r2
@@ -0,0 +1 @@
+MD5 1c3502f3a3a5b79312cd296fb3d60544 links-0.96.tar.gz 485442
diff --git a/net-www/links/files/links-0.96-r2-gentoo.patch b/net-www/links/files/links-0.96-r2-gentoo.patch
new file mode 100644
index 000000000000..1b0c3e63736d
--- /dev/null
+++ b/net-www/links/files/links-0.96-r2-gentoo.patch
@@ -0,0 +1,55 @@
+--- acconfig.h.orig Sun Jul 21 19:28:40 2002
++++ acconfig.h Sun Jul 21 19:27:20 2002
+@@ -53,4 +53,7 @@
+ #undef HAVE_SSL
+
+ /* */
++#undef HAVE_LIBGPM
++
++/* */
+ #undef X2
+--- configure.in.orig Sun Jul 21 19:28:21 2002
++++ configure.in Sun Jul 21 19:36:46 2002
+@@ -56,8 +56,6 @@
+ AC_HAVE_FUNCS(getpid setpgid getpgid setpgrp getpgrp)
+
+ dnl Checks for libraries.
+-dnl Replace `main' with a function in -lgpm:
+-AC_CHECK_LIB(gpm, Gpm_Open)
+ dnl Replace `main' with a function in -lsocket:
+ AC_CHECK_FUNC(socket, cf_result=yes, cf_result=no)
+ if test "$cf_result" = no; then
+@@ -161,6 +159,33 @@
+ AC_MSG_RESULT($cf_result)
+ #endif
+
++dnl Configure switch for gpm added
++dnl Replace `main' with a function in -lgpm:
++#ifdef HAVE_LIBGPM
++AC_ARG_WITH(gpm, [ --without-gpm disable GPM support], [if test "$withval" = no; then disable_gpm=yes; fi])
++AC_MSG_CHECKING([for GPM])
++LIBS_X="$LIBS"
++cf_result=no
++if test -z "$disable_gpm"; then
++ if test "$cf_result" = no; then
++ LIBS="-lgpm $LIBS_X"
++ AC_TRY_LINK([#include <gpm.h>], [Gpm_Connect gpm; Gpm_Open(&gpm, 0)], cf_result=yes, cf_result=no)
++ fi
++
++ if test "$cf_result" != yes; then
++ if test "$withval" = yes; then
++ AC_MSG_ERROR("GPM not found")
++ fi
++ LIBS="$LIBS_X"
++ else
++ AC_DEFINE(HAVE_LIBGPM)
++ fi
++fi
++AC_MSG_RESULT($cf_result)
++#endif
++
++
++
+ test "$have_emx" = yes && LDFLAGS="$LDFLAGS -Zexe"
+
+ AC_OUTPUT(Makefile)
diff --git a/net-www/links/links-0.96-r2.ebuild b/net-www/links/links-0.96-r2.ebuild
new file mode 100644
index 000000000000..e6727ee4d7ff
--- /dev/null
+++ b/net-www/links/links-0.96-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-0.96-r2.ebuild,v 1.1 2002/07/22 18:08:48 naz Exp $
+
+S=${WORKDIR}/${P}
+SRC_URI="http://artax.karlin.mff.cuni.cz/~mikulas/links/download/${P}.tar.gz"
+HOMEPAGE="http://artax.karlin.mff.cuni.cz/~mikulas/links"
+DESCRIPTION="A console-based web browser"
+DEPEND=">=sys-libs/ncurses-5.1
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 ppc"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # patch to add gpm configure switch it solves the linking problem
+ # when USE="-gpm" is specified but gpm is installed
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.patch || die
+
+ autoheader
+ aclocal
+ automake
+ autoconf
+}
+
+src_compile() {
+ local myconf
+ use ssl \
+ && myconf="--with-ssl" \
+ || myconf="--without-ssl"
+ use gpm \
+ && myconf="${myconf} --with-gpm" \
+ || myconf="${myconf} --without-gpm"
+
+ econf ${myconf} || die
+
+ emake || die
+}
+
+
+src_install() {
+ einstall
+ dodoc README SITES NEWS AUTHORS COPYING BUGS TODO Changelog
+}