summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-26 08:04:46 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-26 08:04:46 +0000
commit77b6d1aee59305c5afe8230ba9d23e76d998d54e (patch)
treea83e7aea53dab0d3194638aa9a7a7b760bd92ebd /net-www
parentVarious fixes (diff)
downloadhistorical-77b6d1aee59305c5afe8230ba9d23e76d998d54e.tar.gz
historical-77b6d1aee59305c5afe8230ba9d23e76d998d54e.tar.bz2
historical-77b6d1aee59305c5afe8230ba9d23e76d998d54e.zip
Added chatzilla
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/files/digest-mozilla-0.8.1-r21
-rw-r--r--net-www/mozilla/mozilla-0.8.1-r2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-www/mozilla/files/digest-mozilla-0.8.1-r2 b/net-www/mozilla/files/digest-mozilla-0.8.1-r2
new file mode 100644
index 000000000000..1f66125c9c87
--- /dev/null
+++ b/net-www/mozilla/files/digest-mozilla-0.8.1-r2
@@ -0,0 +1 @@
+MD5 04c6fbb5dd01ba68687ea2dd95195451 mozilla-source-0.8.1.tar.gz
diff --git a/net-www/mozilla/mozilla-0.8.1-r2.ebuild b/net-www/mozilla/mozilla-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..ea443e561d91
--- /dev/null
+++ b/net-www/mozilla/mozilla-0.8.1-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-0.8.1-r2.ebuild,v 1.1 2001/04/26 08:04:46 achim Exp $
+
+A=mozilla-source-${PV}.tar.gz
+S=${WORKDIR}/mozilla
+DESCRIPTION=""
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla${PV}/src/${A}"
+HOMEPAGE="http://www.mozilla.org"
+PROVIDE="virtual/x11-web-browser"
+
+DEPEND=">=gnome-base/ORBit-0.5.7
+ >=x11-libs/gtk+-1.2.9
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.9"
+
+src_compile() {
+
+ try ./configure --prefix=/opt/mozilla --host=${CHOST} \
+ --with-gtk --disable-tests --disable-debug
+ try make
+ try ./configure --prefix=/opt/mozilla --host=${CHOST} \
+ --with-gtk --disable-tests --disable-debug
+ try make BUILD_MODULES=psm
+ try ./configure --prefix=/opt/mozilla --host=${CHOST} \
+ --with-gtk --disable-tests --disable-debug \
+ --with-extensions=default,irc
+ cd extensions/irc
+ try make
+}
+
+src_install () {
+
+ dodir /opt/mozilla/include/{private,obsolete}
+ cd dist/include
+ cp -f *.h ${D}/opt/mozilla/include
+ cp -f obsolete/*.h ${D}/opt/mozilla/include/obsolete
+ cp -f private/*.h ${D}/opt/mozilla/include/private
+
+ export MOZILLA_OFFICIAL=1
+ export BUILD_OFFICIAL=1
+ cd ${S}/xpinstall/packager
+ try make
+ dodir /opt
+ tar xzf ${S}/dist/mozilla-i686-pc-linux-gnu.tar.gz -C ${D}/opt
+ mv ${D}/opt/package ${D}/opt/mozilla
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/mozilla
+ insinto /etc/env.d
+ doins ${FILESDIR}/10mozilla
+ dodoc LEGAL LICENSE README/mozilla/README*
+
+
+}
+