summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-07 19:55:38 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-07 19:55:38 +0000
commit6400becccda20ad3cd9a2227ae1942824d058ae7 (patch)
tree1f73d0f24d324dbac227d1ff84a24bfd0bd2691a /net-www
parentvarious portage things (diff)
downloadhistorical-6400becccda20ad3cd9a2227ae1942824d058ae7.tar.gz
historical-6400becccda20ad3cd9a2227ae1942824d058ae7.tar.bz2
historical-6400becccda20ad3cd9a2227ae1942824d058ae7.zip
*** empty log message ***
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/mozilla-0.8-r2.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-www/mozilla/mozilla-0.8-r2.ebuild b/net-www/mozilla/mozilla-0.8-r2.ebuild
index 8c842a8565fa..9a4c50c5624c 100644
--- a/net-www/mozilla/mozilla-0.8-r2.ebuild
+++ b/net-www/mozilla/mozilla-0.8-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-0.8-r2.ebuild,v 1.2 2001/03/07 15:13:46 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-0.8-r2.ebuild,v 1.3 2001/03/07 19:55:38 achim Exp $
A=mozilla-source-${PV}.tar.gz
S=${WORKDIR}/mozilla
@@ -19,13 +19,19 @@ DEPEND=">=gnome-base/ORBit-0.5.7
src_compile() {
try ./configure --prefix=/opt/mozilla --host=${CHOST} \
- --with-gtk --disable-tests --disable-debug
+ --with-gtk --disable-tests --disable-debug --enable-cpp-rtti
try make
}
src_install () {
+ dodir /opt/mozilla/include/{private,obsolete}
+ cd dist/include
+ cp -f *.h ${D}/opt/mozilla/include
+ cp -f obsolete/*.h ${D}/opt/mozilla/include/obsolete
+ cp -f private/*.h ${D}/opt/mozilla/include/private
+
export MOZILLA_OFFICIAL=1
export BUILD_OFFICIAL=1
cd ${S}/xpinstall/packager
@@ -33,10 +39,7 @@ src_install () {
dodir /opt
tar xzf ${S}/dist/mozilla-i686-pc-linux-gnu.tar.gz -C ${D}/opt
mv ${D}/opt/package ${D}/opt/mozilla
- dodir /opt/mozilla/include/{private,obsolete}
- cp ${S}/dist/include/*.h ${D}/opt/mozilla/include
- cp ${S}/dist/include/obsolete/*.h ${D}/opt/mozilla/include/obsolete
- cp ${S}/dist/include/private/*.h ${D}/opt/mozilla/include/private
+
exeinto /usr/bin
doexe ${FILESDIR}/mozilla
insinto /etc/env.d