summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-10-12 12:55:00 +0000
committerMamoru Komachi <usata@gentoo.org>2003-10-12 12:55:00 +0000
commit2c7d0d6b7327da3c93f211d8c3dbc37134d324ab (patch)
tree2dc8b2190ba96fe7f6e1a56cd0c7ad6f68ee1fc9 /net-www
parentAdded I18N patch and cjk, ssl, truetype and nls IUSE flags. (diff)
downloadhistorical-2c7d0d6b7327da3c93f211d8c3dbc37134d324ab.tar.gz
historical-2c7d0d6b7327da3c93f211d8c3dbc37134d324ab.tar.bz2
historical-2c7d0d6b7327da3c93f211d8c3dbc37134d324ab.zip
Added I18N patch and cjk, ssl, truetype and nls IUSE flags.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/dillo/Manifest4
-rw-r--r--net-www/dillo/dillo-0.7.3-r2.ebuild123
-rw-r--r--net-www/dillo/files/digest-dillo-0.7.3-r23
3 files changed, 128 insertions, 2 deletions
diff --git a/net-www/dillo/Manifest b/net-www/dillo/Manifest
index 8b1385a6f804..8410532eb5bf 100644
--- a/net-www/dillo/Manifest
+++ b/net-www/dillo/Manifest
@@ -1,11 +1,11 @@
-MD5 9b9df9fd8fbe7078be82161fdb149405 ChangeLog 3536
+MD5 18d622d42e3ab06728f2ced231cbe834 ChangeLog 3907
MD5 769892852fbd0785e4cb143cc37d3fdc dillo-0.6.6-r1.ebuild 1752
MD5 ab6982ca55ab3fbfbd774cd47d435c66 dillo-0.6.6-r3.ebuild 1823
MD5 9f92d73f08e4d1292d6f6f535844ac09 dillo-0.7.1.2.ebuild 2626
MD5 b8e73839e0192b0301b52e471bdcb448 dillo-0.7.2.ebuild 2618
MD5 7c3a0a97693f152b241dac6ecee1ceb6 dillo-0.7.3-r1.ebuild 2685
MD5 7e7d5b8e3baa638846425f9306596ff8 dillo-0.7.3.ebuild 2590
-MD5 d726db6d672b3999223c8ee1f710208c dillo-0.7.3-r2.ebuild 3308
+MD5 6551c368aff9364e4e4c4dfe3d1ce10f dillo-0.7.3-r2.ebuild 3307
MD5 7195171b7f074adc1f5f496fceaa8919 files/digest-dillo-0.6.6-r1 133
MD5 87c4d5f926ddf281a2470cb024eb11b9 files/digest-dillo-0.6.6-r3 140
MD5 5decce9a16842c213d1ca6790768de4e files/digest-dillo-0.7.1.2 142
diff --git a/net-www/dillo/dillo-0.7.3-r2.ebuild b/net-www/dillo/dillo-0.7.3-r2.ebuild
new file mode 100644
index 000000000000..bfcc6ee42b9f
--- /dev/null
+++ b/net-www/dillo/dillo-0.7.3-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r2.ebuild,v 1.1 2003/10/12 12:54:51 usata Exp $
+
+inherit flag-o-matic
+
+# Note that truetype, ssl and nls IUSE flags will take effect
+# only if you enable cjk IUSE flag.
+IUSE="ipv6 kde gnome mozilla truetype ssl cjk nls"
+
+S=${WORKDIR}/${P}
+S2=${WORKDIR}/dillo-gentoo-extras-patch3
+I18N_P=${P}-i18n-misc-20031012
+
+DESCRIPTION="Lean GTK+-based web browser"
+HOMEPAGE="http://dillo.auriga.wearlab.de/"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo-gentoo-extras-patch3.tar.bz2
+ cjk? ( http://teki.jpn.ph/pc/software/${I18N_P}.diff.bz2 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.3
+ >=media-libs/libpng-1.2.1
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use cjk && epatch ../${I18N_P}.diff
+
+ if [ "${DILLO_ICONSET}" = "kde" ]
+ then
+ ebegin "Using Konqueror style icon set"
+ cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "gnome" ]
+ then
+ ebegin "Using Ximian style icon set"
+ cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "mozilla" ]
+ then
+ ebegin "Using Netscape style icon set"
+ cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "bold" ]
+ then
+ ebegin "Using bold style icon set"
+ cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
+ eend 0
+ elif [ "${DILLO_ICONSET}" = "trans" ]
+ then
+ ebegin "Using transparent style icon set"
+ cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
+ eend 0
+ else
+ ebegin "Using default Dillo icon set"
+ eend 0
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if [ -n "`use cjk`" ] ; then
+ if [ -n "`use truetype`" ] ; then
+ CPPFLAGS="${CPPFLAGS} -I/usr/include/freetype2"
+ LDFLAGS="${LDFLAGS} -L/usr/X11R6/lib -lXft"
+ export CPPFLAGS LDFLAGS
+ fi
+ myconf="`use_enable nls`
+ `use_enable ssl`
+ `use_enable truetype anti-alias`
+ --enable-meta-refresh"
+ fi
+
+ econf `use_enable ipv6` \
+ ${myconf} || die
+ emake || make || die
+}
+
+src_install() {
+ dodir /etc /usr/share/icons/${PN}
+ einstall || die
+
+ dodoc AUTHORS COPYING ChangeLog* INSTALL README NEWS
+ docinto doc
+ dodoc doc/*.txt doc/README
+
+ cp ${S2}/icons/*.png ${D}/usr/share/icons/${PN}
+}
+
+pkg_postinst() {
+ einfo "This ebuild for dillo comes with different toolbar icons"
+ einfo "If you want mozilla style icons then try"
+ einfo " DILLO_ICONSET=\"mozilla\" emerge dillo"
+ einfo
+ einfo "If you prefer konqueror style icons then try"
+ einfo " DILLO_ICONSET=\"kde\" emerge dillo"
+ einfo
+ einfo "If you prefer ximian gnome style icons then try"
+ einfo " DILLO_ICONSET=\"gnome\" emerge dillo"
+ einfo
+ einfo "If you prefer bold style icons then try"
+ einfo " DILLO_ICONSET=\"bold\" emerge dillo"
+ einfo
+ einfo "If you prefer transparent style icons then try"
+ einfo " DILLO_ICONSET=\"trans\" emerge dillo"
+ einfo
+ einfo "If the DILLO_ICONSET variable is not set, you will get the"
+ einfo "default iconset"
+ einfo
+ einfo "To see what the icons look like, please point your browser to:"
+ einfo "http://dillo.auriga.wearlab.de/Icons/"
+ einfo
+}
diff --git a/net-www/dillo/files/digest-dillo-0.7.3-r2 b/net-www/dillo/files/digest-dillo-0.7.3-r2
new file mode 100644
index 000000000000..42b616d59765
--- /dev/null
+++ b/net-www/dillo/files/digest-dillo-0.7.3-r2
@@ -0,0 +1,3 @@
+MD5 896f4d8c752b86376bfb445740f01470 dillo-0.7.3.tar.bz2 345295
+MD5 3bc2370883e41905791f94f0b8e2f79b dillo-gentoo-extras-patch3.tar.bz2 86929
+MD5 31e1f8b069ed560d128d775bb559d39b dillo-0.7.3-i18n-misc-20031012.diff.bz2 251715