summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-03-11 03:08:34 +0000
committerAron Griffis <agriffis@gentoo.org>2003-03-11 03:08:34 +0000
commit679dde72ac0283e3e534b887a28c685ed9c6d36d (patch)
tree77f63bdf5b83891f79992940a068f314c32d97fb /net-www/w3m
parentbump version to _rc3 (diff)
downloadhistorical-679dde72ac0283e3e534b887a28c685ed9c6d36d.tar.gz
historical-679dde72ac0283e3e534b887a28c685ed9c6d36d.tar.bz2
historical-679dde72ac0283e3e534b887a28c685ed9c6d36d.zip
fix bug #17205
Diffstat (limited to 'net-www/w3m')
-rw-r--r--net-www/w3m/ChangeLog7
-rw-r--r--net-www/w3m/w3m-0.4.ebuild13
2 files changed, 13 insertions, 7 deletions
diff --git a/net-www/w3m/ChangeLog b/net-www/w3m/ChangeLog
index 0ff4f6466427..e33ac4f97ce1 100644
--- a/net-www/w3m/ChangeLog
+++ b/net-www/w3m/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for net-www/w3m
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.20 2003/03/08 03:14:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.21 2003/03/11 03:08:34 agriffis Exp $
*w3m-0.4 (05 Mar 2003)
+ 10 Mar 2003; Aron Griffis <agriffis@gentoo.org> w3m-0.4.ebuild:
+ Fix bug #17205 by answering compface question conditionally on "use imlib".
+ Thanks to Yamakura Makoto for that fix. Also respect $EDITOR at Seemant's
+ request.
+
07 Mar 2003; Aron Griffis <agriffis@gentoo.org> w3m-0.4.ebuild:
Fix bug #16946 for when USE=-gpm. Thanks to Robert Gill for catching this one.
diff --git a/net-www/w3m/w3m-0.4.ebuild b/net-www/w3m/w3m-0.4.ebuild
index 3f51327a5b32..919d783e075f 100644
--- a/net-www/w3m/w3m-0.4.ebuild
+++ b/net-www/w3m/w3m-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/w3m-0.4.ebuild,v 1.3 2003/03/08 03:14:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/w3m-0.4.ebuild,v 1.4 2003/03/11 03:08:34 agriffis Exp $
inherit eutils
@@ -17,8 +17,7 @@ KEYWORDS="x86 ~sparc alpha ~ppc"
DEPEND=">=sys-libs/ncurses-5.2-r3
>=sys-libs/zlib-1.1.3-r2
- media-libs/compface
- imlib? ( >=media-libs/imlib-1.9.8 )
+ imlib? ( >=media-libs/imlib-1.9.8 media-libs/compface )
gpm? ( >=sys-libs/gpm-1.19.3-r5 )
ssl? ( >=dev-libs/openssl-0.9.6b )"
@@ -124,10 +123,12 @@ src_compile() {
echo y
# Use mark operation [y]?
echo y
- # X-Face support (you need uncompface) [n]?
- echo y
+ if use imlib &>/dev/null; then
+ # X-Face support (you need uncompface) [n]?
+ echo y
+ fi
# Input your favorite editor program.
- echo /usr/bin/nano
+ echo ${EDITOR:-/usr/bin/nano}
# Input your favorite external browser program.
echo /usr/bin/mozilla
# Input your favorite C-compiler.