summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-26 18:30:32 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-26 18:30:32 +0000
commite3f88552aa24ba163262360d0bb5b15e9f733641 (patch)
treebf00ad9a3464a14fe65e31e3a78b6641808b6518 /net-www/mozilla
parent<geoman-campus> that CFLAG information that was discussed on #gentoo-mips was... (diff)
downloadhistorical-e3f88552aa24ba163262360d0bb5b15e9f733641.tar.gz
historical-e3f88552aa24ba163262360d0bb5b15e9f733641.tar.bz2
historical-e3f88552aa24ba163262360d0bb5b15e9f733641.zip
Fix bug 47870 (mozilla fails to compile with gcc 3.4) with one-line patch. The patch doesn't seem to apply to 1.7, hopefully the problem is already fixed there
Diffstat (limited to 'net-www/mozilla')
-rw-r--r--net-www/mozilla/ChangeLog8
-rw-r--r--net-www/mozilla/Manifest5
-rw-r--r--net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch11
-rw-r--r--net-www/mozilla/mozilla-1.6-r1.ebuild6
4 files changed, 26 insertions, 4 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 1a33f7454617..6f460a3a0400 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mozilla
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.162 2004/04/26 15:27:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.163 2004/04/26 18:30:32 agriffis Exp $
+
+ 26 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+ +files/mozilla-1.6-gcc-3.4.patch, mozilla-1.6-r1.ebuild:
+ Fix bug 47870 (mozilla fails to compile with gcc 3.4) with one-line patch. The
+ patch doesn't seem to apply to 1.7, hopefully the problem is already fixed
+ there
26 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+files/mozilla-1.7-amd64.patch, mozilla-1.7_beta-r1.ebuild,
diff --git a/net-www/mozilla/Manifest b/net-www/mozilla/Manifest
index 9282f34e581d..4903a4ee3a93 100644
--- a/net-www/mozilla/Manifest
+++ b/net-www/mozilla/Manifest
@@ -1,13 +1,14 @@
MD5 2078a4dd1a04cbc825ff7d3c827f0121 mozilla-1.7_beta-r1.ebuild 15917
-MD5 ed0fb93caa5a4bac97376951d3152155 mozilla-1.6-r1.ebuild 17087
+MD5 c908bcb957951df24e164b510db5dd3c mozilla-1.6-r1.ebuild 17204
MD5 afc05734cc75f3184176c789051c64c9 mozilla-1.7_rc1.ebuild 16114
-MD5 974e1aa7d34be0c2fd7c4d318f70d3c3 ChangeLog 28175
+MD5 56cebfbe0806c73cb1f0e79184313b15 ChangeLog 28451
MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
MD5 e816a98fb3581a6d4a050aa4cdf12905 files/mozilla-1.7-amd64.patch 25433
MD5 d0e52abf109fe61c4195f0cbf002ae18 files/google.src 706
MD5 766df4cd7332bf4127847985f98e46ec files/gtk2mozilla_head_patch2 27148
MD5 f0e9adeb0454377ce019e8969e644efb files/mozilla-1.4-amd64.patch 35052
MD5 ce10376ba06082440ad0e4ecc3218dc5 files/digest-mozilla-1.7_beta-r1 209
+MD5 3ad7410bd680964096c84eee3fa21abf files/mozilla-1.6-gcc-3.4.patch 460
MD5 11cae063228d9997b2cf9f150d9837fe files/digest-mozilla-1.6-r1 201
MD5 e4adf41536cf80df5f8f5f6ff9bd88a7 files/mozilla-rebuild-databases.pl 2310
MD5 fec6b616b0fec2ee53d64edc2dbfa03c files/mozilla 134
diff --git a/net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch b/net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch
new file mode 100644
index 000000000000..9de10a1fae8c
--- /dev/null
+++ b/net-www/mozilla/files/mozilla-1.6-gcc-3.4.patch
@@ -0,0 +1,11 @@
+--- gfx/public/nsRegion.h.old 2003-03-25 02:57:42.000000000 +0000
++++ gfx/public/nsRegion.h 2004-04-23 02:25:09.606368256 +0100
+@@ -234,7 +234,7 @@
+ void MoveInto (nsRegion& aDestRegion)
+ { MoveInto (aDestRegion, mRectListHead.next); }
+
+- nsRegion (const nsRegion& aRegion); // Prevent copying of regions
++ public:nsRegion (const nsRegion& aRegion); // Prevent copying of regions
+ nsRegion& operator = (const nsRegion& aRegion);
+ };
+
diff --git a/net-www/mozilla/mozilla-1.6-r1.ebuild b/net-www/mozilla/mozilla-1.6-r1.ebuild
index e617033d3aca..421b8ce31d90 100644
--- a/net-www/mozilla/mozilla-1.6-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.6-r1.ebuild,v 1.9 2004/04/26 04:38:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.6-r1.ebuild,v 1.10 2004/04/26 18:30:32 agriffis Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome debug xinerama"
# Internal USE flags that I do not really want to advertise ...
@@ -148,6 +148,10 @@ src_unpack() {
# <azarah@gentoo.org> (23 Feb 2003)
epatch ${FILESDIR}/1.3/${PN}-1.3-fix-RAW-target.patch
+ # Fix compilation with gcc-3.4, bug 47870
+ # (26 Apr 2004 agriffis)
+ epatch ${FILESDIR}/mozilla-1.6-gcc-3.4.patch
+
export WANT_AUTOCONF=2.1
autoconf &> /dev/null
unset WANT_AUTOCONF