summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-20 22:14:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-20 22:14:26 +0000
commit0bd57e2740f583143b3c3ca821622b8a66e508e0 (patch)
tree1b36d71e41b7261bc288b77cdbaad04a725a221f /net-print/gtklp
parentunmask new revision for x86 (diff)
downloadhistorical-0bd57e2740f583143b3c3ca821622b8a66e508e0.tar.gz
historical-0bd57e2740f583143b3c3ca821622b8a66e508e0.tar.bz2
historical-0bd57e2740f583143b3c3ca821622b8a66e508e0.zip
emake->make
Diffstat (limited to 'net-print/gtklp')
-rw-r--r--net-print/gtklp/ChangeLog8
-rw-r--r--net-print/gtklp/gtklp-0.9k.ebuild37
2 files changed, 22 insertions, 23 deletions
diff --git a/net-print/gtklp/ChangeLog b/net-print/gtklp/ChangeLog
index 737b902fb0a7..9ca2483bd427 100644
--- a/net-print/gtklp/ChangeLog
+++ b/net-print/gtklp/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for net-print/gtklp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.3 2002/07/25 22:53:34 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.4 2002/10/20 22:14:26 seemant Exp $
*gtklp-0.9k (25 Jul 2002)
+
+ 20 Oct 2002; Seemant Kulleen <seemant@gentoo.org> gtklp-0.9k.ebuild :
+
+ Cleaned up nasty spacing issues, and emake->make. should fix bug #9404 by
+ jmf@gtcom.net (James Michael Fultz)
+
25 Jul 2002; Spider <spider@gentoo.org> gtklp-0.9k.ebuild:
thanks to Luca Barbato <lu_zero@psxfanatics.com> for a new version ebuild
diff --git a/net-print/gtklp/gtklp-0.9k.ebuild b/net-print/gtklp/gtklp-0.9k.ebuild
index eecf4190feae..b285b6082282 100644
--- a/net-print/gtklp/gtklp-0.9k.ebuild
+++ b/net-print/gtklp/gtklp-0.9k.ebuild
@@ -1,40 +1,33 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9k.ebuild,v 1.4 2002/10/20 18:52:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9k.ebuild,v 1.5 2002/10/20 22:14:26 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A GUI for cupsd"
SRC_URI="http://www.stud.uni-hannover.de/~sirtobi/gtklp/files/${P}.src.tar.gz"
HOMEPAGE="http://www.stud.uni-hannover.de/~sirtobi/gtklp"
-KEYWORDS="x86 ppc"
+
SLOT="0"
+KEYWORDS="x86 ppc"
LICENSE="GPL-2"
-DEPEND="virtual/glibc
- =x11-libs/gtk+-1.2*
+DEPEND="=x11-libs/gtk+-1.2*
>=net-print/cups-1.1.7"
-src_unpack() {
- unpack ${P}.src.tar.gz
-}
-
src_compile() {
local myconf=""
- use nls && myconf="${myconf} --enable-nls"
- use nls || myconf="${myconf} --disable-nls"
- use ssl && myconf="${myconf} --enable-ssl"
- use ssl || myconf="${myconf} --disable-ssl"
-
- ./configure --host=${CHOST} \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} \
- --prefix=/usr || die
- emake ||die
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ use ssl \
+ && myconf="${myconf} --enable-ssl" \
+ || myconf="${myconf} --disable-ssl"
+
+ econf ${myconf}
+ emake || make || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
}
-