summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-15 00:16:31 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-15 00:16:31 +0000
commitc0dc7c916349a884cdb87a545f5bb20ea848fd38 (patch)
tree9bb5357f2c1ab69e654cb4ef7e90a05925f48b05 /net-news/nget
parentNew version. (diff)
downloadhistorical-c0dc7c916349a884cdb87a545f5bb20ea848fd38.tar.gz
historical-c0dc7c916349a884cdb87a545f5bb20ea848fd38.tar.bz2
historical-c0dc7c916349a884cdb87a545f5bb20ea848fd38.zip
New version
Diffstat (limited to 'net-news/nget')
-rw-r--r--net-news/nget/ChangeLog7
-rw-r--r--net-news/nget/files/digest-nget-0.22.11
-rw-r--r--net-news/nget/nget-0.22.1.ebuild43
3 files changed, 50 insertions, 1 deletions
diff --git a/net-news/nget/ChangeLog b/net-news/nget/ChangeLog
index 186709373d1a..bb2fc1e2ba0b 100644
--- a/net-news/nget/ChangeLog
+++ b/net-news/nget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/nget
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/nget/ChangeLog,v 1.3 2002/10/23 19:42:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/nget/ChangeLog,v 1.4 2002/12/15 00:16:31 rphillips Exp $
+
+*nget-0.22.1 (14 Dec 2002)
+
+ 14 Dec 2002; Ryan Phillips <rphillips@gentoo.org> :
+ new version
*nget-0.19.1 (19 Jul 2002)
diff --git a/net-news/nget/files/digest-nget-0.22.1 b/net-news/nget/files/digest-nget-0.22.1
new file mode 100644
index 000000000000..b3814656aa24
--- /dev/null
+++ b/net-news/nget/files/digest-nget-0.22.1
@@ -0,0 +1 @@
+MD5 f9b107e87a6f0b2c8cbde7273dc60d3f nget-0.22.1+uulib.tar.gz 346550
diff --git a/net-news/nget/nget-0.22.1.ebuild b/net-news/nget/nget-0.22.1.ebuild
new file mode 100644
index 000000000000..3e44573fdce2
--- /dev/null
+++ b/net-news/nget/nget-0.22.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/nget/nget-0.22.1.ebuild,v 1.1 2002/12/15 00:16:31 rphillips Exp $
+
+IUSE="static build"
+
+NPVER=20011209
+S=${WORKDIR}/${P}
+DESCRIPTION="Network utility to retrieve files from an NNTP news server"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/nget/${P}+uulib.tar.gz"
+HOMEPAGE="http://nget.sourceforge.net/"
+RDEPEND="virtual/glibc"
+DEPEND="$RDEPEND dev-libs/popt"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ local myconf
+# use nls || myconf="--disable-nls"
+# use ssl && myconf="${myconf} --with-ssl"
+# use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+# [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+# use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man $myconf || die
+ if use static; then
+ make LDFLAGS="--static" || die
+ else
+ make || die
+ fi
+}
+
+src_install() {
+ if use build; then
+ insinto /usr
+ dobin ${S}/src/nget
+ return
+ fi
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc COPYING ChangeLog FAQ README TODO
+}