summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-07-11 02:57:19 +0000
committerDonny Davies <woodchip@gentoo.org>2003-07-11 02:57:19 +0000
commitc48c641b5df2f6cbac6cb812f8bf94f029925477 (patch)
treefee4a125199ccab0a081f54675a9979699026a76 /net-nds
parentbump. (diff)
downloadhistorical-c48c641b5df2f6cbac6cb812f8bf94f029925477.tar.gz
historical-c48c641b5df2f6cbac6cb812f8bf94f029925477.tar.bz2
historical-c48c641b5df2f6cbac6cb812f8bf94f029925477.zip
bump.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/yp-tools/Manifest2
-rw-r--r--net-nds/yp-tools/files/digest-yp-tools-2.81
-rw-r--r--net-nds/yp-tools/yp-tools-2.8.ebuild44
3 files changed, 46 insertions, 1 deletions
diff --git a/net-nds/yp-tools/Manifest b/net-nds/yp-tools/Manifest
index fae63a4d56ca..404f48fe4da3 100644
--- a/net-nds/yp-tools/Manifest
+++ b/net-nds/yp-tools/Manifest
@@ -1,4 +1,4 @@
-MD5 408f28c0cfa39329e3b538a3e87261b9 ChangeLog 1987
+MD5 38aff74262dbd28f5d1ba5cf23ccdaf5 ChangeLog 1988
MD5 949388af68fa76905fde1e5c7c83170a yp-tools-2.7-r1.ebuild 1091
MD5 3721b19bbfd597cd528abeb52e1b6c50 yp-tools-2.7.ebuild 865
MD5 171cf64484d30a290ff82a843241fc3f yp-tools-2.8.ebuild 1022
diff --git a/net-nds/yp-tools/files/digest-yp-tools-2.8 b/net-nds/yp-tools/files/digest-yp-tools-2.8
new file mode 100644
index 000000000000..02ac929a83ce
--- /dev/null
+++ b/net-nds/yp-tools/files/digest-yp-tools-2.8
@@ -0,0 +1 @@
+MD5 4a6792c367a3e01e4af7b07f449039e9 yp-tools-2.8.tar.bz2 159738
diff --git a/net-nds/yp-tools/yp-tools-2.8.ebuild b/net-nds/yp-tools/yp-tools-2.8.ebuild
new file mode 100644
index 000000000000..8146fb392f6d
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Information Service tools"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${P}.tar.bz2"
+HOMEPAGE="http://www.linux-nis.org/nis"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf="--sysconfdir=/etc/yp"
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ mkdir intl
+ touch intl/libintl.h
+ export CPPFLAGS="${CPPFLAGS} -I${S}"
+
+ for i in lib/nicknames.c src/*.c
+ do
+ cp ${i} ${i}.orig
+ sed 's:<libintl.h>:<intl/libintl.h>:' \
+ ${i}.orig > ${i}
+ done
+ fi
+ econf ${myconf}
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING NEWS README THANKS TODO
+ insinto /etc/yp ; doins etc/nicknames
+ # This messes up boot so we remove it
+ rm -d ${D}/bin/ypdomainname
+ rm -d ${D}/bin/nisdomainname
+ rm -d ${D}/bin/domainname
+}