summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-09-22 00:34:32 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-09-22 00:34:32 +0000
commitf44754270872c263dcd300b714b201dbc6154b2a (patch)
tree7d934bb4c04925a8c3a2a49cce82985619a83352 /net-nds/openldap
parentFixing the ssh sandbox violation problem in vim (diff)
downloadhistorical-f44754270872c263dcd300b714b201dbc6154b2a.tar.gz
historical-f44754270872c263dcd300b714b201dbc6154b2a.tar.bz2
historical-f44754270872c263dcd300b714b201dbc6154b2a.zip
Make install fixes
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/ChangeLog12
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.25-r31
-rw-r--r--net-nds/openldap/openldap-2.0.25-r3.ebuild81
3 files changed, 93 insertions, 1 deletions
diff --git a/net-nds/openldap/ChangeLog b/net-nds/openldap/ChangeLog
index 8b6dec352557..7c8edc9500de 100644
--- a/net-nds/openldap/ChangeLog
+++ b/net-nds/openldap/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-nds/openldap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.11 2002/09/17 03:41:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.12 2002/09/22 00:34:32 g2boojum Exp $
+
+*openldap-2.0.25-r3 (21 Sept 2002)
+
+ 21 Sept 2002; Grant Goodyear <g2boojum@gentoo.org> openldap-2.0.25-r3.ebuild
+
+ Replaced entire make install section w/ "make DESTDIR=${D} install".
+ The previous version was putting ${D} in the /etc/openldap files, and
+ the simple fix seems to have solved the problem. I also checked, and
+ sysconfdir seems to be working correctly, so I don't think I've broken
+ Seemant's fix.
*openldap-2.0.25-r2 (15 Aug 2002)
diff --git a/net-nds/openldap/files/digest-openldap-2.0.25-r3 b/net-nds/openldap/files/digest-openldap-2.0.25-r3
new file mode 100644
index 000000000000..8f386fb0e4ef
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.25-r3
@@ -0,0 +1 @@
+MD5 57ed9ea3d872595076d6eab7b93337bd openldap-2.0.25.tgz 1304098
diff --git a/net-nds/openldap/openldap-2.0.25-r3.ebuild b/net-nds/openldap/openldap-2.0.25-r3.ebuild
new file mode 100644
index 000000000000..10204341c970
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.25-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.25-r3.ebuild,v 1.1 2002/09/22 00:34:32 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
+LICENSE="OPENLDAP"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ sasl? ( >=dev-libs/cyrus-sasl-1.5.27 )
+ berkdb? ( >=sys-libs/db-3.2.9 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ use tcpd \
+ && myconf="${myconf} --enable-wrappers" \
+ || myconf="${myconf} --disable-wrappers"
+
+ use ssl \
+ && myconf="${myconf} --with-tls" \
+ || myconf="${myconf} --without-tls"
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ if use berkdb; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=berkeley"
+ elif use gdbm; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ elif use ldap-none; then
+ myconf="${myconf} --disable-ldbm"
+ else
+ myconf="${myconf} --enable-ldbm --with-ldbmi-api=auto"
+ fi
+ use ipv6 && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+ use sasl && myconf="${myconf} --enable-cyrus-sasl" \
+ || myconf="${myconf} --disable-cyrus-sasl"
+
+
+ econf \
+ --enable-passwd \
+ --enable-shell \
+ --enable-shared \
+ --enable-static \
+ --localstatedir=/var/state/openldap \
+ --libexecdir=/usr/lib/openldap \
+ --sysconfdir=/etc \
+ ${myconf} || die "bad configure"
+
+ make depend || die
+ make || die
+ cd tests ; make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+}