summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-11-26 01:43:56 +0000
committerWout Mertens <wmertens@gentoo.org>2003-11-26 01:43:56 +0000
commit89bd8c829ac238d5747362d87a115e81cf51bd7c (patch)
treecda6e891e6a1ef30b0c2be87eef9292507f877ce /net-misc
parentversion bump + gcc 3.3.2 fix (diff)
downloadhistorical-89bd8c829ac238d5747362d87a115e81cf51bd7c.tar.gz
historical-89bd8c829ac238d5747362d87a115e81cf51bd7c.tar.bz2
historical-89bd8c829ac238d5747362d87a115e81cf51bd7c.zip
Version bump
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/ChangeLog8
-rw-r--r--net-misc/chrony/Manifest14
-rw-r--r--net-misc/chrony/chrony-1.20.ebuild45
3 files changed, 61 insertions, 6 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index c0bce1712d8d..03dbf939f005 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-misc/chrony
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.10 2003/10/06 21:40:54 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.11 2003/11/26 01:43:55 wmertens Exp $
+*chrony-1.20 (26 Nov 2003)
+
+ 26 Nov 2003; Wout Mertens <wmertens@gentoo.org> :
+ version bump. Should fix #33934 and #21058.
+ Some better RTC configuration thanks to Rob Davies, #28040.
+
06 Oct 2003; Jason Wever <weeve@gentoo.org> chrony-1.19.99.2.ebuild,
chrony-1.19.ebuild:
Marked 1.19.99.2 to stable and masked 1.19 to fix bug #30499.
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index 910b080b0ce1..e8eb72d73a2e 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -1,11 +1,15 @@
MD5 47278c251554b39e15d3180ac25728c5 ChangeLog 1316
-MD5 c544bd104710689a4e10b073324a0831 chrony-1.19.99.2.ebuild 1188
+MD5 c544bd104710689a4e10b073324a0831 chrony-1.20.ebuild 1188
MD5 ba43a52b9b5c1b07a57b1301a26fa544 chrony-1.19.ebuild 1183
-MD5 fa94342edcd12320e3fc947c7921c771 files/chrony-1.19-chrony.conf.example-gentoo.diff 1592
-MD5 b778857b5d802a10ec3e9ffd6ba9d226 files/chrony-1.19-conf.c-gentoo.diff 342
-MD5 fa94342edcd12320e3fc947c7921c771 files/chrony-1.19.99.2-chrony.conf.example-gentoo.diff 1592
-MD5 b778857b5d802a10ec3e9ffd6ba9d226 files/chrony-1.19.99.2-conf.c-gentoo.diff 342
+MD5 c544bd104710689a4e10b073324a0831 chrony-1.19.99.2.ebuild 1188
MD5 110ea7eae2031da898ff83f8ae47e22f files/chronyd.conf 258
+MD5 b778857b5d802a10ec3e9ffd6ba9d226 files/chrony-1.19.99.2-conf.c-gentoo.diff 342
MD5 e43a2a937eabda9d021429fe7f15ba22 files/chronyd.rc 1610
+MD5 530b19caa6b14e1501530401f8cdc986 files/digest-chrony-1.20 63
MD5 c0e426c615798b7c75afc3b1aadcd727 files/digest-chrony-1.19 63
+MD5 fa94342edcd12320e3fc947c7921c771 files/chrony-1.19-chrony.conf.example-gentoo.diff 1592
+MD5 b778857b5d802a10ec3e9ffd6ba9d226 files/chrony-1.19-conf.c-gentoo.diff 342
+MD5 fa94342edcd12320e3fc947c7921c771 files/chrony-1.19.99.2-chrony.conf.example-gentoo.diff 1592
MD5 3c6f0383871cdd1f005b04a37ccf1cfc files/digest-chrony-1.19.99.2 68
+MD5 fa94342edcd12320e3fc947c7921c771 files/chrony-1.20-chrony.conf.example-gentoo.diff 1592
+MD5 b778857b5d802a10ec3e9ffd6ba9d226 files/chrony-1.20-conf.c-gentoo.diff 342
diff --git a/net-misc/chrony/chrony-1.20.ebuild b/net-misc/chrony/chrony-1.20.ebuild
new file mode 100644
index 000000000000..57340923ac26
--- /dev/null
+++ b/net-misc/chrony/chrony-1.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.20.ebuild,v 1.1 2003/11/26 01:43:56 wmertens Exp $
+
+inherit eutils
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.sunsite.dk/"
+SRC_URI="http://chrony.sunsite.dk/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 sparc"
+IUSE="readline"
+
+DEPEND="virtual/glibc
+ readline? ( >=readline-4.1-r4 )"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-conf.c-gentoo.diff
+ epatch ${FILESDIR}/${P}-chrony.conf.example-gentoo.diff
+}
+
+src_compile() {
+ econf `use_enable readline` || die
+ emake all docs || die
+}
+
+src_install() {
+ # the chrony install is brain-dead so we'll just do it ourselves
+ dobin chronyc
+ dosbin chronyd
+
+ dodoc chrony.txt README examples/chrony.{conf,keys}.example
+ dohtml chrony.html
+ doman *.{1,5,8}
+ doinfo chrony.info*
+
+ dodir /etc/chrony
+ exeinto /etc/init.d ; newexe ${FILESDIR}/chronyd.rc chronyd
+ insinto /etc/conf.d ; newins ${FILESDIR}/chronyd.conf chronyd
+ dosed "s:the documentation directory:/usr/share/doc/${PF}/:" /etc/init.d/chronyd
+}