summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-11-10 22:51:46 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-11-10 22:51:46 +0000
commit62bc6085066357dc376e2f4e420c3294348482c9 (patch)
treed07dc6ff5900bb51c104a77e6b01ec9c60742e29 /net-misc/wget
parentRemoved IPV6 patch, caused wget to break ipv4 support. (diff)
downloadhistorical-62bc6085066357dc376e2f4e420c3294348482c9.tar.gz
historical-62bc6085066357dc376e2f4e420c3294348482c9.tar.bz2
historical-62bc6085066357dc376e2f4e420c3294348482c9.zip
Removed IPV6 patch, caused wget to break ipv4 support.
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/Manifest6
-rw-r--r--net-misc/wget/files/digest-wget-1.9-r21
-rw-r--r--net-misc/wget/wget-1.8.2-r2.ebuild51
-rw-r--r--net-misc/wget/wget-1.9-r2.ebuild62
4 files changed, 89 insertions, 31 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index cbe9158bc2e4..593c0e35aa2b 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,9 +1,9 @@
-MD5 07476203b1ac72d2e309b936514be363 ChangeLog 4051
-MD5 491244a20a74214af8d3925b92405f23 wget-1.8.2-r2.ebuild 1489
+MD5 d8e403041fce9a8e139d0384a7a99486 ChangeLog 4049
+MD5 f5aa635cf44fd78e4b7d92be4c6105ba wget-1.8.2-r2.ebuild 1490
MD5 11961cb8da0a697d08440e6f562a805a wget-1.8.2-r3.ebuild 1856
MD5 11a2d154392f421f59c74d6aee578868 wget-1.9.ebuild 1570
MD5 2b173c7a1e9e4a4a1aa7a6541b8c7316 wget-1.9-r1.ebuild 1587
-MD5 491244a20a74214af8d3925b92405f23 wget-1.9-r2.ebuild 1489
+MD5 1ef48be79d9503d3e8e1a1e6f39989c1 wget-1.9-r2.ebuild 1487
MD5 28f004e72194fae0e65365e48b867c83 files/digest-wget-1.8.2-r2 221
MD5 48b772b0df559de2f74806e618687ccb files/digest-wget-1.9 144
MD5 28f004e72194fae0e65365e48b867c83 files/digest-wget-1.8.2-r3 221
diff --git a/net-misc/wget/files/digest-wget-1.9-r2 b/net-misc/wget/files/digest-wget-1.9-r2
new file mode 100644
index 000000000000..6d14fc5e8e62
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.9-r2
@@ -0,0 +1 @@
+MD5 18ac093db70801b210152dd69b4ef08a wget-1.9.tar.gz 1315995
diff --git a/net-misc/wget/wget-1.8.2-r2.ebuild b/net-misc/wget/wget-1.8.2-r2.ebuild
index 98785b2092c2..22d9a29ee2b9 100644
--- a/net-misc/wget/wget-1.8.2-r2.ebuild
+++ b/net-misc/wget/wget-1.8.2-r2.ebuild
@@ -1,38 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r2.ebuild,v 1.13 2003/11/02 07:23:10 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r2.ebuild,v 1.14 2003/11/10 22:51:43 gregf Exp $
inherit gnuconfig
-NPVER=20011209
+IUSE="ssl nls static debug socks5"
+
+NPVER=20031022
DESCRIPTION="Network utility to retrieve files from the WWW"
HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
-SRC_URI="mirror://gnu/wget/${P}.tar.gz
- mirror://gentoo/wget-new-percentage-cvs-${NPVER}.tar.gz
- ipv6? mirror://gentoo/${P}-ipv6-debian.patch.bz2"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86 ppc sparc alpha hppa arm mips ia64"
-IUSE="ssl nls static ipv6 debug"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~amd64 ~ia64"
RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
DEPEND="nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
- cd ${S}/src
- epatch ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff
-
- if use ipv6
- then
- cd ${S}
- epatch ${WORKDIR}/${P}-ipv6-debian.patch
- fi
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${DISTDIR}/${P}+ipvmisc.patch
}
src_compile() {
@@ -40,17 +29,23 @@ src_compile() {
gnuconfig_update
local myconf
- use nls || myconf="--disable-nls"
- use ssl && myconf="${myconf} --with-ssl"
- use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
- use debug && myconf="${myconf} --disable-debug"
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+
use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
- ./configure --prefix=/usr --sysconfdir=/etc/wget \
- --infodir=/usr/share/info --mandir=usr/share/man $myconf || die
+
+ econf \
+ --sysconfdir=/etc/wget \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_with socks5 socks` \
+ ${myconf} || die
+
if use static; then
- make LDFLAGS="--static" || die
+ emake LDFLAGS="--static" || die
else
- make || die
+ emake || die
fi
}
diff --git a/net-misc/wget/wget-1.9-r2.ebuild b/net-misc/wget/wget-1.9-r2.ebuild
new file mode 100644
index 000000000000..0c2980e636f8
--- /dev/null
+++ b/net-misc/wget/wget-1.9-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9-r2.ebuild,v 1.1 2003/11/10 22:51:43 gregf Exp $
+
+inherit gnuconfig
+
+IUSE="ssl nls static debug socks5"
+
+NPVER=20031022
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~amd64 ~ia64"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ epatch ${DISTDIR}/${P}+ipvmisc.patch
+}
+
+src_compile() {
+ # Make wget use up-to-date configure scripts
+ gnuconfig_update
+
+ local myconf
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+
+ use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+
+ econf \
+ --sysconfdir=/etc/wget \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_with socks5 socks` \
+ ${myconf} || die
+
+ if use static; then
+ emake LDFLAGS="--static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ if use build; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+ make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}