summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-11 17:07:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-11 17:07:47 +0000
commit25554748dabe19610605a991a5049750aa215d7c (patch)
tree0304cc02547a6637483e7315986d40578b2ef647 /net-misc/vnc/vnc-3.3.3-r2.ebuild
parentdigests for both files -- the main tarball and the optional tarball (diff)
downloadhistorical-25554748dabe19610605a991a5049750aa215d7c.tar.gz
historical-25554748dabe19610605a991a5049750aa215d7c.tar.bz2
historical-25554748dabe19610605a991a5049750aa215d7c.zip
cleaned up syntax and dependency information
Diffstat (limited to 'net-misc/vnc/vnc-3.3.3-r2.ebuild')
-rw-r--r--net-misc/vnc/vnc-3.3.3-r2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-misc/vnc/vnc-3.3.3-r2.ebuild b/net-misc/vnc/vnc-3.3.3-r2.ebuild
index 5850a5edb72e..e916d030587a 100644
--- a/net-misc/vnc/vnc-3.3.3-r2.ebuild
+++ b/net-misc/vnc/vnc-3.3.3-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Grant Goodyear <g2boojum@hotmail.com>
# /home/cvsroot/gentoo-x86/skel.build,v 1.2 2001/02/15 18:17:31 achim Exp
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.3-r2.ebuild,v 1.5 2001/10/06 15:30:16 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vnc/vnc-3.3.3-r2.ebuild,v 1.6 2002/04/11 17:07:47 seemant Exp $
#P=
@@ -12,7 +12,7 @@ DESCRIPTION=""
SRC_URI="http://www.uk.research.att.com/vnc/dist/${A}"
HOMEPAGE="http://www.uk.research.att.com/vnc/index.html"
-DEPEND=""
+DEPEND="virtual/x11"
src_compile() {
@@ -25,18 +25,18 @@ src_compile() {
#insist that the machine is an i386 for the Xvnc build
sed -e '/#ifdef linux/a\# define i386' Imake.cf.orig > Imake.cf
cd ${S}
- try xmkmf
+ xmkmf || die
#FIXME: my dirty little fix to fix imake brain damage
- try make Makefiles
- try make depend
+ make Makefiles || die
+ make depend || die
cp ${FILESDIR}/vncviewer-makefile-3.3.3r2 ${S}/vncviewer/Makefile
- try make all
+ make all || die
#FIXME: Xvnc build doesn't respect user CFLAGS settings
cd Xvnc
- try make World
+ make World || die
}
@@ -44,7 +44,7 @@ src_install () {
cd ${S}
mkdir -p ${D}/usr/bin
- try ./vncinstall ${D}/usr/bin
+ ./vncinstall ${D}/usr/bin || die
}