summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-06-11 00:11:33 +0000
committerNed Ludd <solar@gentoo.org>2003-06-11 00:11:33 +0000
commitc9955804b295b64337cb67f401c71053aad9e78b (patch)
tree58596fe741e720ab4eb56a89a470f1f21d9d75d6 /net-misc/vconfig
parentUpdate to get vconfig to install into /sbin vs /usr/sbin (planning for suppor... (diff)
downloadhistorical-c9955804b295b64337cb67f401c71053aad9e78b.tar.gz
historical-c9955804b295b64337cb67f401c71053aad9e78b.tar.bz2
historical-c9955804b295b64337cb67f401c71053aad9e78b.zip
Update to get vconfig to install into /sbin vs /usr/sbin (planning for support of init scripts)
Diffstat (limited to 'net-misc/vconfig')
-rw-r--r--net-misc/vconfig/Manifest4
-rw-r--r--net-misc/vconfig/files/digest-vconfig-1.7-r11
-rw-r--r--net-misc/vconfig/vconfig-1.7-r1.ebuild43
3 files changed, 46 insertions, 2 deletions
diff --git a/net-misc/vconfig/Manifest b/net-misc/vconfig/Manifest
index f8d73a0befda..67caace4dc8c 100644
--- a/net-misc/vconfig/Manifest
+++ b/net-misc/vconfig/Manifest
@@ -1,5 +1,5 @@
MD5 2ffc3e5cef7d31ae094f6df8c564fc10 vconfig-1.7.ebuild 967
-MD5 84833dc4daf0f9302f01c9a5e76ceab5 ChangeLog 458
-MD5 a8739e9529deb1f6d71eb93b4ccd288e vconfig-1.7-r1.ebuild 1317
+MD5 ca58bb5cf8cae10bacf6671a37fb0a8a ChangeLog 832
+MD5 111e800d9a45e2d003e424bbbab05b49 vconfig-1.7-r1.ebuild 1320
MD5 f2bc7516c2dfe6d1722ef5cc7c546488 files/digest-vconfig-1.7 59
MD5 f2bc7516c2dfe6d1722ef5cc7c546488 files/digest-vconfig-1.7-r1 59
diff --git a/net-misc/vconfig/files/digest-vconfig-1.7-r1 b/net-misc/vconfig/files/digest-vconfig-1.7-r1
new file mode 100644
index 000000000000..aa2b9ea445e4
--- /dev/null
+++ b/net-misc/vconfig/files/digest-vconfig-1.7-r1
@@ -0,0 +1 @@
+MD5 5c32d84f290162322e16097ff50865bb vlan.1.7.tar.gz 90041
diff --git a/net-misc/vconfig/vconfig-1.7-r1.ebuild b/net-misc/vconfig/vconfig-1.7-r1.ebuild
new file mode 100644
index 000000000000..990b570978a9
--- /dev/null
+++ b/net-misc/vconfig/vconfig-1.7-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vconfig/vconfig-1.7-r1.ebuild,v 1.1 2003/06/11 00:11:25 solar Exp $
+
+MY_PN="vlan"
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="802.1Q vlan control utility"
+HOMEPAGE="http://www.candelatech.com/~greear/vlan.html"
+SRC_URI="http://www.candelatech.com/~greear/vlan/${MY_PN}.${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~arm"
+IUSE="static"
+DEPEND=">=sys-kernel/linux-headers-2.4.14"
+RDEPEND=">=virtual/kernel-2.4.14"
+
+src_compile() {
+ use static && LDFLAGS="${LDFLAGS} -static"
+ emake CC="gcc" CCFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ into /
+ dosbin vconfig || die "dosbin error"
+
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:" \
+ < vlan_test.pl > vlan_test.pl~ && \
+ mv vlan_test.pl~ vlan_test.pl
+ sed -e "s:/usr/local/bin/vconfig:/sbin/vconfig:" \
+ < vlan_test2.pl > vlan_test2.pl~ && \
+ mv vlan_test2.pl~ vlan_test2.pl
+
+ doman vconfig.8 || die "doman error"
+ dohtml howto.html vlan.html || die "dohtml error"
+ dodoc CHANGELOG README vlan_test*.pl || die "dodoc error"
+
+}
+
+pkg_postinst() {
+ einfo "802.1Q VLAN support is now in the linux kernel as of 2.4.14."
+ ewarn "But MTU problems exist for many ethernet drivers"
+}