summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-27 02:16:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-27 02:16:30 +0000
commite38d9b8a026fdd221eb24880cac1c7e3c76b9a7a (patch)
tree2ff7ff79ac6d62a869cf2cb7c5802f60f94b6c02 /net-misc/pavuk
parentrepoman fix (diff)
downloadhistorical-e38d9b8a026fdd221eb24880cac1c7e3c76b9a7a.tar.gz
historical-e38d9b8a026fdd221eb24880cac1c7e3c76b9a7a.tar.bz2
historical-e38d9b8a026fdd221eb24880cac1c7e3c76b9a7a.zip
repoman fix
Diffstat (limited to 'net-misc/pavuk')
-rw-r--r--net-misc/pavuk/pavuk-0.9.28.ebuild33
1 files changed, 12 insertions, 21 deletions
diff --git a/net-misc/pavuk/pavuk-0.9.28.ebuild b/net-misc/pavuk/pavuk-0.9.28.ebuild
index 7b5e6820fd67..d37a0da59121 100644
--- a/net-misc/pavuk/pavuk-0.9.28.ebuild
+++ b/net-misc/pavuk/pavuk-0.9.28.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header:
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pavuk/pavuk-0.9.28.ebuild,v 1.3 2003/03/27 02:16:30 seemant Exp $
IUSE="ssl X gtk gnome mozilla socks5 nls"
+S="${WORKDIR}/${PN}-0.9pl28"
DESCRIPTION="Web spider and website mirroring tool"
-SRC_URI="http://www.pavuk.org/sw/${PN}-0.9pl28.tgz"
-
HOMEPAGE="http://www.pavuk.org/"
+SRC_URI="http://www.pavuk.org/sw/${PN}-0.9pl28.tgz"
-S="${WORKDIR}/${PN}-0.9pl28"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc sparc64"
+KEYWORDS="x86 ppc sparc"
-DEPEND="sys-devel/gettext
+DEPEND=">=sys-apps/sed-4.0.5
+ sys-devel/gettext
sys-libs/zlib
ssl? ( dev-libs/openssl )
X? ( virtual/x11 )
@@ -23,13 +23,6 @@ DEPEND="sys-devel/gettext
mozilla? ( net-www/mozilla )
socks5? ( net-misc/tsocks )"
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
-}
-
src_compile() {
local myconf
@@ -63,7 +56,7 @@ src_compile() {
&& myconf="${myconf} --enable-nls" \
|| myconf="${myconf} --disable-nls"
- econf ${myconf}
+ econf ${myconf} || die
emake || die
}
@@ -71,16 +64,14 @@ src_compile() {
src_install() {
# fix sandbox volation for gnome .desktop and icon
- use gnome \
- && mv Makefile Makefile.orig \
- && mv icons/Makefile icons/Makefile.orig \
- && sed -e 's/GNOME_PREFIX = \/usr/GNOME_PREFIX = ${D}usr/' Makefile.orig >Makefile \
- && sed -e 's/GNOME_PREFIX = \/usr/GNOME_PREFIX = ${D}usr/' icons/Makefile.orig >icons/Makefile
+ if use gnome
+ then
+ sed -i 's:GNOME_PREFIX = /usr:GNOME_PREFIX = ${D}usr:' Makefile
+ sed -i 's:GNOME_PREFIX = /usr:GNOME_PREFIX = ${D}usr:' icons/Makefile
- einstall
+ einstall || die
dodoc ABOUT-NLS README CREDITS FAQ NEWS AUTHORS COPYING BUGS \
TODO MAILINGLIST ChangeLog wget-pavuk.HOWTO jsbind.txt \
pavuk_authinfo.sample pavukrc.sample
}
-