summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-28 05:40:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-28 05:40:50 +0000
commit7c92a05bcb102dc1c867c0d331ab8f00f03818a0 (patch)
tree1ee655555e85e5f484869cfee7ed2c3e4ac873ee /net-misc/mDNSResponder/mDNSResponder-107.5.ebuild
parentGrab fix from upstream #127547 by TGL. (diff)
downloadhistorical-7c92a05bcb102dc1c867c0d331ab8f00f03818a0.tar.gz
historical-7c92a05bcb102dc1c867c0d331ab8f00f03818a0.tar.bz2
historical-7c92a05bcb102dc1c867c0d331ab8f00f03818a0.zip
Version bump, thanks to Beech Horn in bug #126167 for notifying and forwardporting the makefiles patch; also now uses gcc to link and respect CC, CFLAGS and LDFLAGS, and doesn't strip.
Package-Manager: portage-2.1_pre7-r2
Diffstat (limited to 'net-misc/mDNSResponder/mDNSResponder-107.5.ebuild')
-rw-r--r--net-misc/mDNSResponder/mDNSResponder-107.5.ebuild105
1 files changed, 105 insertions, 0 deletions
diff --git a/net-misc/mDNSResponder/mDNSResponder-107.5.ebuild b/net-misc/mDNSResponder/mDNSResponder-107.5.ebuild
new file mode 100644
index 000000000000..bb442787b73b
--- /dev/null
+++ b/net-misc/mDNSResponder/mDNSResponder-107.5.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mDNSResponder/mDNSResponder-107.5.ebuild,v 1.1 2006/03/28 05:40:50 flameeyes Exp $
+
+inherit eutils multilib base toolchain-funcs flag-o-matic
+
+DESCRIPTION="The mDNSResponder project is a component of Bonjour, Apple's initiative for zero-configuration networking."
+HOMEPAGE="http://developer.apple.com/networking/bonjour/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="APSL-2 BSD"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug java"
+
+PATCHES="${FILESDIR}/${P}-Makefiles.patch"
+
+pkg_setup() {
+ if use elibc_FreeBSD; then
+ os=freebsd
+ else
+ os=linux
+ fi
+}
+
+mdnsmake() {
+ local debug, jdk
+ use java && jdk='JDK=$(java-config -O)'
+ use debug && debug='DEBUG=1'
+ einfo "Running emake " os="${os}" CC="$(tc-getCC)" LD="$(tc-getCC) -shared" \
+ ${jdk} ${debug} OPT_CFLAGS="${CFLAGS}" LIBFLAGS="${LDFLAGS}" STRIP="true" "$@"
+ emake os="${os}" CC="$(tc-getCC)" LD="$(tc-getCC) -shared" \
+ ${jdk} ${debug} OPT_CFLAGS="${CFLAGS}" LIBFLAGS="${LDFLAGS}" STRIP="true" "$@"
+}
+
+src_compile() {
+ cd ${S}/mDNSPosix
+ mdnsmake || die "make mDNSPosix failed"
+
+ if use java; then
+ mdnsmake Java || die "make mDNSPosix java failed"
+ fi
+
+ cd ${S}/Clients
+ mdnsmake || die "make Clients failed"
+}
+
+src_install() {
+ cd "${S}/mDNSPosix"
+
+ dodir /usr/sbin
+ dodir /usr/lib
+ dodir /usr/include
+ dodir /lib
+ dodir /etc
+ dodir /usr/share/man/man5
+ dodir /usr/share/man/man8
+
+ local debug
+ local objdir="prod"
+ if use debug; then
+ debug="DEBUG=1"
+ objdir=debug
+ fi
+
+ make DESTDIR="${D}" os=${os} ${debug} install || die "install failed"
+
+ dosbin ${S}/mDNSPosix/build/${objdir}/dnsextd
+ dosbin ${S}/mDNSPosix/build/${objdir}/mDNSResponderPosix
+ dosbin ${S}/mDNSPosix/build/${objdir}/mDNSNetMonitor
+
+ dobin ${S}/Clients/build/dns-sd
+ dobin ${S}/mDNSPosix/build/${objdir}/mDNSProxyResponderPosix
+ dobin ${S}/mDNSPosix/build/${objdir}/mDNSIdentify
+
+ newinitd ${FILESDIR}/mdnsd.init.d mdnsd
+ newinitd ${FILESDIR}/mDNSResponderPosix.init.d mDNSResponderPosix
+ newconfd ${FILESDIR}/mDNSResponderPosix.conf.d mDNSResponderPosix
+ newinitd ${FILESDIR}/dnsextd.init.d dnsextd
+ newconfd ${FILESDIR}/dnsextd.conf.d dnsextd
+
+ insinto /etc
+ doins ${FILESDIR}/mDNSResponderPosix.conf
+
+ dodoc ${S}/README.txt
+
+ # Fix multilib-strictness
+ mv ${D}/lib ${D}/$(get_libdir)
+ mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+
+ if use java; then
+ java-pkg_dojar ${S}/mDNSPosix/build/prod/dns_sd.jar
+ java-pkg_doso ${S}/mDNSPosix/build/prod/libjdns_sd.so
+ fi
+
+}
+
+pkg_postinst() {
+ echo
+ einfo "To enable multicast dns lookups for applications"
+ einfo "that are not multicast dns aware, edit the 'hosts:'"
+ einfo "line in /etc/nsswitch.conf to include 'mdns', e.g.:"
+ einfo "hosts: files mdns dns"
+ echo
+}