summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-05-03 09:26:53 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-05-03 09:26:53 +0000
commitc962b5c1abd91955f8bb65136fc47415bf7fe862 (patch)
tree8b7c52f3d5d8e3eeade6ca8722d7bafe59bf9b33 /net-misc/l7-protocols/l7-protocols-2008.04.23.ebuild
parentSupport also heimdal's krb5 implementation (fixes bug #210762) + some QA (diff)
downloadhistorical-c962b5c1abd91955f8bb65136fc47415bf7fe862.tar.gz
historical-c962b5c1abd91955f8bb65136fc47415bf7fe862.tar.bz2
historical-c962b5c1abd91955f8bb65136fc47415bf7fe862.zip
version bump
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'net-misc/l7-protocols/l7-protocols-2008.04.23.ebuild')
-rw-r--r--net-misc/l7-protocols/l7-protocols-2008.04.23.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/l7-protocols/l7-protocols-2008.04.23.ebuild b/net-misc/l7-protocols/l7-protocols-2008.04.23.ebuild
new file mode 100644
index 000000000000..f5c2a5c1253f
--- /dev/null
+++ b/net-misc/l7-protocols/l7-protocols-2008.04.23.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/l7-protocols/l7-protocols-2008.04.23.ebuild,v 1.1 2008/05/03 09:26:53 dragonheart Exp $
+
+inherit eutils fixheadtails toolchain-funcs
+
+IUSE=""
+
+MY_P=${PN}-${PV//./-}
+
+DESCRIPTION="Protocol definitions of l7-filter kernel modules"
+HOMEPAGE="http://l7-filter.sourceforge.net/protocols"
+
+SRC_URI="mirror://sourceforge/l7-filter/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s/gcc.*\-o/$(tc-getCC) ${CFLAGS} -o/g" \
+ -e "s/g++.*\-o/$(tc-getCXX) ${CXXFLAGS} -o/g" testing/Makefile
+ ht_fix_file testing/*.sh
+}
+
+src_compile() {
+ emake -C testing || die
+}
+
+# NOTE Testing mechanism is currently broken:
+# stack smashing attack in function main()
+
+# Is also extraordinarly inefficent getting random data.
+#
+#src_test() {
+# cd testing
+# find ${S} -name \*.pat -print -exec ./test_match.sh {} \; \
+# -exec ./timeit.sh {} \; || die "failed tests"
+# einfo "patterns past testing"
+#}
+
+src_install() {
+ dodir /usr/share/${PN}
+ pushd testing > /dev/null
+ cp -pPR randprintable randchars test_speed-{kernel,userspace} README \
+ match_kernel speeds-2007-10-02-450MHz *.sh data "${D}"/usr/share/${PN}
+ popd > /dev/null
+ mv example_traffic "${D}"/usr/share/${PN}
+
+ dodoc README CHANGELOG HOWTO WANTED
+ for dir in extra file_types malware ; do
+ newdoc ${dir}/README README.${dir}
+ done
+ rm -rf README CHANGELOG HOWTO LICENSE Makefile WANTED */README testing
+
+ dodir /etc/l7-protocols
+ cp -R * "${D}"/etc/l7-protocols
+ chown -R root:0 "${D}"
+}