summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-05 09:48:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-05 09:48:41 +0000
commitf90b870b6fe70fd57e3995e0606aab5df7315636 (patch)
tree318f703a023c6fe46c82c5d0cf28aea1ee0ff74c /net-mail
parentinitial ebuild, based on bug #5641, with major changes, upstream package is s... (diff)
downloadhistorical-f90b870b6fe70fd57e3995e0606aab5df7315636.tar.gz
historical-f90b870b6fe70fd57e3995e0606aab5df7315636.tar.bz2
historical-f90b870b6fe70fd57e3995e0606aab5df7315636.zip
initial ebuild, based on bug #5641, with major changes, upstream package is still somewhat broken presently.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/vqadmin/Manifest4
-rw-r--r--net-mail/vqadmin/files/digest-vqadmin-2.3.61
-rw-r--r--net-mail/vqadmin/metadata.xml9
-rw-r--r--net-mail/vqadmin/vqadmin-2.3.6.ebuild119
4 files changed, 132 insertions, 1 deletions
diff --git a/net-mail/vqadmin/Manifest b/net-mail/vqadmin/Manifest
index 35bb78bf8257..60bfb58644a2 100644
--- a/net-mail/vqadmin/Manifest
+++ b/net-mail/vqadmin/Manifest
@@ -1,2 +1,4 @@
-MD5 f4594ac61a92710d1840de3be7d40e94 vqadmin-2.3.6.ebuild 3641
+MD5 a137d9e073cbe0f423e70a7ba5bdcc8b vqadmin-2.3.6.ebuild 3793
+MD5 d9f0d360f35620b4f86104899d2d5405 ChangeLog 449
+MD5 9d0c568ea32cf6b45797c6e7c82b4a67 metadata.xml 280
MD5 5386ce666835112ea27392ad947aceca files/digest-vqadmin-2.3.6 65
diff --git a/net-mail/vqadmin/files/digest-vqadmin-2.3.6 b/net-mail/vqadmin/files/digest-vqadmin-2.3.6
new file mode 100644
index 000000000000..b1f2fd296b3d
--- /dev/null
+++ b/net-mail/vqadmin/files/digest-vqadmin-2.3.6
@@ -0,0 +1 @@
+MD5 b808aabaf3f6eee8633217b50cb40f25 vqadmin-2.3.6.tar.gz 155771
diff --git a/net-mail/vqadmin/metadata.xml b/net-mail/vqadmin/metadata.xml
new file mode 100644
index 000000000000..89dcd746873c
--- /dev/null
+++ b/net-mail/vqadmin/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-mail/vqadmin/vqadmin-2.3.6.ebuild b/net-mail/vqadmin/vqadmin-2.3.6.ebuild
new file mode 100644
index 000000000000..e6b91e213216
--- /dev/null
+++ b/net-mail/vqadmin/vqadmin-2.3.6.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vqadmin/vqadmin-2.3.6.ebuild,v 1.1 2004/01/05 09:48:33 robbat2 Exp $
+
+inherit gnuconfig
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A web based control pannel to manage Virtual Qmail Domains. Works with qmailadmin"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.inter7.com/${PN}"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND=">=net-mail/vpopmail-5.3
+ net-mail/qmail"
+RDEPEND="${DEPEND}
+ net-mail/qmailadmin
+ net-www/apache"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
+src_compile() {
+ local dir_vhost="/var/www/localhost/"
+ local dir_vpopmail="/var/vpopmail"
+ local dir_htdocs="${dir_vhost}/htdocs/${PN}"
+ local dir_htdocs_images="${dir_htdocs}/images"
+ local url_htdocs_images="/${PN}/images"
+ local dir_cgibin="${dir_vhost}/cgi-bin"
+ local url_cgibin="/cgi-bin/${PN}"
+ local dir_htdocs_htmlib="/usr/share/${PN}/htmllib"
+ local dir_qmail="/var/qmail"
+ local bin_true="/bin/true"
+ local dir_ezmlm="/usr/bin"
+ local dir_autorespond="/var/qmail/bin"
+ sed -e "3356iwwwroot='${dir_htdocs}'" -e '3356,3369d' -i configure || die "failed to fix configure"
+
+ find . -name 'Makefile*' -o -name '*.c' -o -name '*.html' | xargs -n1 -t sed 's|images/vqadmin|vqadmin/images|g' -i
+
+ econf ${myopts} \
+ --enable-vpopmaildir=${dir_vpopmail} \
+ --enable-htmldir=${dir_htdocs} \
+ --enable-imageurl=${url_htdocs_images} \
+ --enable-imagedir=${dir_htdocs_images} \
+ --enable-htmllibdir=${dir_htdocs_htmlib} \
+ --enable-qmaildir=${dir_qmail} \
+ --enable-true-path=${bin_true} \
+ --enable-ezmlmdir=${dir_ezmlm} \
+ --enable-cgibindir=${dir_cgibin} \
+ --enable-cgipath=${url_cgibin} \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ || die "econf failed"
+
+ sed 's|/vqadmin/vqadmin/|/vqadmin/|g' -i Makefile
+
+ emake || die
+ sed -e "/install-exec-local:/,/chmod go+r/s|${dir_vhost}|\$(DESTDIR)${dir_vhost}|" -i Makefile
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ dodoc ACL AUTHORS BUGS LICENSE ChangeLog FAQ INSTALL NEWS TODO README
+}
+
+#pkg_config() {
+#
+# einfo "Performing post-installation routines for ${P}."
+#
+# cat > ${REAL_CGIBINDIR}/vqadmin/vqadmin.conf <<EOF
+#<Directory "${REAL_CGIBINDIR}/vqadmin">
+# deny from all
+# Options ExecCGI
+# AllowOverride AuthConfig
+# Order deny,allow
+#</Directory>
+#EOF
+#
+# # Including configuration to the apache config file
+# echo "Include ${REAL_CGIBINDIR}/vqadmin/vqadmin.conf" >> /etc/apache/conf/apache.conf
+#
+# # Creating .htaccess
+# einfo ""
+# einfo "We need to create an htaccess for the directory so Apache knows"
+# einfo "how to authenticate users trying to access the directory."
+# cat > ${REAL_CGIBINDIR}/vqadmin/.htaccess <<EOF
+#AuthType Basic
+#AuthUserFile /etc/apache/conf/vqadmin.passwd
+#AuthName vqadmin
+#require valid-user
+#satisfy any
+#EOF
+# # Tightening Permissions
+# chown apache.apache ${REAL_CGIBINDIR}/vqadmin/.htaccess
+# chmod 600 ${REAL_CGIBINDIR}/vqadmin/.htaccess
+#
+# # How set up users ?
+# einfo "Now, You can create a user. Example: "
+# einfo " htpasswd -c /etc/apache/conf/vqadmin.passwd username"
+# einfo "then: "
+# einfo " cd /etc/apache/conf/ && chown root.apache vqadmin.passwd"
+# einfo " chmod 640 vqadmin.passwd"
+# einfo ""
+# einfo "IMPORTANT ! Use the -c (-create) switch ONLY the first time"
+# einfo "IMPORTANT ! You will have to restart apache to get vqadmin working"
+#}
+
+#pkg_postrm() {
+# rm -rf ${REAL_CGIBINDIR}/vqadmin/vqadmin.conf
+# rm -rf ${REAL_CGIBINDIR}/vqadmin/.htaccess
+# rmdir ${REAL_CGIBINDIR}/vqadmin
+# sed "/^Include.*vqadmin.conf$/d" /etc/apache/conf/apache.conf > /etc/apache/conf/apache.conf.new
+# mv --force /etc/apache/conf/apache.conf.new /etc/apache/conf/apache.conf
+#}