summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-15 23:46:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-15 23:46:06 +0000
commit4bfb6a333cab608e7608ac3b6259923b676145ae (patch)
treebcdc140d0b08f025eaab858292ff9a4037df5b36 /net-mail/postfix
parentlame USE flag replaced by encode USE flag (diff)
downloadhistorical-4bfb6a333cab608e7608ac3b6259923b676145ae.tar.gz
historical-4bfb6a333cab608e7608ac3b6259923b676145ae.tar.bz2
historical-4bfb6a333cab608e7608ac3b6259923b676145ae.zip
Changed the USE flags from mta-ldap, mta-tls, and mta-mysql to ldap, ssl, and mysql respectively
Diffstat (limited to 'net-mail/postfix')
-rw-r--r--net-mail/postfix/ChangeLog11
-rw-r--r--net-mail/postfix/files/digest-postfix-1.1.7-r22
-rw-r--r--net-mail/postfix/postfix-1.1.7-r2.ebuild130
3 files changed, 142 insertions, 1 deletions
diff --git a/net-mail/postfix/ChangeLog b/net-mail/postfix/ChangeLog
index cad8d6a12fdb..dbda2c43cc52 100644
--- a/net-mail/postfix/ChangeLog
+++ b/net-mail/postfix/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-mail/postfix
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.11 2002/04/11 16:57:47 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/ChangeLog,v 1.12 2002/04/15 23:46:06 seemant Exp $
+
+*postfix-1.1.7-r2 (15 Apr 2002)
+
+ 15 Apr 2002; Seemant Kulleen <seemant@gentoo.org>
+ postfix-1.1.7-r2.ebuild files/digest-postfix-1.1.7-r2 :
+ Changed the USE flags from mta-ldap, mta-tls, and mta-mysql to ldap, ssl, and
+ mysql respectively. Also, changed the checks to the official use foo &&
+ syntax. This has the added advantage of showing the USE flags being used
+ during the emerge process.
11 Apr 2002; Seemant Kulleen <seemant@gentoo.org>
files/digest-postfix-1.1.7-r1 :
diff --git a/net-mail/postfix/files/digest-postfix-1.1.7-r2 b/net-mail/postfix/files/digest-postfix-1.1.7-r2
new file mode 100644
index 000000000000..9d34ea6d05c2
--- /dev/null
+++ b/net-mail/postfix/files/digest-postfix-1.1.7-r2
@@ -0,0 +1,2 @@
+MD5 320ea040f13c084a5e8bea680b422e06 postfix-1.1.7.tar.gz 1186995
+MD5 a00656e4e7fd1e4827c3e805799d2359 pfixtls-0.8.7-1.1.7-0.9.6c.tar.gz 195132
diff --git a/net-mail/postfix/postfix-1.1.7-r2.ebuild b/net-mail/postfix/postfix-1.1.7-r2.ebuild
new file mode 100644
index 000000000000..b3f00e68e0de
--- /dev/null
+++ b/net-mail/postfix/postfix-1.1.7-r2.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix/postfix-1.1.7-r2.ebuild,v 1.1 2002/04/15 23:46:06 seemant Exp $
+
+DESCRIPTION="A fast and secure drop-in replacement for sendmail"
+HOMEPAGE="http://www.postfix.org/"
+
+POSTFIX_TLS_VER="0.8.7-${PV}-0.9.6c"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.porcupine.org/mirrors/postfix-release/official/${P}.tar.gz
+ ssl? ( ftp://ftp.aet.tu-cottbus.de/pub/postfix_tls/pfixtls-${POSTFIX_TLS_VER}.tar.gz )"
+
+PROVIDE="virtual/mta"
+DEPEND=">=sys-libs/db-3.2
+ >=dev-libs/libpcre-3.4
+ >=dev-libs/cyrus-sasl-1.5.27
+ ldap? ( >=net-nds/openldap-1.2 )
+ mysql? ( >=dev-db/mysql-3.23.28 )
+ ssl? ( >=dev-libs/openssl-0.9.6c )"
+
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00
+ !virtual/mta"
+
+pkg_setup() {
+ if ! grep -q ^postdrop: /etc/group ; then
+ groupadd postdrop || die "problem adding group postdrop"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ use ssl && ( \
+ cd ${S}
+ patch -p1 < ${WORKDIR}/pfixtls-${POSTFIX_TLS_VER}/pfixtls.diff || die
+ )
+
+ cd ${S}/conf
+ cp main.cf main.cf.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" main.cf.orig > main.cf
+
+ cd ${S}/src/global
+ cp mail_params.h mail_params.h.orig
+ sed -e "s:/usr/libexec/postfix:/usr/lib/postfix:" mail_params.h.orig > mail_params.h
+
+ use mysql \
+ && CCARGS="${CCARGS} -DHAS_MYSQL -I/usr/include/mysql" \
+ && AUXLIBS="${AUXLIBS} -lmysqlclient -lm"
+
+ use ldap \
+ && CCARGS="${CCARGS} -DHAS_LDAP" \
+ && AUXLIBS="${AUXLIBS} -lldap -llber"
+
+ use ssl \
+ && CCARGS="${CCARGS} -DHAS_SSL" \
+ && AUXLIBS="${AUXLIBS} -lssl"
+
+ # note: if sasl is built w/ pam, then postfix _MUST_ be built w/ pam
+ use pam \
+ && AUXLIBS="${AUXLIBS} -lpam"
+
+ # stuff we always want...
+ CCARGS="${CCARGS} -I/usr/include -DHAS_PCRE -DUSE_SASL_AUTH"
+ AUXLIBS="${AUXLIBS} -L/usr/lib -lpcre -lsasl -ldl -lcrypt"
+ DEBUG=""
+
+ cd ${S}
+ make tidy || die
+ make makefiles CC="cc" OPT="${CFLAGS}" DEBUG="${DEBUG}" \
+ CCARGS="${CCARGS}" AUXLIBS="${AUXLIBS}" || die
+}
+
+src_compile() {
+ emake || die "compile problem"
+}
+
+src_install () {
+ dodir /usr/bin /usr/sbin /usr/lib/postfix /etc/postfix/sample
+
+ cd ${S}/bin
+ dosbin post* sendmail
+ chown root.postdrop ${D}/usr/sbin/{postdrop,postqueue}
+ chmod 2755 ${D}/usr/sbin/{postdrop,postqueue}
+
+ dosym /usr/sbin/sendmail /usr/bin/mail
+ dosym /usr/sbin/sendmail /usr/bin/mailq
+ dosym /usr/sbin/sendmail /usr/bin/newaliases
+ dosym /usr/sbin/sendmail /usr/lib/sendmail
+
+ cd ${S}/libexec
+ exeinto /usr/lib/postfix
+ doexe *
+
+ cd ${S}/man
+ doman man*/*
+
+ cd ${S}
+ dodoc *README COMPATIBILITY HISTORY LICENSE PORTING RELEASE_NOTES
+ dohtml html/*
+
+ cd ${S}/conf
+ insinto /etc/postfix/sample
+ doins access aliases canonical relocated transport \
+ pcre_table regexp_table postfix-script* *.cf
+
+ exeinto /etc/postfix
+ doexe postfix-script post-install postfix-files || die
+
+ insinto /etc/postfix
+ doins ${FILESDIR}/main.cf master.cf || die
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/postfix.rc6 postfix
+ insinto /etc/pam.d ; newins ${FILESDIR}/smtp.pam smtp
+ insinto /etc/sasl ; doins ${FILESDIR}/smtpd.conf
+}
+
+pkg_postinst() {
+ install -d 0755 ${ROOT}/var/spool/postfix
+
+ einfo "***************************************************************"
+ einfo "* NOTE: If config file protection is enabled and you upgraded *"
+ einfo "* from an earlier version of postfix you must update *"
+ einfo "* /etc/postfix/master.cf to the latest version *"
+ einfo "* (/etc/postfix/._cfg????_master.cf). Otherwise postfix *"
+ einfo "* will not work correctly. *"
+ einfo "***************************************************************"
+}