summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-10-02 21:26:55 +0000
committerAron Griffis <agriffis@gentoo.org>2006-10-02 21:26:55 +0000
commitf7658de13853df37fd3ac60460129d50599efbe6 (patch)
tree4600d2bf1a685296a033d926877cae6bdcd95074 /net-mail/gnubiff/gnubiff-2.2.2.ebuild
parentBlock on older ant-tasks to prevent breakages during update, solves bug #149661. (diff)
downloadhistorical-f7658de13853df37fd3ac60460129d50599efbe6.tar.gz
historical-f7658de13853df37fd3ac60460129d50599efbe6.tar.bz2
historical-f7658de13853df37fd3ac60460129d50599efbe6.zip
Bump to 2.2.2 (from 2.2.1)
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'net-mail/gnubiff/gnubiff-2.2.2.ebuild')
-rw-r--r--net-mail/gnubiff/gnubiff-2.2.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-mail/gnubiff/gnubiff-2.2.2.ebuild b/net-mail/gnubiff/gnubiff-2.2.2.ebuild
new file mode 100644
index 000000000000..79be66cd3db9
--- /dev/null
+++ b/net-mail/gnubiff/gnubiff-2.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/gnubiff/gnubiff-2.2.2.ebuild,v 1.1 2006/10/02 21:26:55 agriffis Exp $
+
+inherit eutils
+
+DESCRIPTION="A mail notification program"
+HOMEPAGE="http://gnubiff.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE="debug fam gnome nls password"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3
+ dev-libs/popt
+ gnome? (
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2 )
+ password? ( dev-libs/openssl )
+ fam? ( virtual/fam )
+ || (
+ x11-proto/xproto
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ gnome? ( dev-util/pkgconfig )"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable gnome) \
+ $(use_enable nls) \
+ $(use_enable fam) \
+ $(use_with password) \
+ $(use_with password password-string ${RANDOM}${RANDOM}${RANDOM}${RANDOM}) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README THANKS TODO
+}