summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-12-22 22:43:11 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-12-22 22:43:11 +0000
commita2907a1ddfbdc489fe963c698f713f4813fcfd0f (patch)
treecd781c80268be478ae37fd7b2b6420a80fdf9589 /net-libs/stem/stem-1.3.0.ebuild
parentStable for amd64 wrt bug #518770 (diff)
downloadhistorical-a2907a1ddfbdc489fe963c698f713f4813fcfd0f.tar.gz
historical-a2907a1ddfbdc489fe963c698f713f4813fcfd0f.tar.bz2
historical-a2907a1ddfbdc489fe963c698f713f4813fcfd0f.zip
Version bump. Remove old.
Package-Manager: portage-2.2.15/cvs/Linux x86_64
Diffstat (limited to 'net-libs/stem/stem-1.3.0.ebuild')
-rw-r--r--net-libs/stem/stem-1.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/stem/stem-1.3.0.ebuild b/net-libs/stem/stem-1.3.0.ebuild
new file mode 100644
index 000000000000..e0c73a526aae
--- /dev/null
+++ b/net-libs/stem/stem-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/stem/stem-1.3.0.ebuild,v 1.1 2014/12/22 22:43:08 mrueg Exp $
+
+EAPI=5
+# Python3.3 fails to execute the test script
+PYTHON_COMPAT=(python2_7)
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-misc/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-misc/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+ sed -i -e "/test_expand_path/a \
+ \ \ \ \ return" test/integ/util/system.py || die
+ sed -i -e "/test_get_connections_by_ss/,+1d"\
+ test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}