summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2006-08-29 23:02:29 +0000
committerGustavo Felisberto <humpback@gentoo.org>2006-08-29 23:02:29 +0000
commit4338bc7231726f26bed65edf3c377004007bba12 (patch)
tree83b09e4c230dca0f6dc8b25ab0a6a55284ff7754 /net-libs/obby
parentremoved obby and gobby and net6 rc versions (diff)
downloadhistorical-4338bc7231726f26bed65edf3c377004007bba12.tar.gz
historical-4338bc7231726f26bed65edf3c377004007bba12.tar.bz2
historical-4338bc7231726f26bed65edf3c377004007bba12.zip
bump
Package-Manager: portage-2.1.1_rc1-r1
Diffstat (limited to 'net-libs/obby')
-rw-r--r--net-libs/obby/ChangeLog9
-rw-r--r--net-libs/obby/files/digest-obby-0.4.13
-rw-r--r--net-libs/obby/obby-0.4.1.ebuild43
3 files changed, 54 insertions, 1 deletions
diff --git a/net-libs/obby/ChangeLog b/net-libs/obby/ChangeLog
index 0d8bff7a68df..b51220b3af47 100644
--- a/net-libs/obby/ChangeLog
+++ b/net-libs/obby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/obby
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/ChangeLog,v 1.15 2006/08/29 13:50:29 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/ChangeLog,v 1.16 2006/08/29 23:02:28 humpback Exp $
+
+*obby-0.4.1 (29 Aug 2006)
+
+ 29 Aug 2006; Gustavo Felisberto <humpback@gentoo.org>; -obby-0.2.0.ebuild,
+ -obby-0.2.1.ebuild, -obby-0.3.0.ebuild, -obby-0.4.0_rc4.ebuild,
+ +obby-0.4.1.ebuild:
+ Removed old version and added new version that will be announced tomorow.
*obby-0.4.0_rc4 (29 Aug 2006)
diff --git a/net-libs/obby/files/digest-obby-0.4.1 b/net-libs/obby/files/digest-obby-0.4.1
new file mode 100644
index 000000000000..44c278884b36
--- /dev/null
+++ b/net-libs/obby/files/digest-obby-0.4.1
@@ -0,0 +1,3 @@
+MD5 b79146369fc76a61d6d4056a937c71c8 obby-0.4.1.tar.gz 469996
+RMD160 296e67fbe5b7ddf89068ac4b66aa27616148681b obby-0.4.1.tar.gz 469996
+SHA256 b69a259795762881a5384072085bb501d77c6fb974e0b7a16ca573565ffe3629 obby-0.4.1.tar.gz 469996
diff --git a/net-libs/obby/obby-0.4.1.ebuild b/net-libs/obby/obby-0.4.1.ebuild
new file mode 100644
index 000000000000..74fc9761aa68
--- /dev/null
+++ b/net-libs/obby/obby-0.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/obby-0.4.1.ebuild,v 1.1 2006/08/29 23:02:28 humpback Exp $
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+inherit eutils
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://darcs.0x539.de/libobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="howl"
+SRC_URI="http://releases.0x539.de/${PN}/${P/_/}.tar.gz"
+
+DEPEND=">=net-libs/net6-1.3.1
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ howl? ( >=net-misc/howl-0.9.8 )"
+
+RDEPEND=""
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+# cd ${S}
+# epatch ${FILESDIR}/dual_subscribe.patch
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} --disable-tests"
+ use howl && myconf="${myconf} --with-howl"
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}