summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-09-14 15:32:26 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-09-14 15:32:26 +0000
commitd14830b700d2ac1b71a51ba24801ea94e96bc56d (patch)
tree28a3519bc375d46ae33882e275abfaee9e364a4f /net-libs/libgsasl/libgsasl-0.2.28.ebuild
parentVersion bump. (diff)
downloadhistorical-d14830b700d2ac1b71a51ba24801ea94e96bc56d.tar.gz
historical-d14830b700d2ac1b71a51ba24801ea94e96bc56d.tar.bz2
historical-d14830b700d2ac1b71a51ba24801ea94e96bc56d.zip
Version bump
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'net-libs/libgsasl/libgsasl-0.2.28.ebuild')
-rw-r--r--net-libs/libgsasl/libgsasl-0.2.28.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libgsasl/libgsasl-0.2.28.ebuild b/net-libs/libgsasl/libgsasl-0.2.28.ebuild
new file mode 100644
index 000000000000..d6398dc7a1f9
--- /dev/null
+++ b/net-libs/libgsasl/libgsasl-0.2.28.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgsasl/libgsasl-0.2.28.ebuild,v 1.1 2008/09/14 15:32:26 dertobi123 Exp $
+
+DESCRIPTION="The GNU SASL library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="http://josefsson.org/gsasl/releases/${P}.tar.gz"
+LICENSE="LGPL-3"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+# * ntlm - libntlm ( http://josefsson.org/libntlm/ )
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="idn kerberos nls"
+PROVIDE="virtual/gsasl"
+DEPEND="nls? ( >=sys-devel/gettext-0.16.1 )
+ kerberos? ( virtual/krb5 )
+ idn? ( net-dns/libidn )"
+RDEPEND="${DEPEND}
+ !virtual/gsasl"
+
+src_compile() {
+ econf \
+ $(use_enable kerberos gssapi) \
+ $(use_enable kerberos kerberos_v5) \
+ $(use_with idn stringprep) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}