summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Fitzgerald <gregf@gentoo.org>2003-10-05 17:30:59 +0000
committerGreg Fitzgerald <gregf@gentoo.org>2003-10-05 17:30:59 +0000
commiteb83ac022843d09b0ddbccc1e55b0bd27b44f7fd (patch)
tree5834afebd70f1b3a3bd0adde97e529627016c959 /net-irc
parentFix for bug #30029 (diff)
downloadhistorical-eb83ac022843d09b0ddbccc1e55b0bd27b44f7fd.tar.gz
historical-eb83ac022843d09b0ddbccc1e55b0bd27b44f7fd.tar.bz2
historical-eb83ac022843d09b0ddbccc1e55b0bd27b44f7fd.zip
Fix for bug #30029
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi/Manifest4
-rw-r--r--net-irc/irssi/files/digest-irssi-0.8.6-r41
-rw-r--r--net-irc/irssi/irssi-0.8.6-r4.ebuild98
3 files changed, 101 insertions, 2 deletions
diff --git a/net-irc/irssi/Manifest b/net-irc/irssi/Manifest
index a33df3363f25..b5b69567133b 100644
--- a/net-irc/irssi/Manifest
+++ b/net-irc/irssi/Manifest
@@ -1,9 +1,9 @@
-MD5 776c067ae416fba431307f7bfb297a5a ChangeLog 4087
+MD5 d24f699f638392e78f76d32e70f60054 ChangeLog 4086
MD5 010f51ca1f64db3840d7d8ad57159429 irssi-0.8.5-r2.ebuild 1865
MD5 f8aa78b673a0a7536d33d273d37b1ba8 irssi-0.8.6-r2.ebuild 2372
MD5 ffeebf3d5d590c343d18887b3c595c42 irssi-0.8.6-r3.ebuild 2490
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
-MD5 95e4c560a0e985e16eb7a1b34af4b393 irssi-0.8.6-r4.ebuild 2470
+MD5 b0be3a93f4efacbe447f5e76dd6a7bfd irssi-0.8.6-r4.ebuild 2469
MD5 1920fb9f4aba0f95f26302d82430ffa8 files/digest-irssi-0.8.5-r2 64
MD5 cb17857da5af4446fef7e94d553277de files/digest-irssi-0.8.6-r2 64
MD5 cb17857da5af4446fef7e94d553277de files/digest-irssi-0.8.6-r3 64
diff --git a/net-irc/irssi/files/digest-irssi-0.8.6-r4 b/net-irc/irssi/files/digest-irssi-0.8.6-r4
new file mode 100644
index 000000000000..0ecb65f16bf8
--- /dev/null
+++ b/net-irc/irssi/files/digest-irssi-0.8.6-r4
@@ -0,0 +1 @@
+MD5 6d66982723e2eb8780ae3b8b3a7ba08d irssi-0.8.6.tar.bz2 746551
diff --git a/net-irc/irssi/irssi-0.8.6-r4.ebuild b/net-irc/irssi/irssi-0.8.6-r4.ebuild
new file mode 100644
index 000000000000..e5cafe9fb100
--- /dev/null
+++ b/net-irc/irssi/irssi-0.8.6-r4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi/irssi-0.8.6-r4.ebuild,v 1.1 2003/10/05 17:30:56 gregf Exp $
+
+IUSE="nls ipv6 perl ssl"
+
+inherit perl-module
+
+DESCRIPTION="A modular textUI IRC client with IPv6 support."
+SRC_URI="http://irssi.org/files/${P}.tar.bz2"
+HOMEPAGE="http://irssi.org/"
+
+DEPEND=">=dev-libs/glib-1.2
+ sys-libs/ncurses
+ >=sys-apps/sed-4
+ perl? ( dev-lang/perl )
+ ssl? ( dev-libs/openssl )
+ !net-irc/irssi-cvs"
+ #socks? ( >=net-misc/dante-1.1.13 )
+RDEPEND="nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ppc sparc alpha hppa mips amd64 ia64"
+
+src_unpack() {
+ unpack ${A}
+
+ # Ugly hack to work around compression of the html files.
+ # Remove this if prepalldocs is changed to avoid gzipping html files.
+ cd ${S} && \
+ sed -i \
+ -e 's/[^ ]\+\.html//g' docs/Makefile.in || \
+ die "sed doc/Makefile.in failed"
+
+ epatch ${FILESDIR}/irssi-0.8.6-configure.patch
+}
+
+src_compile() {
+ # Note: there is an option to build a GUI for irssi, but according
+ # to the website the GUI is no longer developed, so that option is
+ # not used here.
+
+ # Edit these if you like
+ myconf="--without-servertest --with-bot --with-proxy --with-ncurses"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ #perl is auto-detected and must be explicitly disabled
+ use perl || myconf="${myconf} --with-perl=no"
+
+ #ipv6 needs to be explicitly enabled
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ #socks needs to be explicitly enabled
+ #use socks && myconf="${myconf} --with-socks"
+
+ #ssl is auto-detected and must be disabled explicitly
+ #use ssl || myconf="${myconf} --disable-ssl"
+ use ssl && myconf="${myconf} --with-openssl-include=/usr --with-openssl-libs=/usr"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ myflags=""
+
+ use perl && ( \
+ cd ${S}/src/perl/common
+ perl-module_src_prep
+ cd ${S}/src/perl/irc
+ perl-module_src_prep
+ cd ${S}/src/perl/textui
+ perl-module_src_prep
+ cd ${S}/src/perl/ui
+ perl-module_src_prep
+ cd ${S}
+ )
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ gnulocaledir=${D}/usr/share/locale \
+ ${myflags} \
+ install || die
+
+ prepalldocs
+ dodoc AUTHORS ChangeLog README TODO NEWS
+ cd docs && \
+ dohtml -r . || die "dohtml failed"
+}