summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-08-23 07:00:07 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-08-23 07:00:07 +0000
commit968769e3bffa6e5717c11be0bdeaa96bd13bd06a (patch)
tree4074cecc0c1f6d06fe4a1d2a862b693afc7b163a /net-irc
parentfixed at url, updated bzip2, fixed linux r5 name (diff)
downloadhistorical-968769e3bffa6e5717c11be0bdeaa96bd13bd06a.tar.gz
historical-968769e3bffa6e5717c11be0bdeaa96bd13bd06a.tar.bz2
historical-968769e3bffa6e5717c11be0bdeaa96bd13bd06a.zip
moved xchat to new category and modified ebuild (`uses gnome`)
fixed rpm (bzip2 archive name had typo) man pages not fixed yet tcsh working disabled gnome by default in make.conf fixed a gcc mirror URI updated file to 3.32
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-1.4.21
-rw-r--r--net-irc/xchat/xchat-1.4.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-1.4.2 b/net-irc/xchat/files/digest-xchat-1.4.2
new file mode 100644
index 000000000000..1cf56ae069e8
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.4.2
@@ -0,0 +1 @@
+MD5 be790878e80038088c642a5104ab1544 xchat-1.4.2.tar.bz2
diff --git a/net-irc/xchat/xchat-1.4.2.ebuild b/net-irc/xchat/xchat-1.4.2.ebuild
new file mode 100644
index 000000000000..97d6a4807af8
--- /dev/null
+++ b/net-irc/xchat/xchat-1.4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.4.2.ebuild,v 1.1 2000/08/23 07:00:07 drobbins Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="xchat"
+SRC_URI="http://www.xchat.org/files/source/1.4/"${A}
+HOMEPAGE="http://www.xchat.org/"
+
+src_compile() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ ./configure --host=${CHOST} --enable-gnome --disable perl --prefix=/opt/gnome --with-catgets
+ else
+ ./configure --host=${CHOST} --disable-gnome --disable-perl --prefix=/usr/X11R6 --with-catgets
+ fi
+ make
+}
+
+src_install() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ make prefix=${D}/opt/gnome install
+ else
+ make prefix=${D}/usr/X11R6 install
+ fi
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+
+}
+
+
+
+
+
+