summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-02-22 10:41:19 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-02-22 10:41:19 +0000
commit91491ea5b8a210ce027ba771268dc7bd9082d7de (patch)
treeafbf8bb98f5a70a2c2e3d26acb8901147a69fe42 /net-irc/irssi-otr/irssi-otr-0.3.ebuild
parentVersion bump (diff)
downloadhistorical-91491ea5b8a210ce027ba771268dc7bd9082d7de.tar.gz
historical-91491ea5b8a210ce027ba771268dc7bd9082d7de.tar.bz2
historical-91491ea5b8a210ce027ba771268dc7bd9082d7de.zip
Version bump
Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'net-irc/irssi-otr/irssi-otr-0.3.ebuild')
-rw-r--r--net-irc/irssi-otr/irssi-otr-0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-irc/irssi-otr/irssi-otr-0.3.ebuild b/net-irc/irssi-otr/irssi-otr-0.3.ebuild
new file mode 100644
index 000000000000..e62acd0353a0
--- /dev/null
+++ b/net-irc/irssi-otr/irssi-otr-0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/irssi-otr/irssi-otr-0.3.ebuild,v 1.1 2009/02/22 10:41:19 armin76 Exp $
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Off-The-Record messaging (OTR) for irssi"
+HOMEPAGE="http://irssi-otr.tuxfamily.org"
+
+# This should probably be exported by cmake-utils as a variable
+CMAKE_BINARY_DIR="${WORKDIR}"/${PN}_build
+mycmakeargs="-DDOCDIR=/usr/share/doc/${PF}"
+
+SRC_URI="ftp://download.tuxfamily.org/irssiotr/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="net-libs/libotr
+ || (
+ net-irc/irssi
+ net-irc/irssi-svn
+ )"
+
+DEPEND="${RDEPEND}
+ dev-libs/glib
+ >=dev-util/cmake-2.4.7
+ dev-util/pkgconfig
+ dev-lang/python"
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/share/doc/${PF}/LICENSE
+ prepalldocs
+}