summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-02-01 13:19:09 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-02-01 13:19:09 +0000
commit24090853f8c5166b2f5d77bd3b8558969fdffa99 (patch)
treeb075c48a3622d0504de42023fcd73d18b6e6d4e9 /net-irc/conspire/conspire-0.12.0.ebuild
parentInitial commit. You guessed right, a webcam software using aalib (ascii graph... (diff)
downloadhistorical-24090853f8c5166b2f5d77bd3b8558969fdffa99.tar.gz
historical-24090853f8c5166b2f5d77bd3b8558969fdffa99.tar.bz2
historical-24090853f8c5166b2f5d77bd3b8558969fdffa99.zip
Initial commit, ebuild by me.
Package-Manager: portage-2.1.4
Diffstat (limited to 'net-irc/conspire/conspire-0.12.0.ebuild')
-rw-r--r--net-irc/conspire/conspire-0.12.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-irc/conspire/conspire-0.12.0.ebuild b/net-irc/conspire/conspire-0.12.0.ebuild
new file mode 100644
index 000000000000..e21d30d22025
--- /dev/null
+++ b/net-irc/conspire/conspire-0.12.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-0.12.0.ebuild,v 1.1 2008/02/01 13:19:09 chainsaw Exp $
+
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="python gnutls ipv6 nls mmx socks5"
+DEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libsexy"
+RDEPEND="${DEPEND}
+ >=sys-apps/dbus-0.60
+ nls? ( dev-util/intltool )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}