summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2003-10-24 19:30:23 +0000
committerStefan Knoblich <stkn@gentoo.org>2003-10-24 19:30:23 +0000
commitf50414785944ebd8a2c08757ae2b79b901f57563 (patch)
tree7e2d38dc626a5a1ff2f244a9efd488094e6cd09a /net-im
parentnew upstream (diff)
downloadhistorical-f50414785944ebd8a2c08757ae2b79b901f57563.tar.gz
historical-f50414785944ebd8a2c08757ae2b79b901f57563.tar.bz2
historical-f50414785944ebd8a2c08757ae2b79b901f57563.zip
ebuild completely rewritten to fix bug #31384, new maintainer
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openmcu/ChangeLog7
-rw-r--r--net-im/openmcu/Manifest9
-rw-r--r--net-im/openmcu/files/openmcu-1.1.7-include.diff11
-rw-r--r--net-im/openmcu/files/openmcu-1.1.7-log-config.diff20
-rw-r--r--net-im/openmcu/files/openmcu.confd6
-rw-r--r--net-im/openmcu/files/openmcu.rc621
-rw-r--r--net-im/openmcu/metadata.xml9
-rw-r--r--net-im/openmcu/openmcu-1.1.7.ebuild61
8 files changed, 133 insertions, 11 deletions
diff --git a/net-im/openmcu/ChangeLog b/net-im/openmcu/ChangeLog
index eddc7c6c1bcd..6ba1d0ad0b36 100644
--- a/net-im/openmcu/ChangeLog
+++ b/net-im/openmcu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/openmcu
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/openmcu/ChangeLog,v 1.3 2003/10/18 05:45:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/openmcu/ChangeLog,v 1.4 2003/10/24 19:30:17 stkn Exp $
+
+ 24 Oct 2003; <stkn@gentoo.org> metadata.xml, openmcu-1.1.7.ebuild,
+ files/openmcu-1.1.7-include.diff, files/openmcu-1.1.7-log-config.diff,
+ files/openmcu.confd, files/openmcu.rc6:
+ ebuild completely rewritten (fixes bug #31384), new maintainer
17 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> openmcu-1.1.7.ebuild:
tidy
diff --git a/net-im/openmcu/Manifest b/net-im/openmcu/Manifest
index ea44fdb65d1c..1632c1725ec7 100644
--- a/net-im/openmcu/Manifest
+++ b/net-im/openmcu/Manifest
@@ -1,3 +1,8 @@
-MD5 25a4352ad05870d28150081160496eaf ChangeLog 400
-MD5 b2efb36e0eba7ab3687e33649ab18506 openmcu-1.1.7.ebuild 568
+MD5 60f91a6f1c6947c682fcda859a1102c2 ChangeLog 645
+MD5 8b315a13c7a8c0d9eafcf002b5c63b30 openmcu-1.1.7.ebuild 1524
+MD5 44cf247f04cc83413fcb40ed59d0847a metadata.xml 248
+MD5 818a46252f5fc92f31c3668db668ff76 files/openmcu.confd 277
MD5 48d2727ed476eea13c2bcd912dbdf6e2 files/digest-openmcu-1.1.7 64
+MD5 6a20d03e56c855c629254598b2552d52 files/openmcu-1.1.7-include.diff 284
+MD5 31922fffa7bd4da01e4bffc8c0011092 files/openmcu-1.1.7-log-config.diff 675
+MD5 b4fb6e8315f19848a0e1a9a19029e6b0 files/openmcu.rc6 588
diff --git a/net-im/openmcu/files/openmcu-1.1.7-include.diff b/net-im/openmcu/files/openmcu-1.1.7-include.diff
new file mode 100644
index 000000000000..58222283acc0
--- /dev/null
+++ b/net-im/openmcu/files/openmcu-1.1.7-include.diff
@@ -0,0 +1,11 @@
+--- openmcu/main.cxx.ori 2003-08-29 01:11:34.000000000 +0200
++++ openmcu/main.cxx 2003-08-29 01:11:58.000000000 +0200
+@@ -261,7 +261,7 @@
+ #include "speexcodec.h"
+ #ifndef NO_VIDEO
+ #include "h261codec.h"
+-#include "videoio.h"
++#include <ptlib/videoio.h>
+ #endif
+ #include "main.h"
+
diff --git a/net-im/openmcu/files/openmcu-1.1.7-log-config.diff b/net-im/openmcu/files/openmcu-1.1.7-log-config.diff
new file mode 100644
index 000000000000..c13c0039387d
--- /dev/null
+++ b/net-im/openmcu/files/openmcu-1.1.7-log-config.diff
@@ -0,0 +1,20 @@
+--- openmcu/main.cxx.orig 2003-10-20 23:38:28.000000000 +0200
++++ openmcu/main.cxx 2003-10-20 23:40:25.000000000 +0200
+@@ -286,7 +286,7 @@
+
+ ///////////////////////////////////////////////////////////////
+ #ifdef LOGGING
+-static PString DEFAULT_CALL_LOG = "c:\\mcu_log.txt";
++static PString DEFAULT_CALL_LOG = "/var/log/openmcu/call.log";
+ static PMutex logMutex;
+ static PTextFile logFile;
+ static PFilePath logFilename = DEFAULT_CALL_LOG;
+@@ -340,6 +340,8 @@
+ : PProcess("OpenH323 Project", "OpenMCU",
+ MAJOR_VERSION, MINOR_VERSION, BUILD_TYPE, BUILD_NUMBER)
+ {
++ // set location of configuration file
++ SetConfigurationPath("/etc/openmcu.ini");
+ }
+
+
diff --git a/net-im/openmcu/files/openmcu.confd b/net-im/openmcu/files/openmcu.confd
new file mode 100644
index 000000000000..a8b1d5a16222
--- /dev/null
+++ b/net-im/openmcu/files/openmcu.confd
@@ -0,0 +1,6 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-im/openmcu/files/openmcu.confd,v 1.1 2003/10/24 19:30:17 stkn Exp $
+
+OPTIONS="--disable-menu"
diff --git a/net-im/openmcu/files/openmcu.rc6 b/net-im/openmcu/files/openmcu.rc6
new file mode 100644
index 000000000000..f82a950c9507
--- /dev/null
+++ b/net-im/openmcu/files/openmcu.rc6
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-im/openmcu/files/openmcu.rc6,v 1.1 2003/10/24 19:30:17 stkn Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting H.323 Conferencing service"
+ start-stop-daemon --start --quiet --pidfile /var/run/openmcu.pid \
+ -b -m --exec /usr/sbin/openmcu -- ${OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping H.323 Conferencing service"
+ start-stop-daemon --stop --quiet --pidfile /var/run/openmcu.pid
+ eend $?
+}
diff --git a/net-im/openmcu/metadata.xml b/net-im/openmcu/metadata.xml
new file mode 100644
index 000000000000..10f27dc5e06a
--- /dev/null
+++ b/net-im/openmcu/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+ <name>Stefan Knoblich</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-im/openmcu/openmcu-1.1.7.ebuild b/net-im/openmcu/openmcu-1.1.7.ebuild
index 25a4e1e12998..14c2675295de 100644
--- a/net-im/openmcu/openmcu-1.1.7.ebuild
+++ b/net-im/openmcu/openmcu-1.1.7.ebuild
@@ -1,19 +1,64 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/openmcu/openmcu-1.1.7.ebuild,v 1.3 2003/10/18 05:45:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/openmcu/openmcu-1.1.7.ebuild,v 1.4 2003/10/24 19:30:17 stkn Exp $
+
+inherit eutils
+
+IUSE=""
-SRC_URI="http://www.openh323.org/bin/openmcu_${PV}.tar.gz"
-HOMEPAGE="http://www.openh323.org"
DESCRIPTION="H.323 conferencing server"
+HOMEPAGE="http://www.openh323.org/"
+SRC_URI="http://www.openh323.org/bin/openmcu_${PV}.tar.gz"
+
+S=${WORKDIR}/openmcu
SLOT="0"
-LICENSE="GPL-2"
KEYWORDS="~x86"
+LICENSE="MPL-1.0"
-DEPEND=">=dev-libs/pwlib-1.5.0
- >=net-libs/openh323-1.12.0"
+# get the name of the os
+MY_OS="`uname -s | tr [:upper:] [:lower:]`"
+
+DEPEND=">=net-libs/openh323-1.12.2-r1"
+
+src_unpack() {
+ unpack ${A}
+
+ # do some include fixing (again...)
+ cd ${S}
+ epatch ${FILESDIR}/${P}-include.diff
+ epatch ${FILESDIR}/${P}-log-config.diff
+}
src_compile() {
- cd work/openmcu
- OPENH323DIR="/usr/share/openh323" make all || die "make failed"
+
+ CFLAGS="${CFLAGS} -DLOGGING=1" \
+ PWLIBDIR=/usr/share/pwlib \
+ OPENH323DIR=/usr/share/openh323 \
+ emake opt || die
+}
+
+src_install() {
+ dodir /usr/sbin /var/log/openmcu
+ dosbin obj_${MY_OS}_${ARCH}_r/openmcu
+ keepdir /var/log/openmcu
+
+ doman openmcu.1
+ dodoc ReadMe.txt mpl-1.0.htm
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/openmcu.rc6 openmcu
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/openmcu.confd openmcu
+}
+
+pkg_postinst() {
+ einfo "this patched version of openmcu stores it's configuration"
+ einfo "in \"/etc/openmcu.ini\" you can generate this file by doing:"
+ einfo " openmcu <options_you_want> --save"
+ einfo "or you can add your options to /etc/conf.d/openmcu"
+ ewarn "but be careful with removing --disable-menu (this will break"
+ ewarn "the openmcu init script)"
+ sleep 10
}