summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-09-04 18:08:49 +0000
committerDon Seiler <rizzo@gentoo.org>2003-09-04 18:08:49 +0000
commitc2e28106bf1c3b8774282ef0e974c4b0ee005ff5 (patch)
treec3409547f9912a182d6d51aa9dab172564ddedc5 /net-im
parentRevision bump to pick up encryption patch. (diff)
downloadhistorical-c2e28106bf1c3b8774282ef0e974c4b0ee005ff5.tar.gz
historical-c2e28106bf1c3b8774282ef0e974c4b0ee005ff5.tar.bz2
historical-c2e28106bf1c3b8774282ef0e974c4b0ee005ff5.zip
Revision bump to pick up encryption patch.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.68-r12
-rw-r--r--net-im/gaim/files/gaim-encryption-2.10-keys.patch12
-rw-r--r--net-im/gaim/gaim-0.68-r1.ebuild82
-rw-r--r--net-im/gaim/metadata.xml4
5 files changed, 100 insertions, 4 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 2e4868535ce0..e9c502ac6fb6 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -4,8 +4,8 @@ MD5 63f5d5add45a34870e61e2e39d70b919 gaim-0.63-r1.ebuild 1835
MD5 b7dbbfc3c88f5a2f775f6eaf0a7e5f90 gaim-0.66-r4.ebuild 1996
MD5 a7d996e60f8521e458599e249267645f gaim-0.66-r3.ebuild 1994
MD5 91f54778609b147c372351022d0e884d gaim-0.68.ebuild 2335
-MD5 8750c50a90e487fcf40b240804fa33be gaim-0.68-r1.ebuild 2415
-MD5 1f14f82305da34e5777522ca04690df9 ChangeLog 12454
+MD5 0b185f663a67d39645e0916cddcba37e gaim-0.68-r1.ebuild 2418
+MD5 d60580dfc08617863039b5837d40507e ChangeLog 12454
MD5 dc9ef26d3efea7cbe38cbe534cdeaa53 metadata.xml 510
MD5 5993641de8d56c2c433f252997c3c39c files/digest-gaim-0.67 135
MD5 a2573960c3aaad5d08dddcc3ad9b5f23 files/digest-gaim-0.68 135
diff --git a/net-im/gaim/files/digest-gaim-0.68-r1 b/net-im/gaim/files/digest-gaim-0.68-r1
new file mode 100644
index 000000000000..6b534e53721c
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.68-r1
@@ -0,0 +1,2 @@
+MD5 604c749f236e3813a1d2341e2e9208bc gaim-0.68.tar.bz2 2973856
+MD5 a15724c2f3b07f79a5698ff627a5e328 gaim-encryption-2.10.tar.gz 223873
diff --git a/net-im/gaim/files/gaim-encryption-2.10-keys.patch b/net-im/gaim/files/gaim-encryption-2.10-keys.patch
new file mode 100644
index 000000000000..e5bfe0e559a9
--- /dev/null
+++ b/net-im/gaim/files/gaim-encryption-2.10-keys.patch
@@ -0,0 +1,12 @@
+--- keys.orig 2003-09-04 12:47:12.000000000 -0500
++++ keys.c 2003-09-04 12:47:20.000000000 -0500
+@@ -60,8 +60,8 @@
+
+
+ crypt_key * GE_find_key_by_name(key_ring *ring, char *name) {
+- gaim_debug(GAIM_DEBUG_MISC, "gaim-encryption", "find key by name: %s\n", name);
+ key_ring *i = GE_find_key_node_by_name(ring, name);
++ gaim_debug(GAIM_DEBUG_MISC, "gaim-encryption", "find key by name: %s\n", name);
+ return (i == NULL) ? NULL : ((key_ring_data *)i->data)->key;
+ }
+
diff --git a/net-im/gaim/gaim-0.68-r1.ebuild b/net-im/gaim/gaim-0.68-r1.ebuild
new file mode 100644
index 000000000000..267e4a7d50d3
--- /dev/null
+++ b/net-im/gaim/gaim-0.68-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.68-r1.ebuild,v 1.1 2003/09/04 18:08:44 rizzo Exp $
+
+IUSE="nls perl spell nas ssl"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.10
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ ssl? ( dev-libs/nss )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ cd gaim-encryption-${EV}
+ epatch ${FILESDIR}/gaim-encryption-2.10-keys.patch
+ }
+ #use cjk && {
+ #cd ${S}/src
+ #epatch ${FILESDIR}/gaim_gtkimcontext_patch.diff
+ #}
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ econf || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ use perl && sed -i -e 's:\(-e "install(\)\(.@ARGV.,.$(VERBINST).,0,.$(UNINST).);"\):\1$(DESTDIR)/\2:' plugins/perl/common/Makefile
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ ewarn
+ fi
+}
diff --git a/net-im/gaim/metadata.xml b/net-im/gaim/metadata.xml
index b2a46f38823c..041822f836ad 100644
--- a/net-im/gaim/metadata.xml
+++ b/net-im/gaim/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>net-im</herd>
<maintainer>
- <email>rizzo@gentoo.org</email>
- <name>Don Seiler</name>
+ <email>lostlogic@gentoo.org</email>
+ <name>Brandon Low</name>
</maintainer>
<longdescription>
Gaim is a multi-protocol instant messaging client for Linux, BSD, MacOS X, and Windows. It is compatible with AIM (Oscar and TOC protocols), ICQ, MSN Messenger, Yahoo, IRC, Jabber, Gadu-Gadu, and Zephyr networks.