summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-30 09:54:00 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-30 09:54:00 +0000
commit38de822769246a605c24962836af633fcc960bfd (patch)
tree28e310a32027f59ab8d6b4e8859b0405a29e5ba8 /net-im/silc-client
parentVersion bump; bugs #211853 and #211938. (diff)
downloadhistorical-38de822769246a605c24962836af633fcc960bfd.tar.gz
historical-38de822769246a605c24962836af633fcc960bfd.tar.bz2
historical-38de822769246a605c24962836af633fcc960bfd.zip
old
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-im/silc-client')
-rw-r--r--net-im/silc-client/silc-client-1.1.2.ebuild81
-rw-r--r--net-im/silc-client/silc-client-1.1.3.ebuild83
2 files changed, 0 insertions, 164 deletions
diff --git a/net-im/silc-client/silc-client-1.1.2.ebuild b/net-im/silc-client/silc-client-1.1.2.ebuild
deleted file mode 100644
index 4edaf7e38971..000000000000
--- a/net-im/silc-client/silc-client-1.1.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-1.1.2.ebuild,v 1.6 2007/08/15 21:24:07 dertobi123 Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
-SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
-HOMEPAGE="http://silcnet.org/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc ~sparc x86"
-IUSE="ipv6 perl debug"
-
-DEPEND="perl? ( dev-lang/perl )
- sys-libs/ncurses
- !<=net-im/silc-toolkit-0.9.12-r1"
-
-RDEPEND="${DEPEND}
- perl? (
- !net-irc/irssi
- !net-irc/irssi-svn
- )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- sed -i -e "s:-g -O2:${CFLAGS}:g" configure
- use amd64 && sed -i -e 's:felf\([^6]\):felf64\1:g' configure
- epatch "${FILESDIR}/${PN}-1.1-docdir.patch"
-}
-
-src_compile() {
- local myconf=""
- use ipv6 && myconf="${myconf} --enable-ipv6"
-
- econf \
- --datadir=/usr/share/${PN} \
- --datarootdir=/usr/share/${PN} \
- --mandir=/usr/share/man \
- --includedir=/usr/include/${PN} \
- --sysconfdir=/etc/silc \
- --with-helpdir=/usr/share/${PN}/help \
- --libdir=/usr/$(get_libdir)/${PN} \
- --docdir=/usr/share/doc/${PF} \
- --disable-optimizations \
- $(use_enable debug) \
- ${myconf}
-
- emake || die "emake failed"
-}
-
-src_install() {
- local myflags=""
-
- if use perl
- then
- R1="s/installsitearch='//"
- R2="s/';//"
- perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
- myflags="${myflags} INSTALLPRIVLIB=/usr/$(get_libdir)"
- myflags="${myflags} INSTALLARCHLIB=${perl_sitearch}"
- myflags="${myflags} INSTALLSITELIB=${perl_sitearch}"
- myflags="${myflags} INSTALLSITEARCH=${perl_sitearch}"
- fi
-
- make DESTDIR="${D}" ${myflags} install || die "make install failed"
-
- rm -rf ${D}/etc ${D}/usr/libsilc* ${D}/usr/include
-
- dodoc CHANGES CREDITS README TODO
- cd "${S}/apps/irssi"
- dodoc silc.conf docs/formats.txt docs/manual.txt docs/signals.txt docs/special_vars.txt
- dohtml docs/startup-HOWTO.html
-
- insinto /usr/share/silc-client/help
- rm docs/help/Make*
- doins docs/help/*
-}
diff --git a/net-im/silc-client/silc-client-1.1.3.ebuild b/net-im/silc-client/silc-client-1.1.3.ebuild
deleted file mode 100644
index 05d087a82612..000000000000
--- a/net-im/silc-client/silc-client-1.1.3.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-1.1.3.ebuild,v 1.6 2008/02/14 21:49:00 coldwind Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="IRSSI-based text client for Secure Internet Live Conferencing"
-SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
-HOMEPAGE="http://silcnet.org/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc ~ppc64 sparc x86"
-IUSE="ipv6 perl debug"
-
-DEPEND="perl? ( dev-lang/perl )
- sys-libs/ncurses
- dev-util/pkgconfig
- >=dev-libs/glib-2.8
- !<=net-im/silc-toolkit-0.9.12-r1"
-
-RDEPEND="${DEPEND}
- perl? (
- !net-irc/irssi
- !net-irc/irssi-svn
- )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "s:-g -O2:${CFLAGS}:g" configure
- use amd64 && sed -i -e 's:felf\([^6]\):felf64\1:g' configure
- epatch "${FILESDIR}/${PN}-1.1-docdir.patch"
-}
-
-src_compile() {
- local myconf=""
- use ipv6 && myconf="${myconf} --enable-ipv6"
-
- econf \
- --datadir=/usr/share/${PN} \
- --datarootdir=/usr/share/${PN} \
- --mandir=/usr/share/man \
- --includedir=/usr/include/${PN} \
- --sysconfdir=/etc/silc \
- --with-helpdir=/usr/share/${PN}/help \
- --libdir=/usr/$(get_libdir)/${PN} \
- --docdir=/usr/share/doc/${PF} \
- --disable-optimizations \
- $(use_enable debug) \
- ${myconf}
-
- emake || die "emake failed"
-}
-
-src_install() {
- local myflags=""
-
- if use perl
- then
- R1="s/installsitearch='//"
- R2="s/';//"
- perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
- myflags="${myflags} INSTALLPRIVLIB=/usr/$(get_libdir)"
- myflags="${myflags} INSTALLARCHLIB=${perl_sitearch}"
- myflags="${myflags} INSTALLSITELIB=${perl_sitearch}"
- myflags="${myflags} INSTALLSITEARCH=${perl_sitearch}"
- fi
-
- make DESTDIR="${D}" ${myflags} install || die "make install failed"
-
- rm -rf "${D}"/etc "${D}"/usr/libsilc* "${D}"/usr/include
-
- dodoc CHANGES CREDITS README TODO
- cd "${S}/apps/irssi"
- dodoc silc.conf docs/formats.txt docs/manual.txt docs/signals.txt docs/special_vars.txt
- dohtml docs/startup-HOWTO.html
-
- insinto /usr/share/silc-client/help
- rm docs/help/Make*
- doins docs/help/*
-}