summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-03-09 16:35:15 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-03-09 16:35:15 +0000
commit43efbb76f06c9ce7a81a825089d08a03ba697db7 (patch)
treecc9312990049d3b3bf088654bef0a8fd5f0cdac3 /net-im/qutecom
parentVersion bumped. Removed useless .la files, bug #299016. (diff)
downloadhistorical-43efbb76f06c9ce7a81a825089d08a03ba697db7.tar.gz
historical-43efbb76f06c9ce7a81a825089d08a03ba697db7.tar.bz2
historical-43efbb76f06c9ce7a81a825089d08a03ba697db7.zip
net-im/qutecom: new ebuild for bug 237941
Package-Manager: portage-2.2_rc65/cvs/Linux x86_64
Diffstat (limited to 'net-im/qutecom')
-rw-r--r--net-im/qutecom/ChangeLog10
-rw-r--r--net-im/qutecom/Manifest4
-rw-r--r--net-im/qutecom/metadata.xml10
-rw-r--r--net-im/qutecom/qutecom-2.2_p20100309.ebuild63
4 files changed, 87 insertions, 0 deletions
diff --git a/net-im/qutecom/ChangeLog b/net-im/qutecom/ChangeLog
new file mode 100644
index 000000000000..488dbcdce3e5
--- /dev/null
+++ b/net-im/qutecom/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-im/qutecom
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutecom/ChangeLog,v 1.1 2010/03/09 16:35:15 chithanh Exp $
+
+*qutecom-2.2_p20100309 (09 Mar 2010)
+
+ 09 Mar 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +qutecom-2.2_p20100309.ebuild:
+ initial import for bug 237941
+
diff --git a/net-im/qutecom/Manifest b/net-im/qutecom/Manifest
new file mode 100644
index 000000000000..1065aaa80f93
--- /dev/null
+++ b/net-im/qutecom/Manifest
@@ -0,0 +1,4 @@
+DIST qutecom-2.2_p20100309.tar.xz 34683024 RMD160 1966ec94afef4950eee5256702197121f205998a SHA1 a860034bf0349953450e82c5df807d4a7cfe1f03 SHA256 596199a112d479086b369fe033c202bfa4c4b51f9b049b80773d14b3ed7aadaf
+EBUILD qutecom-2.2_p20100309.ebuild 1789 RMD160 894874e6178f671898591ff372952184879c7dbe SHA1 ef18310922bf21032b76275eb4460709c91235d3 SHA256 d87cbc4f8817fab1eb6b4b1a6f82db2aff73e6b80ec9acc5ec6459330d199d85
+MISC ChangeLog 376 RMD160 331fa224dee4c5e8aed70fe8a50db4e92eb7f6c8 SHA1 87c37b49d217b6c361938d0c0a97d5022c39ae47 SHA256 070786eb5ca0ad678b45f64c2cbad3e80fff52e49f4bba5cafd585d1bd13acf3
+MISC metadata.xml 272 RMD160 4a80062ca381c4d74a4efabc38d29fb1b0c6b592 SHA1 28f9d9426442ff315737006285ca0b90b4ef833f SHA256 55558c7efd245be98e0b3a5be45c4e855ecb6f2f4d651edf3d5442d6edbd9298
diff --git a/net-im/qutecom/metadata.xml b/net-im/qutecom/metadata.xml
new file mode 100644
index 000000000000..11b753103370
--- /dev/null
+++ b/net-im/qutecom/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>voip</herd>
+ <maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-im/qutecom/qutecom-2.2_p20100309.ebuild b/net-im/qutecom/qutecom-2.2_p20100309.ebuild
new file mode 100644
index 000000000000..8c93c9b131a0
--- /dev/null
+++ b/net-im/qutecom/qutecom-2.2_p20100309.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutecom/qutecom-2.2_p20100309.ebuild,v 1.1 2010/03/09 16:35:15 chithanh Exp $
+
+EAPI="3"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Multi-protocol instant messenger and VoIP client"
+HOMEPAGE="http://www.qutecom.org/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug oss portaudio xv"
+
+RDEPEND="dev-libs/boost
+ dev-libs/glib
+ dev-libs/openssl
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libsamplerate
+ media-libs/libsndfile
+ portaudio? ( media-libs/portaudio )
+ media-libs/speex
+ media-video/ffmpeg
+ net-im/pidgin[gnutls]
+ net-libs/gnutls
+ >=net-libs/libosip-3
+ >=net-libs/libeXosip-3
+ net-misc/curl
+ x11-libs/libX11
+ x11-libs/qt-gui
+ x11-libs/qt-svg
+ xv? ( x11-libs/libXv )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.41" && has_version ">=dev-libs/boost-1.41"; then
+ ewarn "QuteCom build system may mix up headers and libraries if versions of"
+ ewarn "dev-libs/boost both before and after 1.41 are installed. If the build"
+ ewarn "fails due to undefined boost symbols, remove older boost."
+ fi
+}
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use_enable portaudio PORTAUDIO_SUPPORT)
+ $(cmake-utils_use_enable alsa PHAPI_AUDIO_ALSA_SUPPORT)
+ $(cmake-utils_use_enable oss PHAPI_AUDIO_OSS_SUPPORT)
+ $(cmake-utils_use_enable xv WENGOPHONE_XV_SUPPORT)
+ -DLIBPURPLE_INTERNAL=OFF
+ -DPORTAUDIO_INTERNAL=OFF
+ -DCMAKE_VERBOSE_MAKEFILE=ON "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu wengophone/res/${PN}.desktop || die "domenu failed"
+ doicon wengophone/res/${PN}_64x64.png || die "doicon failed"
+
+}