summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-25 06:11:45 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-25 06:11:45 +0000
commit12c3b06adc3df2f5a187be337b905e61a565be2e (patch)
tree5ce59cb8642ca6abf5f66ab2f94e599dae3bd8f8 /net-ftp
parentVersion bump. Upstream bug fixes. (diff)
downloadhistorical-12c3b06adc3df2f5a187be337b905e61a565be2e.tar.gz
historical-12c3b06adc3df2f5a187be337b905e61a565be2e.tar.bz2
historical-12c3b06adc3df2f5a187be337b905e61a565be2e.zip
Version bump. Upstream bug fixes.
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/Manifest4
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.6.61
-rw-r--r--net-ftp/lftp/lftp-2.6.6.ebuild62
3 files changed, 65 insertions, 2 deletions
diff --git a/net-ftp/lftp/Manifest b/net-ftp/lftp/Manifest
index 7e4008b20aca..df2189740edb 100644
--- a/net-ftp/lftp/Manifest
+++ b/net-ftp/lftp/Manifest
@@ -1,10 +1,10 @@
MD5 f727572af305b17b0063c5c69add2d48 lftp-2.6.4.ebuild 1410
-MD5 8327ccd436a347e0151b0c2c25daaaef lftp-2.6.6.ebuild 1765
+MD5 050a674a354c5fd8530e4d2207960d1b lftp-2.6.6.ebuild 1657
MD5 383e3ccd02f528d8f5b452130adfa46a lftp-2.6.3.ebuild 1425
MD5 ef5a1bde05cd2a74983aa8c7e9cbed7a lftp-2.5.4-r1.ebuild 1237
MD5 42befc4ad7cd2089eb1ae0e1f5f4630b lftp-2.6.5.ebuild 1761
MD5 c1d515d7e93351a1081f865c13127b5a lftp-2.6.2.ebuild 1607
-MD5 a6c5ab568f99b8a8254ba5ec187e903a ChangeLog 4476
+MD5 4ca67bfaf22c6fd0419673972d15bc63 ChangeLog 4607
MD5 096d8792a2b0989e03d9a39f8f5a2495 files/configure-lftp-2.6.2.diff 717
MD5 b39ba922d0d3b3f4a352d25f38d88364 files/digest-lftp-2.5.4-r1 64
MD5 f2a4efd6f8acc770b7e2603e9340d0e9 files/digest-lftp-2.6.2 64
diff --git a/net-ftp/lftp/files/digest-lftp-2.6.6 b/net-ftp/lftp/files/digest-lftp-2.6.6
new file mode 100644
index 000000000000..7b2d936b31fd
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.6.6
@@ -0,0 +1 @@
+MD5 fec9d5c2a4ec65eb37fa33d21b869c81 lftp-2.6.6.tar.bz2 1163154
diff --git a/net-ftp/lftp/lftp-2.6.6.ebuild b/net-ftp/lftp/lftp-2.6.6.ebuild
new file mode 100644
index 000000000000..3812d8b09296
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.6.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.6.6.ebuild,v 1.1 2003/07/25 06:11:38 raker Exp $
+
+IUSE="ssl socks5 nls alpha"
+
+inherit eutils
+
+DESCRIPTION="A sophisticated ftp/http client, file transfer program."
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+SRC_URI="http://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc ~sparc ~alpha"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ socks5? ( >=net-misc/dante-1.1.12 )
+ nls? ( sys-devel/gettext )
+ alpha? ( dev-lang/perl )
+ alpha? ( >=sys-apps/sed-4 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use nls && myconf="--enable-nls" \
+ || myconf="--disable-nls"
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use socks5 && myconf="${myconf} --with-socksdante=/usr" \
+ || myconf="${myconf} --without-socksdante"
+
+ econf \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ ${myconf}
+
+ [ "${ARCH}" == "alpha" ] && {
+ # remove duplicate libraries, causes problems on ALPHA.
+ # -taviso
+ einfo "Adding check for superfluous linking..."
+ sed -i \
+ 's/\(link_command="\)\($compile_command$compile_rpath\)"/\1\`echo \2 | perl -lane \x27print "@F" if @F = grep \!\$seen{\$_}++, @F\x27\`"/' \
+ libtool
+ }
+
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ # hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+}