summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-16 13:08:04 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-16 13:08:04 +0000
commit868d74c9c2ffe4c88ee9a7bdc06e6dbd5b69f716 (patch)
tree5abecc31d1eef807ddac15aeab161fa9b4128ddb /net-ftp/lftp
parentUpdate (diff)
downloadhistorical-868d74c9c2ffe4c88ee9a7bdc06e6dbd5b69f716.tar.gz
historical-868d74c9c2ffe4c88ee9a7bdc06e6dbd5b69f716.tar.bz2
historical-868d74c9c2ffe4c88ee9a7bdc06e6dbd5b69f716.zip
Update
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.3.101
-rw-r--r--net-ftp/lftp/lftp-2.3.10.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-ftp/lftp/files/digest-lftp-2.3.10 b/net-ftp/lftp/files/digest-lftp-2.3.10
new file mode 100644
index 000000000000..bca34bbecdeb
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.3.10
@@ -0,0 +1 @@
+MD5 07b79619247970356b73a80006ad426c lftp-2.3.10.tar.bz2
diff --git a/net-ftp/lftp/lftp-2.3.10.ebuild b/net-ftp/lftp/lftp-2.3.10.ebuild
new file mode 100644
index 000000000000..26350468a602
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.3.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.3.10.ebuild,v 1.1 2001/05/16 13:08:04 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Groovy little ftp client"
+SRC_URI="ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${A}
+ http://metalab.unc.edu/pub/Linux/system/network/file-transfer/${A}"
+
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1
+ >=dev-libs/openssl-0.9.6"
+
+src_unpack () {
+ unpack ${A}
+}
+
+src_compile() {
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+ try ./configure --prefix=/usr --sysconfdir=/etc/lftp --with-modules
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/usr sysconfdir=${D}/etc/lftp install
+ prepman
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS NEWS
+ dodoc README* THANKS TODO
+
+}
+
+
+
+
+