summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-18 17:15:28 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-18 17:15:28 +0000
commit9e458d6384faaf14579d11b23140b2d0b2fc0d56 (patch)
tree79a2e6dce64155ccac73154c6d5518ee0c69640f /net-fs/nfs-utils
parentVersion bumped. (diff)
downloadhistorical-9e458d6384faaf14579d11b23140b2d0b2fc0d56.tar.gz
historical-9e458d6384faaf14579d11b23140b2d0b2fc0d56.tar.bz2
historical-9e458d6384faaf14579d11b23140b2d0b2fc0d56.zip
Version bumped.
Diffstat (limited to 'net-fs/nfs-utils')
-rw-r--r--net-fs/nfs-utils/Manifest4
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-1.0.61
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.6.ebuild65
3 files changed, 68 insertions, 2 deletions
diff --git a/net-fs/nfs-utils/Manifest b/net-fs/nfs-utils/Manifest
index 96b007627d07..7d6eb11a8513 100644
--- a/net-fs/nfs-utils/Manifest
+++ b/net-fs/nfs-utils/Manifest
@@ -1,5 +1,5 @@
-MD5 ea89a080150922de66acbd0f32c4ba85 ChangeLog 3737
-MD5 bc7e9d106d8b3c1b8ba7ab1e9ddfa284 nfs-utils-1.0.6.ebuild 1872
+MD5 03c60e718725d618872ab4a3f12e78f3 ChangeLog 3863
+MD5 87a23c8c308c66afecc2d71fec18a294 nfs-utils-1.0.6.ebuild 1868
MD5 c65cd5fc394327242a58f9c1d49b8ac6 nfs-utils-1.0.5-r1.ebuild 1920
MD5 3a3d8bd1a03bbf2c51a4e77a3516febd files/digest-nfs-utils-1.0.6 67
MD5 a02eed87e5d581e56feb0f6dfd18e6df files/exports 66
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6 b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6
new file mode 100644
index 000000000000..319c3d94379e
--- /dev/null
+++ b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.6
@@ -0,0 +1 @@
+MD5 f17e9983457e1cf61c37f0be4493fce6 nfs-utils-1.0.6.tar.gz 265964
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild
new file mode 100644
index 000000000000..9dffda4ec117
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild,v 1.1 2003/09/18 17:15:21 mholzer Exp $
+
+IUSE="tcpd"
+
+DESCRIPTION="NFS client and server daemons"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz"
+HOMEPAGE="http://nfs.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~arm ~hppa ~amd64"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND} >=net-nds/portmap-5b-r6"
+
+src_compile() {
+ ./configure \
+ --mandir=/usr/share/man \
+ --with-statedir=/var/lib/nfs \
+ --disable-rquotad --enable-nfsv3 || die "Configure failed"
+
+ if ! use tcpd; then
+ sed -i "s:\(-lwrap\|-DHAVE_TCP_WRAPPER\)::" config.mk
+ fi
+
+ # parallel make still fails
+ make || die "Failed to compile"
+}
+
+src_install() {
+ make install install_prefix=${D} MANDIR=${D}/usr/share/man \
+ || die "Failed to install"
+
+ # Install some client-side binaries in /sbin
+ mkdir ${D}/sbin
+ mv ${D}/usr/sbin/rpc.{lockd,statd} ${D}/sbin
+
+ dodoc ChangeLog COPYING README
+ docinto linux-nfs ; dodoc linux-nfs/*
+
+ insinto /etc ; doins ${FILESDIR}/exports
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/nfs-2 nfs
+ newexe ${FILESDIR}/nfsmount nfsmount
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/nfs.confd nfs
+}
+
+pkg_postinst() {
+ einfo "NFS V2 and V3 servers now default to \"sync\" IO if ${P}"
+ einfo "(or later) is installed."
+ einfo "More info at ${HOMEPAGE} (see questions 5, 12, 13, and 14)."
+ echo
+ ewarn "PLEASE note: Since the latest NFS utils has changed the server"
+ ewarn "default to \"sync\" IO, then if no behavior is specified in the"
+ ewarn "export list, thus assuming the default behavior, a warning will"
+ ewarn "be generated at export time."
+ echo
+ # Running depscan since we introduced /etc/init.d/{portmap,nfs}
+ /etc/init.d/depscan.sh
+}