summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-11-21 09:59:51 +0000
committerEldad Zack <eldad@gentoo.org>2004-11-21 09:59:51 +0000
commit027e45893152be050d861921b02434009523a10a (patch)
tree0410af208ac879956df1c77411d3159fcf32594b /net-firewall
parentAdded to ~amd64, bug #71887 (diff)
downloadhistorical-027e45893152be050d861921b02434009523a10a.tar.gz
historical-027e45893152be050d861921b02434009523a10a.tar.bz2
historical-027e45893152be050d861921b02434009523a10a.zip
initscript updates
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall/ChangeLog6
-rw-r--r--net-firewall/shorewall/Manifest20
-rw-r--r--net-firewall/shorewall/files/shorewall15
3 files changed, 32 insertions, 9 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index 862d14659d4f..694a8ae10f72 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/shorewall
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.55 2004/08/22 21:11:37 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.56 2004/11/21 09:59:51 eldad Exp $
+
+ 21 Nov 2004; Eldad Zack <eldad@gentoo.org> files/shorewall:
+ initscript: added clear function to remove firewall rules, /dev/null'd restart
+ output. Closes #24882.
22 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> shorewall-2.0.4.ebuild:
Stable on alpha.
diff --git a/net-firewall/shorewall/Manifest b/net-firewall/shorewall/Manifest
index 9f5963487e88..2cd054bb65ef 100644
--- a/net-firewall/shorewall/Manifest
+++ b/net-firewall/shorewall/Manifest
@@ -1,11 +1,21 @@
-MD5 a458fdea4838c70cf90899afa8698f47 ChangeLog 7623
-MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 d4ccd1f4e2f19ebd16b8e5706bde9cb3 shorewall-1.4.10f.ebuild 1120
+MD5 442ef04cfadc0fec0ffd0606dbe82971 shorewall-2.0.7.ebuild 1879
MD5 e52449d5fc61584fd3f5d0e14fe12487 shorewall-2.0.4.ebuild 1874
MD5 1e25d047f7e2a7bf086d25e788b0d8ec shorewall-2.0.6.ebuild 1877
-MD5 442ef04cfadc0fec0ffd0606dbe82971 shorewall-2.0.7.ebuild 1879
-MD5 3b1f1510d6cf9a2d9a050cfd5e70c7d5 files/digest-shorewall-1.4.10f 142
+MD5 73000f327909bb8f03a537ed6cce3843 ChangeLog 7791
+MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
MD5 f7624af859e62ac0d00abc12ea839d23 files/digest-shorewall-2.0.4 138
MD5 1a13758183c5f9c39b3fbe90235b405f files/digest-shorewall-2.0.6 139
MD5 42daac4688988d74bb62f390b6aa486a files/digest-shorewall-2.0.7 139
-MD5 4ab5274205e37890797251bc9faac88c files/shorewall 808
+MD5 3b1f1510d6cf9a2d9a050cfd5e70c7d5 files/digest-shorewall-1.4.10f 142
+MD5 886a46dd1ca55990686be5bf42b776de files/shorewall 1041
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBoGXyT+MN7JbqCpMRApUTAJ9GcKPXjShgG6DnPeJgrtngzMvZtwCeKc6u
+pi0nPZGqyYWepOFZsV6DCgQ=
+=mqBG
+-----END PGP SIGNATURE-----
diff --git a/net-firewall/shorewall/files/shorewall b/net-firewall/shorewall/files/shorewall
index f688ee6bc5ff..ca6a562eecf3 100644
--- a/net-firewall/shorewall/files/shorewall
+++ b/net-firewall/shorewall/files/shorewall
@@ -1,9 +1,9 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall,v 1.6 2004/07/14 23:31:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall,v 1.7 2004/11/21 09:59:51 eldad Exp $
-opts="start stop restart"
+opts="start stop restart clear"
depend() {
need net
@@ -28,6 +28,15 @@ restart() {
# here. Note that this comment is required to fix bug 55576;
# runscript.sh greps this script... (09 Jul 2004 agriffis)
ebegin "Restarting firewall"
- /sbin/shorewall restart
+ /sbin/shorewall restart 1>/dev/null
+ eend $?
+}
+
+clear() {
+ # clear will remove all the rules and bring the system to an unfirewalled
+ # state. (21 Nov 2004 eldad)
+
+ ebegin "Clearing all firewall rules and setting policy to ACCEPT"
+ /sbin/shorewall clear
eend $?
}