summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-12 06:08:37 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-12 06:08:37 +0000
commitd372d555bbdd9d34bcc470ea5faf1508afd3dd9c (patch)
tree59d308253e8604c0f4bd0bf9fdcc2b5548eab56f /net-dialup/gnuradius
parentAdded 'suid' flag for gringotts (see bug #69458) (diff)
downloadhistorical-d372d555bbdd9d34bcc470ea5faf1508afd3dd9c.tar.gz
historical-d372d555bbdd9d34bcc470ea5faf1508afd3dd9c.tar.bz2
historical-d372d555bbdd9d34bcc470ea5faf1508afd3dd9c.zip
initial import from #67645
Diffstat (limited to 'net-dialup/gnuradius')
-rw-r--r--net-dialup/gnuradius/ChangeLog8
-rw-r--r--net-dialup/gnuradius/Manifest14
-rw-r--r--net-dialup/gnuradius/files/digest-gnuradius-1.21
-rw-r--r--net-dialup/gnuradius/gnuradius-1.2.ebuild58
-rw-r--r--net-dialup/gnuradius/metadata.xml5
5 files changed, 86 insertions, 0 deletions
diff --git a/net-dialup/gnuradius/ChangeLog b/net-dialup/gnuradius/ChangeLog
new file mode 100644
index 000000000000..a6919836c2ae
--- /dev/null
+++ b/net-dialup/gnuradius/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-dialup/gnuradius
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnuradius/ChangeLog,v 1.1 2004/11/12 06:08:37 mrness Exp $
+
+*gnuradius-1.2 (12 Nov 2004)
+
+ 12 Nov 2004; Alin Nastac <mrness@gentoo.org> +gnuradius-1.2.ebuild:
+ Initial import, thanks to Marcin Jurczuk <spock@stars.eu.org>. Closing #67645.
diff --git a/net-dialup/gnuradius/Manifest b/net-dialup/gnuradius/Manifest
new file mode 100644
index 000000000000..d8b6174d2b07
--- /dev/null
+++ b/net-dialup/gnuradius/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 5e05b54cc35a994f38d6e5b777e595f9 ChangeLog 394
+MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
+MD5 56b98a03ad0f3073187e7ceed8decace gnuradius-1.2.ebuild 1467
+MD5 2ab0db30efa4a96f74d1e4fd3f7cd875 files/digest-gnuradius-1.2 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBlFNyjtv59x0+BrURAiSoAJ9M7s7mDQ/aPRmeCsfhqrnTWMTZSQCgiETk
+KHXy7Y6pYQr6pUW4mR5Pue4=
+=wh2w
+-----END PGP SIGNATURE-----
diff --git a/net-dialup/gnuradius/files/digest-gnuradius-1.2 b/net-dialup/gnuradius/files/digest-gnuradius-1.2
new file mode 100644
index 000000000000..a79587b67cbe
--- /dev/null
+++ b/net-dialup/gnuradius/files/digest-gnuradius-1.2
@@ -0,0 +1 @@
+MD5 41efba1332ff563e1f88f2aba04d9d24 radius-1.2.tar.gz 1784097
diff --git a/net-dialup/gnuradius/gnuradius-1.2.ebuild b/net-dialup/gnuradius/gnuradius-1.2.ebuild
new file mode 100644
index 000000000000..3c1ec489f3c9
--- /dev/null
+++ b/net-dialup/gnuradius/gnuradius-1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/gnuradius/gnuradius-1.2.ebuild,v 1.1 2004/11/12 06:08:37 mrness Exp $
+
+MY_P=radius-${PV}
+DESCRIPTION="GNU radius authentication server"
+HOMEPAGE="http://www.gnu.org/software/radius/radius.html"
+SRC_URI="ftp://ftp.gnu.org/gnu/radius/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="guile mysql postgres odbc dbm nls snmp pam static debug"
+DEPEND="!net-dialup/freeradius
+ guile? ( >=dev-util/guile-1.4 )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
+ readline? ( sys-libs/readline )
+ dbm? ( sys-libs/gdbm )
+ snmp? ( virtual/snmp )
+ pam? ( sys-libs/pam )"
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -i -e "1i\#ifndef RADIUS_H" -e "1i\# define RADIUS_H" include/radius.h
+ echo '#endif //RADIUS_H' >> include/radius.h
+}
+
+src_compile() {
+ local myconf=" \
+ `use_with guile` \
+ `use_with mysql` \
+ `use_with postgres` \
+ `use_with odbc` \
+ `use_with readline` \
+ `use_enable dbm` \
+ `use_enable nls` \
+ `use_enable snmp` \
+ `use_enable pam` \
+ `use_enable debug` \
+ `use_enable static` "
+
+ if useq guile; then
+ myconf="$myconf --with-client --with-server-guile"
+ fi
+
+ econf $myconf || die "configuration failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "installation failed"
+}
diff --git a/net-dialup/gnuradius/metadata.xml b/net-dialup/gnuradius/metadata.xml
new file mode 100644
index 000000000000..1e11e7bbd01b
--- /dev/null
+++ b/net-dialup/gnuradius/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+</pkgmetadata>