summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-04-08 08:44:58 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-04-08 08:44:58 +0000
commite8aeb849b63cb2ec27fe18b719a4187edaa87065 (patch)
tree4bfd636d6d644af503dac44c2468dea8d2fe77aa /net-analyzer
parentInitial import. (diff)
downloadhistorical-e8aeb849b63cb2ec27fe18b719a4187edaa87065.tar.gz
historical-e8aeb849b63cb2ec27fe18b719a4187edaa87065.tar.bz2
historical-e8aeb849b63cb2ec27fe18b719a4187edaa87065.zip
Added ipv6 support. Removed -static from gcc's command line. Added hppa to KEYWORDS. Added the IUSE variable.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netcat/ChangeLog8
-rw-r--r--net-analyzer/netcat/files/digest-netcat-110-r32
-rw-r--r--net-analyzer/netcat/netcat-110-r3.ebuild46
3 files changed, 55 insertions, 1 deletions
diff --git a/net-analyzer/netcat/ChangeLog b/net-analyzer/netcat/ChangeLog
index df48ef1e1f33..21d2234f1397 100644
--- a/net-analyzer/netcat/ChangeLog
+++ b/net-analyzer/netcat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/netcat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.11 2003/02/12 07:48:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.12 2003/04/08 08:44:58 gmsoft Exp $
+
+*netcat-110-r3 (08 Arp 2003)
+
+ 08 Arp 2003; Guy Martin <gmsoft@gentoo.org> netcat-110-r3.ebuild, files/digest-netcat-110-r3 :
+ Added ipv6 support. Removed -static from gcc's command line. Added hppa to KEYWORDS.
+ Added the IUSE variable.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-analyzer/netcat/files/digest-netcat-110-r3 b/net-analyzer/netcat/files/digest-netcat-110-r3
new file mode 100644
index 000000000000..b9d692521dd5
--- /dev/null
+++ b/net-analyzer/netcat/files/digest-netcat-110-r3
@@ -0,0 +1,2 @@
+MD5 402632f2fe01c169ff19a0ad6e9d608c nc110.tgz 75267
+MD5 84d850745dd860aedce64b518e0e3330 nc-v6-20000918.patch.gz 8740
diff --git a/net-analyzer/netcat/netcat-110-r3.ebuild b/net-analyzer/netcat/netcat-110-r3.ebuild
new file mode 100644
index 000000000000..0bbdd279a632
--- /dev/null
+++ b/net-analyzer/netcat/netcat-110-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110-r3.ebuild,v 1.1 2003/04/08 08:44:58 gmsoft Exp $
+
+MY_P=nc${PV}
+S=${WORKDIR}/nc-${PV}
+DESCRIPTION="A network piping program"
+SRC_URI="http://www.l0pht.com/~weld/netcat/${MY_P}.tgz
+ipv6?( ftp://sith.mimuw.edu.pl/pub/users/baggins/IPv6/nc-v6-20000918.patch.gz )"
+HOMEPAGE="http://www.l0pht.com/~weld/netcat"
+
+IUSE="ipv6"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha hppa"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${MY_P}.tgz
+ if [ -n "`use ipv6`" ]; then
+ unpack nc-v6-20000918.patch.gz
+ patch -p1 < nc-v6-20000918.patch
+ fi
+}
+
+src_compile() {
+
+ cp netcat.c netcat.c.orig
+ sed -e "s:#define HAVE_BIND:#undef HAVE_BIND:" \
+ netcat.c.orig > netcat.c
+
+ export XFLAGS="-DLINUX"
+ [ -n "`use ipv6`" ] && XFLAGS="${XFLAGS} -DINET6"
+ CC="gcc ${CFLAGS}" make -e nc || die
+}
+
+src_install () {
+ dobin nc
+ dodoc README
+ docinto scripts
+ dodoc scripts/*
+}